Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4868 Discussions

Intel I225-V Drops Connections!

berkkocaturk
New Contributor I
5,470 Views

I used to have realtek 2.5gbit lan without any issue on my home network but recently made a misteke of upgrading to intel 12th gen with MSI PRO Z690-A DDR4 with intel I225-V

I constantly have network problems.

It works sometimes but then connection is slow or it just drops and comes back but twice the connection dropped and even with me uninstalling and reinstalling drivers and on the device manager didnt solve the issue after a fresh install of windows and installing the driver again it worked for some time but randomly it stopped working and reinstalling drivers and replacing it didnt work

I have tested both msi latest driver and intel latest 28.0 driver.

I have read online that I225-V has problems and i am experiencing all of them!

 

I left my pc pinging my router for 8 hours and looked at it and it sometimes did not get a response

It is slower than realtek 2.5gbit when t works but it also doesnt work most of the time

 

On my second fresh install it stopped working again and i have restarted the system uninstalled and  installed drivers again which didnt work then I have read on forums to disable fastboot and restarted and I have connection right now but this is the worst experience I have with ethernet rigt now.

 

After a day connection  dropped again i do not have internet

 

What is wrong with this?

0 Kudos
12 Replies
Frank772
Beginner
5,437 Views

I have a very similar problem, except it just doesn't work.  I've abandoned the Ethernet connection and am using a Thunderbolt 4 to Ethernet adapter.  It runs at about 1.0 Gb.  I'm following to see if you can get a fix.

0 Kudos
Frank772
Beginner
5,415 Views

Berkkocaturk,

I had a thread on the NUC community about this problem.  The Intel Tech I was talking with feels the problem was most likely my AT&T Gateway, but since I was able to connect with an adapter, not running an Intel Controller, I wasn't sure that is a correct solution.  During my attempt to find a solution, I saw that the I225 controller is on a lot of motherboards from various manufacturers that had a similar problem.  Most of these manufacturers had a fix of one sort or another involving Bios and Controller software updates.  I not sure if MSI is one of them.   It's probably worth a try.  I just wish I could get a fix from Intel.

Good luck,

Frank772

 

0 Kudos
berkkocaturk
New Contributor I
5,426 Views

I left it overnight and connection dropped again.

0 Kudos
B_Y
Employee
5,392 Views

Hello Berk Kocatürk, 

 

Thank you for posting in Intel Ethernet Communities. We have received your request under case #05812408. We are sorry for the inconvenience this issue has caused you.

An Intel I225-V was distributed to OEM/vendor to have own build, configuration and settings. Understand from this thread that you have upgraded from realtek 2.5gbit lan to intel I225-V, may I know if it is purchased together with MSI PRO Z690-A and not as separate NIC?

 

I have escalated the SSU information back to our engineering to check.

Meanwhile, here are a few troubleshooting steps you can try and remember to test your LAN network connection before proceeding to next step:

1) If you may be needing to re-install your drivers :we would advise to do first a clean state driver then you can also firstly try using MSI LAN driver (version: 26.2.0.1) , then our drivers. 

Please use the links below as reference;

Clean Driver Installation Guide for Intel® Ethernet Connections

https://www.intel.com/content/www/us/en/support/articles/000058304/ethernet-products.html

 

Then download this Intel complete Driver Pack and install. Update driver through the device manager:

https://www.intel.com/content/www/us/en/download/15084/intel-ethernet-adapter-complete-driver-pack.html?wapkw=I225-V

a. Unzip the file "Release_28.0.zip"

b. Open Device Manager, Double-click Network adapter: Intel Ethernet Connection I225-V, Click on the "Driver" tab and Click <Update Driver>

c. Select <Browse my computer for drivers> and Browse the driver from the location you have unzipped "Release_28.0.zip" > PRO2500 > Winx64 and choose NDIS68 (for Win10)

 

2) You can also try to disable or change the values for mentioned property with the following steps:

a. Open Device Manager.

b. Double-click Network adapter: Intel Ethernet Connection I225-V

c. Click on the "Advanced" tab, change values for following property-

- Energy Efficient Ethernet (EEE) to "Off"

- Ultra Low Power Mode to "Disabled"

- Large Send Offload V2 (IPv4) to "Disabled"

- Large Send Offload V2 (IPv6) to "Disabled"

- TCP Checksum Offload (IPv4) to "Tx Enabled"

- TCP Checksum Offload (IPv6) to "Tx Enabled"

 

3) If issue still persist - please try to reboot into safe mode with networking and let us know the result of LAN connection:

The steps: https://www.msi.com/support/technical_details/DT_Boot_OS_Entry

 

4) If your initial effort to fresh install/reload the Win 10 home and have ensure proper clean partition, install only critical windows update and immediately pause the windows update to see if see if the issue reoccurred. Windows defender or patches update may interfere or change the behaviour of driver and registry.

 

5) Kindly double check on link speed and share if you're system is connected properly to .

On Network and Internet Settings; View your Network Properties and scroll down to Link speed (Receive/Transmit).

 

The following external thread is for your reference which has some similarity in some areas:

https://forum-en.msi.com/index.php?threads/msi-pro-z690-a-wifi-ddr4-and-intel-i225-v-lan.370128/

 

We'll be waiting for your response.

 

Best regards,

BY_Intel

Intel Customer Support

 

0 Kudos
berkkocaturk
New Contributor I
5,311 Views

I have already tried everything you mentioned at step 1 ,

 

I will try the rest.

0 Kudos
Feejus
New Contributor III
1,204 Views

While the recommendation provided above is valuable, it requires an additional adjustment related to Power Saving mode.

In Windows, it's crucial to disable Power Saving mode for PCI devices. You can access this setting by navigating to "Power Options" and then "Advanced Settings." Within these settings, locate "PCI Express" and then "Link State Power Management," ensuring that the setting is set to "Off." This adjustment is essential for optimal performance and stability.

 

 

0 Kudos
B_Y
Employee
5,366 Views

Hello Berk Kocatürk,

Please also ensure that from (2):

2) You can also try to disable or change the values for mentioned property with the following steps:

a. Open Device Manager.

b. Double-click Network adapter: Intel Ethernet Connection I225-V

c. Click on the "Advanced" tab, change values for following property-

- Speed & duplex to "Auto negotiation"


And this settings, should be apply on your switch or router after ensuring all connected devices have latest drivers:

- Energy Efficient Ethernet (EEE) to "Off"

- Speed & duplex to "Auto negotiation"


Best regards,

BY_Intel

Intel Customer Support


0 Kudos
B_Y
Employee
3,993 Views

Hello Berk Kocatürk,


I hope this message finds you well. I am just sending a follow up if you have any questions from the previous post. If so, please let us know. In case we do not hear from you, I will make a follow up on April 21st 2023 . Thank you.


Best regards,

BY_Intel

Intel Customer Support


0 Kudos
berkkocaturk
New Contributor I
3,986 Views

I was away from desktop pc. I will test it and write results if there are any issues.

0 Kudos
B_Y
Employee
3,934 Views

Hello Berk Kocatürk,


Good day and I hope everything is great!

This is just a follow up regarding the issue of your reported with us.

If you have additional questions, clarifications or result from testing, feel free to let us know.

In case we do not hear from you, I will make a follow up on April 26th 2023 . Thank you.


Best regards,

BY_Intel

Intel Customer Support


0 Kudos
berkkocaturk
New Contributor I
3,923 Views

I did not have issues for couple days now unfortunatly I am on a voyage and wont be using my desktop for some time

0 Kudos
B_Y
Employee
3,923 Views

Hello Berk Kocatürk,


Thank you for the update. Glad to hear its working for you now.

Please be informed that we will now close this request. Just feel free to post a new question if you may have similar or any other inquiry in the future as this thread will no longer be monitored.

Bon Voyage and Safe Travels. May you have a great holidays!


Best regards,

BY_Intel

Intel Customer Support


0 Kudos
Reply