Ethernet Products
Intel® Ethernet products and technologies
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
4171 Discussions

Intel I225-V disconnecting in Windows 11

karlmayer
Beginner
5,004 Views

I have an Asus Prime Z490-A motherboard with Intel Core i9-10850K & latest BIOS 2403 on Windows 11 build 22000.593 that has intermittent I225-V disconnections.

The documented fix addressed early I225-V disconnection issues for a long period of time on Windows 10 & 11: Network Issues with Intel® Ethernet Controller I225-V. However, the issue has returned in January, across multiple versions of the I225-V drivers including 1.0.1.4 (signed by Intel), 1.0.2.8 (signed by Microsoft) & 2.1.1.7 (signed by Intel). On a side note, the support article should be updated to describe what to expect with drivers newer than 1.0.1.4.

Changing the driver via Device Manager immediately to any of these immediately resolves the disconnect.

I have Energy Efficient Ethernet disabled and Speed & Duplex set to 1Gbps Full Duplex.

0 Kudos
13 Replies
Zigfreid_Intel
Moderator
4,982 Views

Hello karlmayer,


Thank you for posting on Intel Ethernet Communities. 


We would like to clarify as to what would be your exact concern for your I225-V controller? Are you still having any issues? please do advise.


We do apologize if our support article has not yet been updated since there are several updates on our drivers and we thank you for raising it. 


We'd also like to set your expectations for Original Equipment Manufacturer(OEM) Ethernet controller, we have a limited support and it would be best if you can also get in touch with the manufacturer for further support since they have customized drivers, firmware and software to enable or alter features on your card. They are in best position where you can seek assistance so you don’t lose features or customizations of the Ethernet controller. But don't worry as we will still provide our best effort support to help you resolve the issue. 


If you have questions or other clarifications please let us know so we can help you further


Awaiting to hear from you soon, should there be no response from you, I’ll make sure to reach out after 3 business days. Thank you and have a nice day!



Best regards,

Zigfreid I.

Intel® Customer Support


karlmayer
Beginner
4,941 Views

My exact concern is that the I225-V driver is randomly failing/disconnecting.  Thus far, 2.1.1.7 appears to be the most stable, but even it still randomly disconnects, and occasionally it does not reconnect until I change the driver using Device Manager.  disconnect 2.png

Zigfreid_Intel
Moderator
4,917 Views

Hello karlmayer,


Thank you very much for advising and for providing us an update. We will have this check first before we provide you our recommendations. Please provide us some time for this, is it okay if we can provide you an update between 2-3 business days? If you have a preferred date please advise us instead. Thank you and have a nice day!



Best regards,

Zigfreid I.

Intel® Customer Support


karlmayer
Beginner
4,885 Views

Apart from not using I225-V ethernet port, all I can do is wait. There are others with this issue as well: Z690 Hero i225-V LAN randomly dropping connection for ~10 seconds with latest (v1.0.2.14) driver : i... , even with driver 1.0.1.4 (the first version of the driver that addressed this issue).

Zigfreid_Intel
Moderator
4,861 Views

Hello karlmayer,


We will have this check first before we can provide you our recommendations. Please provide us some time to have this check, we will provide an update between 2-3 business days. Thank you for understanding and have a nice day!


Best regards,

Zigfreid I.

Intel® Customer Support


Zigfreid_Intel
Moderator
4,833 Views

Hello karlmayer,


What we would recommend is to first try to do a clean driver installation and reinstall our driver version 27.2. 


Please refer to our;


Clean Driver Installation Guide for Intel® Ethernet Connections

https://www.intel.com/content/www/us/en/support/articles/000058304/ethernet-products.html


Intel® Ethernet Adapter Complete Driver Pack

https://www.intel.com/content/www/us/en/download/15084/intel-ethernet-adapter-complete-driver-pack.h...


If this does not work, please provide us your SSU logs so that we can check on your system.


Please follow the steps below to generate your SSU:

1. Download the Intel® System Support Utility and save the application to your system.

*Windows

https://www.intel.com/content/www/us/en/download/18377/intel-system-support-utility-for-windows.html


*Linux 

https://www.intel.com/content/www/us/en/download/18895/intel-system-support-utility-for-the-linux-op...


2. Open the application and click Scan to see system and device information. The Intel® System Support Utility defaults to the Summary View on the output screen following the scan. Click the menu where it says summary to change to Detailed View.

3. To save your scan, click Next and click Save. You can save the file to any accessible location on your computer.


Note: Please put a tick on "Everything" when scanning the log

4. You can attach the logs in the thread.


Since you are using an embedded ethernet controller we can only provide you our best effort on this. Your board manufacturer should still be the best source of support.


If you have questions or other clarifications please let us know so we can help you further


Awaiting to hear from you soon, should there be no response from you, I’ll make sure to reach out after 3 business days. Thank you and have a nice day!



Best regards,

Zigfreid I.

Intel® Customer Support





Zigfreid_Intel
Moderator
4,756 Views

Hello karlmayer,


Good day! We hope that you are having a great one so far.


We'd like to know if you have done our recommendations and if the issue is still persistent. Also if you have any other questions or clarifications please let us know so we would know if we can close the thread.


Hoping to hear from you soon.


We will wait for your reply within 3 business days in case we don't hear from you, we will proceed closing this request.


Best regards,

Zigfreid I.

Intel® Customer Support


Zigfreid_Intel
Moderator
4,720 Views

Hello karlmayer,


Good day! We hope that you are having a great one so far.


Please be informed that we will now close this request since we haven't received any response from our previous follow ups. Just feel free to post a new question if you have any other inquiry in the future as this thread will no longer be monitored.


Best regards,

Zigfreid I.

Intel® Customer Support


karlmayer
Beginner
4,687 Views

I've had a long period of stability.

I cleaned up the Intel drivers (except the Microsoft Intel driver that comes with Windows 11) and installed just Intel Ethernet Controller I225-V 2.1.1.7 dated 2/2/2022. No disconnects that I noticed or Event Viewer so far. I hope Intel updates knowledge base article to reflect the latest versions: Network Issues with Intel® Ethernet Controller I225-V

Zigfreid_Intel
Moderator
4,666 Views

Hello karlmayer,


Thank you very much for responding and advising. We will take note on your comment on our supported article "Network Issues with Intel® Ethernet Controller I225-V" however this is more focused on Windows 10. We would also like to check if you have other concerns or questions so we would know if we can already close the thread, please advise us. 


Awaiting to hear from you soon, should there be no response from you, I’ll make sure to reach out after 3 business days. Thank you and have a nice day!



Best regards,

Zigfreid I.

Intel® Customer Support



Zigfreid_Intel
Moderator
4,617 Views

Hello karlmayer,


Good day! We hope that you are having a great one so far.


We would also like to check if you have other concerns or questions so we would know if we can already close the thread, please advise us. 


Hoping to hear from you soon.


We will wait for your reply within 3 business days in case we don't hear from you, we will proceed closing this request.


Best regards,

Zigfreid I.

Intel® Customer Support


Crisselle_Intel
Moderator
4,538 Views

Hello karlmayer,


I hope you are doing great!


Please be informed that we will now close this request since we haven't received any response from our previous follow ups. Just feel free to post a new question if you may have any other inquiry in the future as this thread will no longer be monitored.


Thank you for choosing Intel and stay safe!


Best regards,

Crisselle C.

Intel® Customer Support


Texas_Gore
Beginner
1,112 Views

I found this thread after searching for a while and pulling out a lot of hair.

I've been having severe and randomly occurring connection issues with my Intel I225-v (3) on-motherboard controller:
   - connection dropping repeatedly

 

  OR

   - connection reduces speed to 100Mbit (should be 2.5Gbit)

These are "fixed" temporarily by either 1. reboot or 2. disable and re-enable the controller via device manager.

There is no pattern or root cause that I can fathom. It's driving me nuts. It can happen at any time of day, a few minutes or a few hours after a cold boot, or minutes or hours after waking the PC from sleep, after heavy internet traffic or almost no traffic.


The I225-v (3) is on-board my Asus RoG Strix B650E E-Gaming WiFi motherboard. Windows 11 Pro build 22621.963 (previous builds also had the same problems)

Having read around some threads and articles, none of the solutions I've found work.
These include, but are not limited to

   - using the earliest (only) driver available on the motherboard web page for I225-v (3): 1.1.3.28 (clean driver install)

   - using every driver I can find up to and including: 2.1.2.3 (clean driver installs every time)

   - trying to use driver 1.0.1.4 (it doesn't install (and so I am unwilling to try to update the firmware that comes with 1.0.1.4 as recommended in another thread. There is no NVMUpdatePackage matching I225-v (3), the closest is I210, as of Intel Ethernet Driver Pack 27.8))

   - adjusting Transmit and Receive Buffers (along with almost every other setting in the Advanced tab)

   - using different CAT6A cables to connect to my router (tried different ports on the router, too)

 

Any help greatly appreciated.

Kind regards,

TG

 

 

 

 

 

Reply