Ethernet Products
Intel® Ethernet products and technologies
4018 Discussions

Intel i350 & FreeBSD 9

Community Manager

Hi guys,

I am having a problem with the igb driver on FreeBSD


We have two Dell R720 servers with the Intel i350 QP adapter.

We are need three connections.

1. Connection to external switch

2. Connection to internal switch

3. Connections to the other server via crossover cable

Connection 1 and 2 are working fine and remain consistent and are connected to a Cisco switch.

But connection three keeps dropping out and when we try bring it back online it doesn't respond.

We have restarted the networking on both servers and the connection will come back for about 10 minutes then drop again. This is also the case if we restart the servers.

We have tried a straight through cable instead of the crossover with the same effect.

I have contacted Dell and they said they cannot help because Intel develop the driver for FreeBSD and i should contact them, but when i contact Intel they tell me they only support Intel boxed products.

Anyone got any ideas?

0 Kudos
4 Replies

Have you tried the latest driver?


Your connections that go to the switch are working, so this seems related to running the back-to-back connection. You said that you tried both straight-through and a crossover cables. How about trying a longer cable? Have you tried throwing in a switch in between the two connections to narrow things down to confirm whether the issue might be caused by the back-to-back connection or not?

I noticed this issue listed in the readme:

Detected Tx Unit Hang in Quad Port Adapters


In some cases ports 3 and 4 won't pass traffic. Ports 1 and 2 don't show

any errors and will pass traffic.

This issue MAY be resolved by updating to the latest BIOS. You can

check your system's BIOS by downloading the Linux Firmware Developer Kit

that can be obtained at

So making sure you have the latest BIOS updates (if any) is worthwhile.

If none of the above helps, try sending an email with details about your issue to

Mark H

Community Manager

Hi Mark,

We have not tried the latest driver yet as this would require recompiling the kernel.

We have tried a variety of cable and lengths with no joy.

We have just tried plugging the fourth interface igb3 into a switch and VLANing them off and the connection remains with no drops. So it looks like the problem is the direct connection between the two NICs.

We are running the latest firmware(BIOS) for the NICs.

Community Manager

Also i have emailed and had no reply.

Community Manager

Try adding this in the /boot/loader.conf




Then reboot.

I've had similar dropout issues with igb interfaces and this fixed it.