Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4529 Discussions

NIC Teaming Missing Tab


I know there are some similar discuss have been created in this community.

However, I can not find any solution for my case from former posts.

Here is the situation:

Operating system: windows 2003 R2 SP2

NIC-1: Intel PRO/1000 PT server adapter (External)

NIC-2: Intel 82575EB Gigabit network adapter (Onboard)

Proset version:

(Yes, the latest version is 16.3, but because all other servers are running 16.1 and have been working pretty well, so customer decided to keep using 16.1.)

I create the teaming on Monday night, and made some test, everything worked just fine, the teaming tab, advanced tab... they were right there as usual.

But the next day morning, I was told that the teaming tab, advanced tab were all missing.

All I can see are only 2 tabs there in the properties windows, "General" and "Driver"

I search throught this community, I've tried these solutions:

1. restart WMI service

2. Change the identity of DCOM "NCS2Prov", from "Interactive User" to "Launching User"

Neither of them worked for my case. But they give me some... inspiration (not sure)...,

when I open the properties window of Teaming, it should request to WMI to fetch the info, then WMI call "NCS2Prov".

If the tab is missing, that means there may be something wrong between them.

Then, I create a VBscript to query Teaming Name from WMI, it return the error code "0x80041001", means "Call Failure"

Then I run "Wbemtest.exe", and connect to Namespace "\root\IntelNCS2", execute query "Select * from IANet_LogicalEthernetAdapter"

The result turns out like this:

instance of IANet_ExtendedStatus




ClientSetHandle = 0;


Description = "";


File = ".\\Src\\WomClassRouterHelper.cpp";


Line = 289;


Operation = "CreateInstanceEnumAsync";


ParameterInfo = "AddCimImplementorListToMap";


ProviderName = "NCS2 IMP";


RuleFailureReasons = {};


StatusCode = 2147748106;



(StatusCode = 2147748106 = 0x8004090A)

I find the description of this error code from PDF white paper, "Intel PROSet For Windows* Device Manager WMI Provider User"s Guide"

0x8004090A "WMI: Class not implemented by this provider"

Now, I cannot go further, can anybody tell me what it means? or what can I do?

Any idea will be appreciated.

0 Kudos
0 Replies