Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
4848 Discussions

PROSET 28.0 cmdlet error on W10 LTSC 1809

mfg
Beginner
959 Views

On W10 LTSC 1809 I've installed latest driver and Proset package (28.0) to add a VLAN tag to ethernet adapter

I've 2 network card (SSU detail attached):

- "Intel(R) I210 Gigabit Network Connection"

- "Intel(R) Ethernet Connection I219-LM"

 

I tried Get-IntelNetAdapter and Add-IntelNetVLAN powershell cmdlets.

Both fail with "Provider load failure" error.

 

I tried downgrading to the oldest available package (22.10) but the problem is the same.

 

In another pc identical to this one cmdlets seems to work (i tried Get-IntelNetAdapter only)

It has ProSet 20.4.308.0 version installed, but this is version is not longer available

 

Could you please help.

0 Kudos
7 Replies
B_Y
Employee
934 Views

Hi @mfg ,

 

Thank you for posting in Intel Ethernet Communities.

In order to better assist you, we recommend for you to provide below information:

1. May I know if the issue existed before the installation / upgrade to Intel Proset package (28.0)? Can I know the steps and source/link you got for the Intel Proset package (28.0)?

2. May I know if you are using Intel server board or other OEM motherboard/system configuration.

3. Have you try to clean uninstall the Intel® PROSet Software and reinstall with older version driver?

 

Best regards,

BY_Intel

Intel® Customer Support 

 

0 Kudos
mfg
Beginner
905 Views

1. May I know if the issue existed before the installation / upgrade to Intel Proset package (28.0)? Can I know the steps and source/link you got for the Intel Proset package (28.0)?

Proset was not installed before. I've installed it to configure VLAN tagging

I've downloaded it from intel website by searching for "Intel(R) I210 Gigabit Network Connection driver"

Landing page: https://www.intel.it/content/www/it/it/download/18293/intel-network-adapter-driver-for-windows-10.html

Download link: https://downloadmirror.intel.com/772070/Wired_driver_28.0_x64.zip

 


2. May I know if you are using Intel server board or other OEM motherboard/system configuration.

It' an industrial oem system CINCOZE DS-1100

 


3. Have you try to clean uninstall the Intel® PROSet Software and reinstall with older version driver?

Yes, installation of 22.10 version was made after disinstalling 28.0 from "Program and features" uninstall shortcut

0 Kudos
mfg
Beginner
905 Views

Hi B_Y,

thanks for reply

 

>>1. May I know if the issue existed before the installation / upgrade to Intel Proset package (28.0)? Can I know the steps and source/link you got for the Intel Proset package (28.0)?

Proset was not installed before. I've installed it to configure VLAN tagging

I've downloaded it from intel website by searching for "Intel(R) I210 Gigabit Network Connection driver"

landing page: https://www.intel.it/content/www/it/it/download/18293/intel-network-adapter-driver-for-windows-10.html

download link: https://downloadmirror.intel.com/772070/Wired_driver_28.0_x64.zip

 

>>2. May I know if you are using Intel server board or other OEM motherboard/system configuration.

it is an OEM embedded system CINCOZE DS-1100

From the manufacturer's website I fetched the installer for ProSet 20.4.308.0

cmdlets Get-IntelNetAdapter works, but this version does not support Add-IntelNetVLAN on Windows 10

 

>>3. Have you try to clean uninstall the Intel® PROSet Software and reinstall with older version driver?

Yes, all installations were made after disinstalling previous installed package from "Program and features" uninstall shortcut

0 Kudos
B_Y
Employee
757 Views

Hi @mfg ,

 

Thank you for your patience.

Proset is not supported for Ethernet model: I219-LM

On the other hand, the cmdlets need to be imported before they will work on I210. The e-doc: “Adapters and Devices User Guide” below will describe how the Powershell cmdlets may incorporate according to your needs.

It is at Section 3.5.1, page: 21.

https://cdrdv2-public.intel.com/705831/Adapter_User_Guide.pdf

 

May I ask if other cmdlet/s is working, other than these 2 cmdlets: "Get-IntelNetAdapter and Add-IntelNetVLAN" that you have tested?

Looking forward to hearing from you. Thank you.

 

Best regards,

BY_Intel

Intel® Customer Support

 

0 Kudos
B_Y
Employee
698 Views

Hi @mfg ,

 

I hope this message finds you well. I am just sending a follow up if you have any questions from the previous post. If so, please let us know.

Thank you.

 

Best regards,

BY_Intel

Intel® Customer Support


0 Kudos
mfg
Beginner
689 Views

in previous tests the import-module command was always used according to manual.

I haven't tried other cmdlets than "Get-IntelNetAdapter and Add-IntelNetVLAN"

Now I can't devote any more time to this problem.

I solved my use case by adding a managed switch near the user.

It is an increase in costs and in the complexity of the installation, but that's the way it is

Thanks anyway for your attempt to help me

Bye

0 Kudos
B_Y
Employee
686 Views

Hi @mfg ,

 

Thank you for the feedback and glad it is resolved. Please be informed that we will now close this request since you have found the solution. Just feel free to post a new question if you may have any other inquiry in the future as this thread will no longer be monitored.

Thank you.

 

Best regards,

BY_Intel

Intel® Customer Support


0 Kudos
Reply