Community
cancel
Showing results for 
Search instead for 
Did you mean: 
APetz
Beginner
2,045 Views

Unable to activate teaming in Windows 10

Hi,

I created an nic teaming 802.3ad using i219 onboard + i210 PCIe NICs but I'm not able to activate the connection.

When I click on "Activate" in the context menu a popup "Activating..." appears but the connection stays inactive.

Intel Ethernet Driver 22.6 running Windows 10 1703 Build 15063.540

LAG is configured on my Netgear GS724Tv4 switch and works with a Windows Server 2016 machine.

Any idea how to set the team to "Active"?

Greetings from Munich, Germany!

Tags (1)
0 Kudos
10 Replies
idata
Community Manager
326 Views

Hi Troubadix,

 

 

Thank you for posting at Wired Communities. I will have to check on this, just to double check what is the network adapter teamed on your Windows server 2016?

 

 

Thanks,

 

sharon

 

idata
Community Manager
326 Views

Hi Troubadix,

 

 

You may refer to the steps below for the configuration:

 

 

1. Install the ANS driver

 

https://downloadcenter.intel.com/download/25016/Intel-Network-Adapter-Driver-for-Windows-10?product=...

 

 

2. On the switch do the following:

 

a. Create LAG group

 

b. Assign ports to LAG group

 

c. select static link aggregation

 

d. Disable STP

 

 

3. Create static link aggregation team in ANS on the NIC

 

4. Plug the cable to connect the NIC ports to the switch, please check the status shows as "active" in team properties window and "enabled" in network connection windows

 

5. Reboot your system

 

 

Feel free to update me.

 

 

Regards,

 

sharon

 

APetz
Beginner
326 Views

Hi Sharon,

the server uses two i210 NICs but they are teamed using the Server Manager from Windows Server 2016. Everything works great!

The computer with the problem (can't activate the teamed connection) runs Windows 10 1703 x64

Your guide is nearly what I did except that I want to use dynamic LAG, not the static one. The driver you mentioned is already installed.

APetz
Beginner
326 Views

Ok, I tried the static LAG but the connection still remains inactive.

APetz
Beginner
326 Views

No chance to enable in the command line ;(

idata
Community Manager
326 Views

Hi Troubadix,

 

 

Thank you for the additional information. Please make sure STP mode in the switch should be disable. Based on the screenshot on lag3.JPG (correct me if I am wrong), the STP mode is enable. Can you help double check? Thanks.

 

 

Regards,

 

sharon

 

APetz
Beginner
326 Views

Hi Sharon,

I changed the STP mode to disabled but still not able to activate the connection.

I tried to delete and recreate the team but still the same.

Are there any logfiles I can provide you? Where can I find them?

idata
Community Manager
326 Views

Hi Troubadix,

 

 

Thank you for the information. I will try further check. For the meantime, can you try using driver version 22.4 https://downloadcenter.intel.com/download/27092/Intel-Network-Adapter-Driver-for-Windows-10

 

 

Please feel free to update me.

 

 

Thanks,

 

sharon

 

 

 

 

 

 

 

 

 

APetz
Beginner
326 Views

Hi Sharon,

I installed 22.4 driver and the LAG is working now

(even with STP mode active)

So there must be a bug in the 22.6 driver.

If there is a way to help you with debug logs or if I should test a beta version please let me know.

Thank you for your support!

idata
Community Manager
326 Views

Hi Troubadix,

 

 

Thank you so much for the update and glad the issue is fixed. I will bring this matter to our engineer's attention. Again, thank you for your time on this matter.

 

 

Regards,

 

sharon