Ethernet Products
Intel® Ethernet products and technologies
3890 Discussions

Windows 10 Advanced tab language

nm987
Beginner
4,717 Views

This is the issue which I have on 2 PCs with 3 different Intel NICs. Just to make clear what am I talking about I will post this Intel link with a screenshot of affected tab:

https://www.intel.com/content/www/us/en/support/articles/000005593/network-and-i-o/ethernet-products...

Now let's get to the issue. Both PCs have English as display language, but Japan is set as a region. As a result all advanced settings are garbled and can't set them up without tons of guesswork. The same settings are garbled in PROSet Adapter configuration utility as well.

Question is how to change those settings to be displayed in English? Answers like "change your region setting" are unacceptable because changing it will break other company specific software on both PCs.

Driver package:  Intel® Network Adapter Driver for Windows® 10 25.6

Affected NICs: X520-2, I219V, X540-T1

0 Kudos
1 Solution
AlfredoS_Intel
Moderator
2,482 Views

Hi Nm987,

Thank you for waiting for our update.

We just received an update from engineering that after a series of validations, the issue that you are experiencing is an expected behavior based on the way Windows handles localization. For more information, please check the link. 

https://docs.microsoft.com/en-us/windows-hardware/drivers/install/inf-strings-section

 

Since re-installing Windows would be tedious for you, our Engineering tea, provided a workaround by running "sysprep.exe /oobe" and selecting English during the install wizard — worked. You need to uninstall/delete and then reinstall the driver afterwards. This could be a shorter workaround for the than a full Windows reinstall.

Furthermore, based on the findings above, this is not driver related. It is how Windows handles localization. You may also check or contact Microsoft for more information.

We look forward to your reply or assessment of the answer above. Should we not get your reply, we will follow up after three business days.



Best Regards,

Alfred S

Intel® Customer Support


View solution in original post

36 Replies
AlfredoS_Intel
Moderator
3,206 Views

Hi Nm987,

Thank you for posting in our Intel® Ethernet Communities Page.

We are sorry to hear about the issue that you are experiencing with your network adapter. 

To better assist you, we need to get some logs from your system. It will tell us the different driver version and components installed on your system. Please download and run our Intel® System Support Utility from this page, https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-. After running it, you will be given an option to save the logs to a text file, please do so and attach the file on your reply.

We look forward to hearing from you. If we do not get your reply, we will follow up after 3 business days.



Best Regards,

Alfred S

Intel® Customer Support



Best Regards,

Alfred S

Intel Customer Support


nm987
Beginner
3,201 Views

Hi Alfredo,

here is the requested file.


Cheers

AlfredoS_Intel
Moderator
3,182 Views

Hi Nm987,

Thank you providing those logs.

To help us in checking this, may we ask, do you only experience this issue on the Advanced Settings of the network driver or does it also happen on other drivers or other applications?

We look forward to hearing from you. If we do not get your reply, we will follow up after 3 business days.


Best Regards,

Alfred S

Intel® Customer Support 


nm987
Beginner
3,169 Views

Hi Alfred,

I installed Mellanox NIC and there are no issues with option display there. Only Intel NICs are affected.

 

Kind regards

AlfredoS_Intel
Moderator
3,164 Views

Hi Nm987,

Thank you for your response.

We took note that you would not consider a fix involving changing language settings. Although, we would like to ask if you are okay to test this one: https://www.gonnalearn.com/windows-10-uses-two-display-languages/

Just try to put a check on “Welcome Screen and system accounts”; if it works, please try to remove the check again and see if it the language setting stays.

We look forward to your reply if the suggestions worked. Should we not get your reply, we will follow up after three business days.


Best Regards,

Alfred S

Intel® Customer Support


nm987
Beginner
3,158 Views

Hi Alfredo,

I tried what you've suggested, but it didn't fix the issue. It seems that that solution only works for native Windows components, not 3rd party components like Intel drivers.

Mike_Intel
Moderator
3,137 Views

Hi Nm987,


Thank you for for the update.


Did you try to reboot the system or perform a power cycle after changing the settings to make sure that the old settings is not the cache anymore?


We look forward to your reply if the suggestions worked. Should we not get your reply, we will follow up after three business days.


Best regards,

Michael L.

Intel® Customer Support


nm987
Beginner
3,129 Views

Hi Michael,

one of the affected PCs was rebooted at lease dozen times since I raised this question. Also I shut down that PC every day so full power cycle doesn't help as well.

AlfredoS_Intel
Moderator
3,125 Views

Hi Nm987,

Thank you for your response.

We know that this maybe too much, however, we thought that there maybe a possibility that it could fix the issue — please uninstall the drivers and change the setting that we have provided; see if it works this time.

If you find it tedious to do this, please let us know so we will just proceed to investigate the issue.  


We look forward to your reply. Should we not get your reply, we will follow up after three business days.


Best Regards,

Alfred S

Intel® Customer Support


nm987
Beginner
3,118 Views

Hi Alfredo,

I uninstalled Intel Network connections software, uninstalled drivers with the option to delete driver software, X540-T1 appeared as an unknown device in device manager, then I double checked that the language settings are correct (link you've provided), reinstalled driver software again and nothing changed. The issue still remains the same.

I am using 64bit drivers from the following link:
https://downloadcenter.intel.com/download/25016/Ethernet-Intel-Network-Adapter-Driver-for-Windows-10

AlfredoS_Intel
Moderator
3,111 Views

Hi Nm987,

We appreciate your cooperation for carrying out our suggestion.

Please allow us some time to check on other options on how to fix your concern.

We will get back to you no later than 3 business days from now.



Best Regards,

Alfred S

Intel® Customer Support


AlfredoS_Intel
Moderator
3,107 Views

Hi Nm987,

Thank you for waiting for our update.

We started our preliminary investigation on your concern, and while doing so we would like to confirm if you have already tried a clean installation of the drivers, as listed on this page, https://www.intel.com/content/www/us/en/support/articles/000022173/wireless.html.

Please ignore that the steps are  for our wireless drivers. It is applicable also to our wired networking products.

We look forward to your reply so we can continue to further check on your concern. Should we not get your reply, we will follow up after three business days.



Best Regards,

Alfred S

Intel® Customer Support


nm987
Beginner
3,092 Views

Hi Alfred,

that is exactly how I uninstalled the drivers when instructed to do so.

Speaking about other Intel drivers it seems that same principle applies here as well. I would say that they are trying to be "smart" and they decide what user "needs". In this case drivers probably determined that I "want" advanced settings in Japanese and because of the character encoding issues the text cannot be displayed properly.

On the same PC I have Intel Graphics driver which also decided that I "need" all settings in Japanese. 

On that note software with multilanguage support should suggest what language user might need, not to decide for the users. Users should decide that for themselves. 

AlfredoS_Intel
Moderator
3,087 Views

Hi Nm987,

Thank you for providing that information and for adding your insights on the possible cause of the concern.

What we are looking for at the moment, is if there are switches that you can use to install the software and bypass the region.  

We will continue checking this and the information that provided is invaluable to us.

Please allow us some time to check on this. We hope for your understanding regarding this

We will get back to you no later than 3 business days from now.



Best Regards,

Alfred S

Intel® Customer Support


AlfredoS_Intel
Moderator
3,063 Views

Hi Nm987,

Thank you for waiting for our update.

While we were investigating your concern, these questions came to mind which will help us find a recommendation for your issue:

1. Was the issue happening since you first integrated the discrete ethernet adapters on the machine?

2. When did the issue start happening?

3. May we also know how do you install the network software so we can picture the process and create a suggestion from there?

We look forward to your reply. Should we not get your reply, we will follow up after three business days.



Best Regards,

Alfred S

Intel® Customer Support Technician


nm987
Beginner
3,055 Views

Hi Alfred,

1. I have two PCs, one with integrated Intel NIC (Dell OEM) and one with NIC from the other vendor. The one with integrated NIC had the issue since the day one when I put a brand new PC out of the box.

2. Intel X520-2 and X540-T1 required additional drivers from Intel. After installing them the issue happened. Once again, there was no period of time when advanced settings were displayed correctly.

3. I tried running installer, unpacking it and manually install drivers and the result is the same.

 

I believe it is obvious that no matter how I install them I will get the same result. Unless there is some registry tweak or similar OS tweak which will force Intel NIC drivers and those drivers only without affecting other system settings to use English display instead of (trying) displaying Japanese I believe that we will go in endless circles with this kind of Q/A without addressing the issue.

 

AlfredoS_Intel
Moderator
2,920 Views

Hi Nm987,

We appreciate your cooperation in providing that information.

We are deeply sorry about what you felt when we asked the questions. Rest assured, all of our questions are part of our investigation and like you our goal is also to find a solution for your issue not just constant questions.

Thank you for your insight. We are actually looking into those as well. We just need to ask the questions to narrow out the issue.

We appreciate your continued cooperation to answer our questions and your patience.

Please allow us some time to check on this. We hope for your understanding regarding this

We will get back to you no later than 3 business days from now.



Best Regards,

Alfred S

Intel® Customer Support


nm987
Beginner
2,794 Views

Hi Alfred,

sorry if my message sounded harsh.

My experience with Intel software in general is that it will use language as selected in regional settings. For example I know that graphics drivers do that. In my previous experience I had similar issue when evaluating Parallel studio compiler where the only way to switch display language is to change regional settings. https://software.intel.com/content/www/us/en/develop/articles/changing-language-setting-to-see-engli...

 

Having that in mind I have a strong reason to believe that NIC drivers follow the same behaviour pattern. As I've written before I don't mind if software suggests the display language  as long as I am able to change it somehow. However, with Intel software I don't have that option without changing OS global settings or doing some hacks in order to make it display desired language. I am fine with hacks because they will only affect application, however changing OS global settings can break other software/services like in my case and it is just not a way how to take care of multi language piece of software in my opinion.

 

Kind regards

AlfredoS_Intel
Moderator
2,632 Views

Hi Nm987,

Thank you for your patience in waiting for an update.

Our engineers and software team are still investigating your issue.

We are deeply sorry for the time that it is taking for us to find a solution. Rest assured, we are doing everything that we can to find a solution to your concern.

We will try to get back to you with an answer no later than three business days from now; however, we will reach out to you if we need additional information or if we already have developments regarding your concern.



Best Regards,

Alfred S

Intel® Customer Support


AlfredoS_Intel
Moderator
1,906 Views

Hi Nm987,

Thank you for your patience in waiting for an update.

Please allow us more time to continue investigating your concern.

Here are our engineer’s findings so far:

1. Our engineering team tried to reproduce the issue you are experiencing; however, we could not do so.

2. There is a possibility that since the system is set to use the Japan region but using the English language, the driver is pulling strings from the wrong translation.

We will try to get back to you with an answer no later than five business days from now; although, we will reach out to you if we need more information or if we already have developments regarding your concern.

We hope for your continued understanding and patience with your concern.



Best Regards,

Alfred S

Intel® Customer Support


Reply