Ethernet Products
Determine ramifications of Intel® Ethernet products and technologies
5018 Discussions

intel nic drivers 19.3 huge 6000+ dpc latency spike once a few secs

ATay3
Novice
80,173 Views

hi, i would like to report that the new intel nic drivers version 19.3 that just released recently has huge 6000+ dpc latency spike once in a few secs.

my specs

Intel(R) 82579LM Gigabit Network Connection

windows 7 SP1 32bit + lastest windows update

i downgrade to intel nic drivers previous version 19.1 and the problem is just gone.

285 Replies
ASell
Novice
4,728 Views

Thanks for the huge, thorough and highly detailed reply! However, it didn't help me much, from what I could tell. I also tried the the AlternateSemaphoreDelay setting without any luck. I also have a P8Z77-based motherboard from Asus like smakkerlak has. I'm pretty sure there is no way in UEFI/BIOS to disable Management Engine. I'm pretty sure as I've looked pretty much into anything in there. If it's possible it's probably hidden or has to be done in some other way. I can't help it but it feels like a rather strange "workaround" to solve a problem. Other drivers has been fine before, until NIC driver 19.2 or 19.3+. Something seems to be very different from those newer driver sets than before, that's for sure.

 

Like smakkerlak it seems like I have to use the 19.1 driver also, I hope there is a better solution/new driver soon. I mean without having to be a programmer to understand certain things, dig through the registry and tweaking stuff just to get it to "work" I mean.

0 Kudos
st4
New Contributor III
4,728 Views

Hi Hidskjalf

Thank you for the update You may continue to use version 19.1.

rgds,

wb

0 Kudos
ASell
Novice
4,728 Views

I tried the recently released 20.1 Intel NIC drivers today. I just wanted to report that the DPC latency issue is still there.

0 Kudos
st4
New Contributor III
4,728 Views

Hi Hlidskjalf,

Thank you for the update and taking time to test . So far what is new in this driver release are:

(from release notes)

- Linux support for VXLAN Overlay on Intel(R) Ethernet Controller X552-based

devices

- Support for the Intel(R) Ethernet Connection X552/X557-AT 10GBASE-T

- As of this release, tools such as the Intel(R) Ethernet Flash Firmware

Utility (BootUtil) and Intel(R) PROSet for Windows Device Manager no longer

support boot image file formats prior to software release 17.1.

- Support for Microsoft* Windows* 10

- The prefix for Intel(R) PROSet for Windows* Device Manager ANS teams has

changed from "TEAM : " to "TEAM: ". Please update your scripts accordingly.

http://downloadmirror.intel.com/18713/eng/readme.txt http://downloadmirror.intel.com/18713/eng/readme.txt

rgds,

wb

0 Kudos
ASell
Novice
4,728 Views

You're right, I should have read the release notes. I totally rushed that one! I guess I'll wait for a new driver to try out (and take the time to read the release notes first).

Thanks for the reply though!

0 Kudos
ATadr
Beginner
4,728 Views

Thanks for the informative reply. Explaining the reasoning to us and being transparent about the situation is a huge plus in my book for any company.

wb_Intel wrote:

Assuming, we recommend you the one of the following solution (starting from the best one):

1.) Disabling ME FW /AMT if it's not needed

2.) Doing some experiments and decreasing AlternateSemaphoreDelay value to achieve smaller delays

3.) Setting AlternateSemaphoreDelay to 0 to enable the older wait mechanism from driver 12.10.28.0

I am on Windows 10, and I have the latest Windows 10 network controller drivers installed (from 6/2/2015). My motherboard is an Asus Sabertooth Z77 and I looked through my BIOS and it has no option anywhere to disable Intel Management Engine unfortunately. I did uninstall the Intel ME software though, but that didn't help as I'm still getting DPC spikes.

With regards to the AlternateSemaphoneDelay, is this a string key or a DWORD key? I tried adding it but didn't see any effect really. Is a PC reboot needed or can I just disable and re-enable the network adapter?

EDIT: I just completely uninstalled the Intel network driver and Windows 10 seems to have reverted to a default driver which no longer causes the stuttering...so I'll leave it like that for now.

0 Kudos
ASell
Novice
4,728 Views

Thanks for the informative reply. Explaining the reasoning to us and being transparent about the situation is a huge plus in my book for any company.

I agree with you fully on this one. It's great that Intel acknowledges there is an issue is a good first step, indeed.

I am on Windows 10, and I have the latest Windows 10 network controller drivers installed (from 6/2/2015). My motherboard is an Asus Sabertooth Z77 and I looked through my BIOS and it has no option anywhere to disable Intel Management Engine unfortunately. I did uninstall the Intel ME software though, but that didn't help as I'm still getting DPC spikes.

DPC Latency Checker isn't compatible with Windows 8 and 8.1, so my guess is that it isn't compatible with Windows 10 either, but I could be wrong. DPC Latency Checker doesn't show correct values in Windows 8/8.1 (DPC latency appears to be higher on Windows 8 while it's probably much lower). They have Windows 7 and below in the compatibility list on Thesycon's website. You should try monitoring with http://www.resplendence.com/latencymon LatencyMon instead for more accurate values. Chances are at least higher that Latencymon will work better. At least that is my bet.

0 Kudos
st4
New Contributor III
4,728 Views

Hi Hlidskjalf,

Thank you for sharing the test result which is very informative.

rgds,

wb

0 Kudos
ASell
Novice
4,661 Views

Sure thing, but this time it was atadros who reported some DPC latency issues in Windows 10.

By the way, I tried the Intel Connections Software version 20.2 located at http://www.station-drivers.com/index.php/outils/Drivers/Intel/Network-Connections-Software/Intel-Network-Connections-Software-Version-20.2.40-WHQL/ Station-Drivers and I read the release notes this time so I guess I kind of expected that the DPC latency issue was still there, but I just wanted to report to others that might be wondering that it's no use, not on my 82579V NIC at least. These are the results.

0 Kudos
st4
New Contributor III
4,661 Views

Hi Hlidskjalf,

Thank you for sharing the information there is no mention about the fix for latency issue so far in version 20.1 and Windows 10 is not officially released yet.

rgds,

wb

0 Kudos
ASell
Novice
4,661 Views

I always tested in Windows 7 64-bit, and I've had DPC latency spikes since the 19.3 drivers (as the topic header suggests) up to 20.1 and 20.2. It was atadros who reported his experience in Windows 10. Just wanted to clear that up, if there has been some confusion about who is who. Right, Windows 10 isn't officially released just yet, but it seems that the latest build 10240 is going to be RTM. And what atadros wrote suggests that the DPC latency issue in Intel NIC drivers are apparent in Windows 7, Windows 8 (from what I gather), and even Windows 10 (even though atadros probably wasn't running the 10240 /RTM build at the time probably) . I just installed Windows 10 myself, so I might try the 20.1 and 20.2 drivers and see if I have any luck with that. I doubt it but I like testing stuff in my free time. But I guess we'll just have to wait, however a bit impatiently as you may have noticed.

In the meantime, cheers!

0 Kudos
SKanh
Beginner
4,661 Views

Glad I found this thread as reverting to the 19.1 drivers solved my drop outs on my MOTU 1248. Regarding the suggested fix of disabling ME FW, can someone advise me on how to disable it on my Intel DP67BG motherboard? Also, what will I lose by disabling the Management Engine?

Cheers,

KanaryProductions

0 Kudos
st4
New Contributor III
4,661 Views

Hi KanaryProductions,

What you can do is to uninstall the ME or refer to this website at http://www.intel.com/support/motherboards/desktop/sb/cs-020837.htm Desktop Boards — Integration Guide: BIOS Settings to disable the AMT

As extracted below:

Intel® Active Management Technology  

Intel Active Management Technology is included with desktop boards intended for corporate environments. This technology is a hardware-based solution that uses out-of-band communication for system management access to client systems. Even with a crashed hard drive, a locked operating system, or if a system is turned off, access is still available to the client system to perform basic management tasks.

To disable Intel Active Management Technology:

  1. Enter BIOS Setup by pressing [F2] during boot.
  2. Go to the Intel ME menu.
  3. Set Manageability Feature to None.
  4. Exit and save changes [F10].

Hope this helps.

rgds,

wb

0 Kudos
SKanh
Beginner
4,661 Views

Hi wb,

I did check my BIOS first but I don't see an Intel ME menu. I do see that my PC builder ran an MEI setup file as I can see where it was downloaded and a couple of log files that says it was installed. I checked Control Panel to uninstall but I don't see an entry for the install so If I rerun the setup, will it allow me to uninstall MEI? Thanks for your help.

Cheers,

KanaryProductions

0 Kudos
st4
New Contributor III
4,763 Views

Hi Alpha_Tay,

Please be informed our business unit engineering is working on the issue using the information provided.

rgds,

wb

0 Kudos
aasus
Beginner
4,763 Views

@ Intel Support

i build a new PC using a Mainboard "Asus H97 Pro Gamer" and running Win7 x64 Home 3 weeks ago.

It has the Intel Ethernet i218-V Lan Chip onboard.

Now i´am trying to switch to this new machine, i terrified because i (also) detect skipping or http://dict.tu-chemnitz.de/english-german/stutter.html stutter but even during a "simple" Radio Webstream (!!) 192kbit/s (audio output via Realtek onboard) while the Software BattleNet is updating Starcraft2 15 GB.

Pretty annoying...but i though the reason is the Blizzard Software. That was a a mistake.

What i have done to solve the problem:

Swap from Winamp Lite (last Ver) to MS Media Player

still have this Problem. When this occurs Winamp says: Puffer 10% ...50% than it runs sometimes for 2 sec.. and it happens again

SO iam trying to install cfos (Asus Gamefirst) sometimes it was better but it also happens while Traffic Shaping is active .... so i decided to deinstall it..

Now i didn´t start the Battlenet Software the stuttering still happens and i don´t know why.

My old PC was a G31 intel Chipset Mainboard with intel Lan too running WinXP.

I never had problems this way the last 7 years!

 

Iam sure this Problems is caused by the intel NIC. 

 

 

Unfortunatly i can´t provide more infos... while iam reading and writing the Postings here and google (took 1 Hour) , this stupid effect didn´t occurs once...

so it seems it´s difficult to reproduce the problem here.

I hope you will find a solution.

byebye Asus h97

 

 

 

 

 

 

0 Kudos
SYeo3
Valued Contributor I
4,763 Views

Hi everyone,

Upon checking, we found the delay is enabled in registry key. Please disable it by setting AlternativeSemaphoreDelay registry key to 0.

Please let us know if this help resolve the latency issue.

Sincerely,

Sandy

0 Kudos
AGöra
Beginner
4,763 Views

Hello,

First of all, thanks for trying to fix this issue.

Unfortunately, it did not help.

Methods of testing:

Direct change in the registry (it's AlternateSemaphoreDelay by the way, if someone wanna try it out) to 0, to use the Microsoft-provided NdisStallExecution() function to implement the delays (more info in the INF file). Then restarted the network adapter. Also restarted Windows just in case. DPC latency still spiking.

Modded INF file and a reinstall gave all the same result.

Tested with latest 20.0 drivers using Windows 7 SP1 x64 and Intel 82579V.

Regards,

Andreas

0 Kudos
AKaga1
Novice
4,763 Views

Thanks for testing the possible Fix Andreas, Do let us know if you have any luck with either the INF edit or registry edit.

@Sandy_Intel, If you would like more users to test the registry fix please advise, otherwise I will wait for official driver update.

0 Kudos
SYeo3
Valued Contributor I
4,763 Views

@Trivve - Sorry to hear that disabling the AlternateSemaphoreDelay didn't resolve the issue.

@Skyenet - I understand you are also experiencing latency issue. However, for most users on this thread, the latency appeared after updating to driver version 19.3 and later. Installing version 19.1 does not experience the latency problem. Try installing our driver. https://downloadcenter.intel.com/ Intel® Download Center

@AJK47 and everyone - as of the moment, the workaround that may fix this issue are:

1. Rollback to older driver version 19.1 or below.

2. Modifying registry key. - AlternateSemaphoreDelay set to 0 to disable

Since we are dealing with different system and motherboard models, please share with us if you see other registry keys with the word "Delay" so we can further check if it can be disabled too.

We are continuously working to fix this issue. Please do share with us your test results.

Sincerely,

Sandy

0 Kudos
SMath11
Beginner
4,763 Views

I've been having this issue for a long time, and never realized there was a thread on here about it. My experience echoes pretty much everyone in this thread. I install intel drivers, and after a while I experience stuttering i(usually while opening a new browser window or navigating web pages). Using DPC Latency Checker I correlate the stuttering with peaks in DPC latency.

One thing that may not have been mentioned, and may help diagnose it (or it may have been mentioned, or be useless) is that the problem only presents a while after I install the intel drivers provided by Asus for my motherboard (Maximus VII Ranger, which it seems is version 19.1.51.0). So my solution so far has just been to reinstall those every week or so. I'm going to try installing an older version now and see if the problem goes away until Intel fixes it.

0 Kudos
Reply