Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Valued Contributor III
1,092 Views

Arria 10 LPM_mult IP with Qsys, modelsim simulation errors libraries not found

Hellow every one i am new here i hope i can find someone to help me 

So thank you in advance. 

I am using Quartus prime for a project based on multipliers. I used LPM_mult from the IP catalog (with Qsys which replaced megawizard plugin..). The design is a simple structural architecture using LPMs as components. These LPMs folders are generated in the project directory containing vhdl files and packages. The design in quartus prime is synthetisable (no errors), but , once I move to modelsim to test and verify the design functionality I can’t compile the associated vhdl LPMs files. In one hand, I received this kind of error messages “library coef86_lpm_mult_170 is not found”. 

On the other hand, I tried to compile all the files in every folder generated by quartus. Simulation is set and I get this hierarchical (as attached) but when running the simulataion all signal assigned to LPM outputs are set in high impedence. 

Please, can anyone help me? Is this due to the libraries miss? If so, how can I add them knowing that each LPM used has his own library name.
0 Kudos
2 Replies
Highlighted
Valued Contributor III
190 Views

Hi Anand, 

 

I thank you for your reply. i really appreciate it. 

Yes i tried to load them manually. 

 

I followed the script you attached and also in _setup.tcl and i think it worked with script. (attached file) 

 

The problem is, simulation running is launched automatically but what i want is to use it as a component in another top level file including many LPMs. 

 

I tried to modify the <file>.do with commenting the "elab" and "run" commands to avoid the simulation of the mult.  

When i compiled the rest of files included in the project and run the simulation i have this kind of errors  

 

"Loading work.coef274(rtl) 

# Loading coef274_lpm_mult_170.coef274_lpm_mult_170_aafwdzy 

# ** Error: (vsim-3033) C:/Users/HP/Desktop/test_lpm_sim_script/coef274/sim/../lpm_mult_170/sim/coef274_lpm_mult_170_aafwdzy.v(30): Instantiation of 'lpm_mult' failed. The design unit was not found. 

# Time: 0 ps Iteration: 0 Instance: /test_dct5_b4_v2/c1/comp_etage1/compcoef274/lpm_mult_0 File: C:/Users/HP/Desktop/test_lpm_sim_script/coef274/sim/../lpm_mult_170/sim/coef274_lpm_mult_170_aafwdzy.v 

# Searched libraries: 

# C:/Users/HP/Desktop/test_lpm_sim_script/libraries/work" 

 

I think the inner components of the LPM are no longer compiled and added in the hierarchical. 

 

Can you help me with that please?  

 

Thank you again
0 Kudos
Highlighted
Valued Contributor III
190 Views

Hi, 

 

I was not able to reproduce the error. 

I have done a simple project with 3 LPM_MUL Ip and integrated in top (.vhd) file and simulated with do file without any error. 

attached the for reference 

 

Best Regards, 

Anand Raj Shankar 

(This message was posted on behalf of Intel Corporation)https://www.alteraforum.com/forum/attachment.php?attachmentid=14691 https://www.alteraforum.com/forum/attachment.php?attachmentid=14692
0 Kudos