Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,256 Views

DDR3 Memory Calibration Fails for Cyclone V - EMIF Toolkit Error

I'm currently using a custom board with 5CEFA9F31C7N Cyclone V E FPGA chip and Alliance AS4C512M16D3L DDR3 8GB with 1.5V on Quartus II 13.1. 

 

After setting up my timing constraints and generated an IP through MegaWizard, I SignalTapped my local calibrations that resulted with calibrations failed. 

 

After reading through 

https://www.altera.com/content/dam/altera-www/global/en_us/pdfs/literature/hb/external-memory/emi_un... 

I know that the EMIF Toolkit can be useful in determining what stage the calibration failed to narrow down the culprit. Is this available for the Cyclone V E?  

 

Page 11 states: 

"The UniPHY External Memory Interface Debug Toolkit and EMIF On-Chip Debug Toolkit do not workwith Arria V and Cyclone V SoC devices. Debugging information for Arria V and Cyclone V SoC devicesis available by enabling a debug output report, which contains similar information." 

 

My chip is not an SoC so it would work correct? 

 

I compiled my project (Analysis & Synthesis, ran .tcl scripts for pin assignments, map, and timing, Fitter, then Full Compile), programmed the board and proceeded to start up the toolkit, only to have it timeout on the "Initialize Connections" task. Any insight on this? 

 

I also used the Cyclone V GT Development Kit and was able to calibrate the DDR3 memory on that device with no issues with read/write functionalities. However, Toolkit would still timeout after a few minutes on "Initialize Connections". 

 

-Steve
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
86 Views

I was able to get my EMIF toolkit working. I had 13.1 installed without updated patches. I noticed there were updates for Cyclone V and Extermal Memory support from the 13.1.4.182 (Software Update 4 Patch). After installing the patch update, the toolkit works. I have a Read Calibration - Guaranteed Read Failure that I will look into.

Altera_Forum
Honored Contributor I
86 Views

 

--- Quote Start ---  

I was able to get my EMIF toolkit working. I had 13.1 installed without updated patches. I noticed there were updates for Cyclone V and Extermal Memory support from the 13.1.4.182 (Software Update 4 Patch). After installing the patch update, the toolkit works. I have a Read Calibration - Guaranteed Read Failure that I will look into. 

--- Quote End ---  

 

 

 

Can you please detail me on how you used the toolkit? I am assuming you used Add EMIF debug interface in Calibration Debug options. 

Did you add any JTAG master for the same? 

I programmed the .sof file(calibration failed) into Arria 10 custom board. So i want to debug the reason for the failure. 

I am using version quartus version 17.0
Reply