FPGA Intellectual Property
PCI Express*, Networking and Connectivity, Memory Interfaces, DSP IP, and Video IP
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5990 Discussions

Error (10481): VHDL Use Clause error at fir_compiler_v13_0_ast.vhd(33)

Altera_Forum
Honored Contributor II
2,262 Views

I exported a series of HDL files with DSP Builder 13.0,and setup a new quartus ii project,but when I started compilation,some errors occured,the error information is : 

Error (10481): VHDL Use Clause error at fir_compiler_v13_0_ast.vhd(33): design library "auk_dspip_lib" does not contain primary unit "auk_dspip_lib_pkg_fir_130" 

 

 

Error (10800): VHDL error at fir_compiler_v13_0_ast.vhd(33): selected name in use clause is not an expanded name 

 

 

then I found the file auk_dspip_lib_pkg_fir_130.vhd,added it into my project,and I also tried to add the lib file into my project,but the error still existed. 

quartus ii help information is : 

 

 

CAUSE: 

In a Use Clause at the specified location in a vhdl design file (.vhd) (http://quartushelp.altera.com/13.0/mergedprojects/reference/glossary/def_vhd.htm), you tried to access the specified primary unit of the specified design library. However, the design library does not contain the primary unit, or the primary unit has not been successfully compiled. For example, the Use Clause in the following code attempts to access the primary unit example, but the ieee design library does not contain the primary unit example: 

LIBRARY ieee; 

USE ieee.example; 

 

 

ACTION: 

Access only primary units that exist in a design library and have been successfully compiled. 

 

but I don't understand the ACTION. 

 

 

https://alteraforum.com/forum/attachment.php?attachmentid=13568&stc=1 https://alteraforum.com/forum/attachment.php?attachmentid=13569&stc=1 https://alteraforum.com/forum/attachment.php?attachmentid=13570&stc=1
0 Kudos
1 Reply
Altera_Forum
Honored Contributor II
787 Views

You need to add the auk_dspip_lib_pkg_fir_130.vhd file to the auk_dspip_lib library. Libraries in VHDL are NOT paths on your hard disk. The global libraries tab are really only needed for Verilog and AHDL. They mean nothing to VHDL. 

 

The column after "type" is called "library". You need to change the properties on the source file to add the file to the required library.
Reply