Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
897 Views

Error when compiling simple video application

Hello, 

I try to compile a very simple system using two video Megacore functions and a Nios II 

-test pattern generator directly connected to 

- video output 

during compilation I have got the following message 

Error: Node instance "auto_inst" instantiates undefined entity "alt_vip_tpg_0_GN" 

 

Attached is a document with screen shots showing SOPC architecture, toplevel bdf and error message 

Thank for your help 

Jacques 

Config is :  

Windows XP 

Quartus 9.1 

Stratix IV 

Audio video Developmemnt kit Stratix IV GX Edtion
0 Kudos
9 Replies
Altera_Forum
Honored Contributor I
39 Views

Hello, 

 

I get exactly the the same message. Perhaps you've already solved the problem. 

 

Thanks in advace 

 

Andreas Schwirzer
Altera_Forum
Honored Contributor I
39 Views

You need to manually add the VHDL file for your "alt_vip_tpg_0" block to your Quartus project. It can't find the entity. 

 

Jake
Altera_Forum
Honored Contributor I
39 Views

Thank you for reply. 

 

The problem occurred because of administration rights in windows 7. Running Quartus as administrator, without any changes to my project, there are no more errors. 

 

Andreas
Altera_Forum
Honored Contributor I
39 Views

I wonder if any one can help me. I have the same problem as Ehrlich, however I have tried the suggestions here with no luck. Ehrlich, can you please share what you did to resolve this? 

 

Thank you, 

Harold
Altera_Forum
Honored Contributor I
39 Views

I forgot mention that the alt_vip_tpg_0_GN.vhd file generated from my project is 0KB in size. Could I be missing a licence or something? Thanks

Altera_Forum
Honored Contributor I
39 Views

make sure you run as administrator when using VIP Suite in Windows. the SOPC Builder system needs to be generated as administrator also

Altera_Forum
Honored Contributor I
39 Views

Thanks thepancake - that worked!

Altera_Forum
Honored Contributor I
39 Views

While it may not always be the case, we found the solution to errors such as these are to check the IP Cores that the file uses and install/reinstall using the Megawizard. Has worked nearly every time.

Altera_Forum
Honored Contributor I
39 Views

 

--- Quote Start ---  

While it may not always be the case, we found the solution to errors such as these are to check the IP Cores that the file uses and install/reinstall using the Megawizard. Has worked nearly every time. 

--- Quote End ---  

 

 

Hi trennert, 

I facing the same issue. Can you please mention in detail.
Reply