FPGA Intellectual Property
PCI Express*, Networking and Connectivity, Memory Interfaces, DSP IP, and Video IP
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5890 Discussions

Help: Writing into CVO registers

Altera_Forum
Honored Contributor II
1,003 Views

My system consists of only TPG , CVO and SD-SDI output. 

 

TPG (720x480)>> CVO >> SD SDI output 

 

Using Neo, I can read/write the TPG correctly, but each time 

when I try to write into the VCO the software hung.  

 

Does this mean I have to do something on TPG (i.e stop) or put into certain operating mode before I can write into any of the VCO registers ? My goal is I want to be able to change VCO parameters at runtime and view the changes of video image on SDI monitor. 

 

Thanks in advance.
0 Kudos
3 Replies
Altera_Forum
Honored Contributor II
138 Views

You should be able to read/write the CVO registers at any time without hanging the system. The only thing I can think of is that maybe you selected the a wrong/bad clock in SOPC builder for the CVO.

Altera_Forum
Honored Contributor II
138 Views

Thanks, Kevin. I will check. 

Since I can read/write the TPG fine, I would think my clock (27MHZ) should be fine.  

 

Question for you though: At the moment I am only interested in using MODE1 of the CVO, the following two parameters were what I set on the megawizard that I am not very certain about ! 

 

Runtime configurable video modes = 1 

Width of "vid_std" bus = 1 

 

Are these setting correct? 

 

Again thank you for your help, 

 

 

JIMMY
CSoil
Beginner
138 Views

Hi Jimmy, did you ever figure out your issue? I am having issues with the CVO not getting the mode matched.

Reply