Community
cancel
Showing results for 
Search instead for 
Did you mean: 
VCham
New Contributor I
195 Views

Is it possible to instantiate a Qsys IP from a newer version of Quartus in an older versioned project?

We use Quartus 17.0.2 which unfortunately does not support EPCQA flash devices and we are trying to implement remote update. I am trying to use the ASMI Parallel II IP from version 17.1 which does support EPCQA and synthesize it in my Quartus 17.0 project.

 

Any insight would be really helpful. If anybody has other suggestions for how to write a new FPGA image onto an EPCQA device using a Quartus 17.0.2 build please let me know!

0 Kudos
6 Replies
ShafiqY_Intel
Employee
90 Views

Hi VCham,

 

It is not possible to use EPCQ-A with Quartus 17.0.2 build. Plus, you are using ASMI Parallel II IP which not IP Compatibility.

https://www.intel.com/content/dam/www/programmable/us/en/pdfs/literature/an/an822.pdf

EPCQA compatibility.JPG

Therefore, you need to regenerate IP core and programming file.

 

 

However, if you use a legacy device that is not supported in the Intel Quartus® Prime software version 17.1 and later, the Quartus 13.1 Version have patches available to download which add EPCQ-A support to legacy Quartus releases.

https://www.intel.com/content/www/us/en/programmable/products/configuration-devices/support.html#sof...

 

 

Thanks

VCham
New Contributor I
90 Views

Hi,

Thank you for your response. However, I have some questions. What do you mean by "if you use a legacy device"?

Could you give me an example of that use case?

 

ShafiqY_Intel
Employee
90 Views

Hi VCham,

 

"if you use a legacy device" means the device that is not supported in Quartus 17.1 version.

 

For example

  • Cyclone III device (last Quartus support this device is Quartus 13.1)
  • Arria II device (last Quartus support this device is Quartus 14.1)

 

 

Thanks

VCham
New Contributor I
90 Views

Ohhh okay I understand.

 

We are using Cyclone V so that isn't the case for us. We also require that the Quartus release we use be Functional Safety Certified and I believe 13.1 is not unfortunately.

ShafiqY_Intel
Employee
90 Views

Hi VCham,

 

I think the best option for you is migrate to Quartus 17.1 version.

 

Thanks

USo00
Beginner
78 Views

Hi ShafiqY_Intel,

Will Quartus 17.1 (or other newer versions) be added to the Functional Safety Data Package (FSDP) any time soon?

We will also run into the same problem. The latest FSDPv5.1 only includes Quartus v17.0.2, which doesn't support the EPCQ-A devices.

I had been wondering if the patch to add EPCQ-A support to legacy Quartus versions would work for legacy versions other than v13.1, but from your answers, that doesn't seem to be the case.

https://www.intel.com/content/www/us/en/programmable/support/support-resources/knowledge-base/compon...

https://www.intel.com/content/www/us/en/programmable/products/configuration-devices/support.html

If there's no other workaround for this, we'll have to add hardware provisions for PS mode configuration and not use an Intel Configuration Device (at least in the production version).

We could use a newer version of Quartus that supports EPCQ-A during initial FPGA development in AS mode and then once our microcontroller FPGA firmware upgrade feature has been developed, we could go back to v17.0.2 for functional safety and change to PS mode configuration.

Is there any other way to support EPCQ-A using Quartus v17.0.2 since we are restricted to this version for functional safety?

Thanks.