FPGA Intellectual Property
PCI Express*, Networking and Connectivity, Memory Interfaces, DSP IP, and Video IP
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5881 Discussions

Problem with Altera ASMI Parallel IP

Altera_Forum
Honored Contributor II
918 Views

We are using Cyclone V SX with EPCQ256 memory. We would like to use the flash memory for user data since the FPGA is configured from the HPS. I have added the Altera's ASMI Parallel IP to our Qsys system. The ASMI Parallel is controlled by our custom IP block. I have problem with the Protect Sector command since the memory freezes after this command. The asmi_busy signal locks to high state after the sector_protect- and wren-signals are asserted. It seems that there is some problem with writing to the status register since the other memory commands work without any problems. Has anybody any ideas how to fix this problem? I have also tried to use the Altera's Generic Quad SPI Controller but the same problem occurs also with that. I have tried also to lower the clock frequency of the memory from 20 MHz to 1 MHz but it doesn't help. 

 

best regards, 

Joonas
0 Kudos
0 Replies
Reply