Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
810 Views

Triple Speed Ethernet and Simple Socket Server on Arria V starter kit

Hello Altera Forums, 

 

I am trying to get the Simple Socket Server working on an Arria V starter kit. I have created a Nios system to accomplish this. Here is a screenshot of the system: 

https://i.imgur.com/AZOlZyc.png  

 

I have connected the Nios system to the appropriate pins, and when I run the Simple Socket Server (RGMII), I get this response: 

 

InterNiche Portable TCP/IP, v3.1 Copyright 1996-2008 by InterNiche Technologies. All rights reserved. prep_tse_mac 0 Can't read the MAC address from your board. We will assign you a MAC address. Please enter your 9-digit serial number. This is printed on a label under your Nios dev. board. The first 3 digits of the label are ASJ and the serial number follows this. -->Created "Inet main" task (Prio: 2) Created "clock tick" task (Prio: 3) 123456789 123456789 Your Ethernet MAC address is 00:07:ed:ff:cd:15 prepped 1 interface, initializing... INFO : TSE MAC 0 found at address 0x08202000 INFO : PHY Marvell 88E1111 found at PHY address 0x00 of MAC Group INFO : PHY - Automatically mapped to tse_mac_device INFO : PHY - Restart Auto-Negotiation, checking PHY link... INFO : PHY - Auto-Negotiation PASSED MARVELL : Mode changed to RGMII/Modified MII to Copper mode MARVELL : Enable RGMII Timing Control MARVELL : PHY reset INFO : PHY - Checking link... INFO : PHY - Link not yet established, restart auto-negotiation... INFO : PHY - Restart Auto-Negotiation, checking PHY link... INFO : PHY - Auto-Negotiation PASSED INFO : PHY - Link established INFO : PHY - Speed = 1000, Duplex = Full OK, x=0, CMD_CONFIG=0x00000000 MAC post-initialization: CMD_CONFIG=0x0400020b RX descriptor chain desc (1 depth) created mctest init called IP address of et1 : 142.104.60.71 DHCP timed out, going back to default IP address(es) Simple Socket Server starting up Simple Socket Server listening on port 30 Created "simple socket server" task (Prio: 4)  

 

When I try to ping, I get no connection. 

 

To debug, I connected signal tap to the RX[3..0] and TX[3..0] signals. I am seeing signal on the RX bus, but there is no data on the TX bus. The tx_enable pin is also never asserted. This is likely why the Simple Socket Server can't connect to the DHCP, but I can't figure out why there is no data on the TX bus. 

 

Help me alteraforum, you're my only hope!
Tags (1)
0 Kudos
1 Reply
Altera_Forum
Honored Contributor I
17 Views

If anyone comes across this when looking for solutions, I managed to fix it by constraining the timing. I used the board update portal example provided with the Arria V starter kit (on the CD) as a starting point and modified it to fit with my design. 

 

I am now able to connect to the DHCP and get assigned an IP address. I can ping successfully, but I get a 60% packet loss 

 

I've included the SDC files that solved my timing issues here in case anyone else finds them useful. If you have any insights into why I'm losing so many packets, I would be grateful.