Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
805 Views

USB Example

Hello all, 

 

I am using the stratix IV DE4 development board and am having some troubles with the USB example project shipped on the CD, the usb chip is the isp1761. 

 

 

The project compiles and nios2 run successfully and the debug screen asks to insert a USB mouse or storage device, however nothing happens when I plug them in. Even the 3 leds (vbus1,vbus2,vbus3) are not lighting up, they do however light up when I run their demo batch file(provided on shipped CD) and attaching usb mouse/storage device are able to work from there.  

 

Here is the output when I run there example project(adding in some extra debug print): 

===== DE4 ISP1761 USB Host Demo ===== 32 bit bus Port 1 as host ISP1761 (SCRATCH register pass) hcInitReg Check chip ID matched chip id hcReset Port 1 configured as host Set hub device address success, address=1 Set Config, HubAddr=1, ConfigValue=1 --------------- Get Hub Descriptor (Addr=1) --------------- Please insert USB-Storage or/and HID USB-Mouse  

 

Leds dont light up, and doesn't respond when i insert a device. 

 

I am missing something?
0 Kudos
2 Replies
Altera_Forum
Honored Contributor I
45 Views

After adding# define DEBUG_USB_PORT which prints some more debug msgs i now get this. 

 

PTD Write Header: 

DW0=2020 0041h 

DW1=0000 0800h 

DW2=1001 8000h 

DW3=8180 0000h 

DW4=0000 0000h 

DW5=0000 0000h 

DW6=0000 0000h 

DW7=0000 0000h 

PTD Write Header: 

DW0=16D0 0041h 

DW1=79E6 45B0h 

DW2=0001 8000h 

DW3=8200 0000h 

DW4=0000 0000h 

DW5=0000 0000h 

DW6=0000 0000h 

DW7=0000 0000h 

[PORT_ERR]done map 0h(timeout=0.000sec) 

[PORT_ERR][ERR]AltOut Error!!!!!!!!!!!!!!!! 

[PROTOCOL_ERR]USB_ControlRequest->error 

[PROTOCOL_ERR]Get Device Descriptor fail, DeviceAddr=48879 

[HUB_ERR]Get hub descriptor fail 

Failed to start USB Hub
KPhan4
Beginner
45 Views

Hi

I am working on the usb device project on the DE4 board on window 7.

But when loading .sof and elf files, the driver is not supported on win7.

Can anybody help me fix this?

Reply