Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Honored Contributor I
748 Views

Video image problem

Hi, 

 

I'm new to Cyclone and IP cores and have an issue with my video implementation. 

 

My base system is the Cyclone V SoC Development Kit with the Bitec HSMC Quad Video card. I have copied the sample processing structure (PAL video signal, TVP5154 video chip, clocked video input YCbCr 4:2:2, colour space sequence, chroma resampler YCbCr 4:4:4, colour space converter CbCrY' SDTV to Computer B'G'R' for RGB 24 bit output, deinterlacer, video frame buffer, mixer, clocked video output, CH7010B video output chip) and end up with the supplied image. 

 

As can be seen in this image (sorry for the weird selfie) there is a lot of red "interference". 

 

As a test I have put a test pattern generator into the system at different points to test the video out. For the output I configure the TPG to uniform background and then have an application on a NIOS processor constantly change the colour. Putting the TPG anywhere from the mixer back to the deinterlacer everything appears fine. When I place it as the input to the colour space converter (CSC) I end up with some colours that have "interference" - see photo 2 - it should be green. (Yes I have changed it to YCbCr output and changed the colour settings appropriately for this) 

 

Looking at formulas used to convert YCbCr to RGB values are subtracted for the Y, Cb and Cr values before they are multiplied out (e.g. G = Y - (0.34414 * (Cb - 128)) - (0.71414 * (Cr - 128)) . The formula within the CSC only allows for multiplication of the individual values with a summand at the end. 

 

Is this really the problem or is it somewhere else? I find it hard to believe that Altera would release something like the CSC that would not work with the default options. 

 

Any help with this would be greatly appreciated. 

 

Cheers 

David 

https://www.alteraforum.com/forum/attachment.php?attachmentid=9262 https://www.alteraforum.com/forum/attachment.php?attachmentid=9263
0 Kudos
0 Replies