Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
776 Views

confusion about scaler

hi, 

I have a problem with scaler, my data path is : 

CVI(clocked video input)->SCL(scaler)->FRM(frame buffer)->CVO(clocked video output) 

It takes the input resolution 800x600 and scaled to 1920x1080 and output , when the input is 800x600, it worked well. 

But when I changed the input resolution from 800x600 to 640x480, the whole screen flickered badly. 

So I think the input resolution of scaler is fixed, am I right? 

Thanks for reply!
0 Kudos
4 Replies
Altera_Forum
Honored Contributor I
40 Views

Hi, 

 

If you use the Scaler as is (without controlling it via the run-time control) then the input is fixed per the configuration in the SOPC. 

If you use the run-time control then the input resolution is the maximum resolution you can input. 

 

BR, 

Reuven
Altera_Forum
Honored Contributor I
40 Views

 

--- Quote Start ---  

Hi, 

 

If you use the Scaler as is (without controlling it via the run-time control) then the input is fixed per the configuration in the SOPC. 

If you use the run-time control then the input resolution is the maximum resolution you can input. 

 

BR, 

Reuven 

 

--- Quote End ---  

 

 

hi, ra2m, thanks for reply. 

do you mean if I use the run-time control of scaler which means I can input other resolution equal to or less than the maximum resolution I set in sopc? 

But it seems that there is no register of scaler for me to explictly change the scaler to adapt to the input resolution at run time.
Altera_Forum
Honored Contributor I
40 Views

Yes, when the run-time control is used the input resolution in the SOPC setting is the maximum resolution. Any resolution below the set input resolution it will be scaled. 

But if the run-time control is not used the input resolution in the SOPC is the only resolution that can be used in the input. 

 

BR, 

Reuven
Altera_Forum
Honored Contributor I
40 Views

You should probably check the following thread since this seems to be the system you are trying to implement: 

http://www.alteraforum.com/forum/showthread.php?t=21066&page=1 

 

It is mentioned that the CVI could have some issues with some DVI inputs. This could explain the flickering in your case.
Reply