FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
5993 Discussions

Converting .sof file to .flash file for Stratix 10 GX development kit

cconger
Beginner
5,689 Views

Hello Intel,

 

I have the Stratix 10 GX development kit, and am needing to load a user design into the Flash for auto-configuration of the user design at power up.  I've been following through the documentation, and have successfully reached the page in the Board Update Portal where you specify a hardware file.

 

However, the method of converting the Quartus Prime produced .sof file into the necessary .flash file, is not documented clearly.

 

The link to the instructions to convert the .sof file state the following:

Convert user .sof file and .elf file to the format required to program the Flash
Note: You must have the Nios® II EDS installed in order to perform this step.
1. From the Start Menu, open Nios II Command Shell
2.  In the Nios II Command Shell, navigate to the build_hw.sh file and type

    sh build_hw.sh yourfile_hw.sof 1

 

However, I cannot find the build_hw.sh script anywhere.  The instructions only say to navigate to it, but do not say where it is.

 

A search for that filename in the Quartus Prime 23.1 installation directory does not find it.  I was able to find one version of it buried deep in the design material .zip file downloaded from the Stratix 10 GX product page:

stratix10GX_1sg280uf50_fpga_revd_htile_v18.1b222_v1.0.zip\stratix10GX_1sg280uf50_fpga_revd_htile_v18.1b222_v1.0\factory_recovery\build_factory_source\PRD\build_hw.sh

But this does not appear to be the correct script (looks like it will produce a .pof, and we need a .flash right?), and anyways it does not execute correctly when invoked from within the Nios II power shell as it exits with a syntax error.

I saw this previous post with a similar question however it was never actually solved, only marked as complete as the OP stopped responding:

Solved: Procedure for programming the hardware1 region of flash on my Stratix 10 GX development board? - Intel Communities

 

Please help clarify the process of converting the .sof file into whatever format is needed to load into flash from the Board Update Portal.  If I need to use a specific script from within the Nios II power shell, where is that script located?  Is there any alternative, or command line command I can enter manually like was done previously with the Arria 10 GX dev kit (sof2flash)?

 

0 Kudos
46 Replies
EBERLAZARE_I_Intel
591 Views

Hi,


Just a quick point from one of our experts, I did try using Quartus 19.1 and 18.1 Pro, the script was working and I got the .bin. Do you have at least these two versions or in between? Which Quartus version do you have currently? This is just to check the functionality.




0 Kudos
EBERLAZARE_I_Intel
582 Views

Hi,


I hope you have update. As of now, we might not be able to get the Board Update Portal script for the new Quartus version in the shortest of timeline.


So our suggestions is if you are able to use the Quartus version 18.1~ - 19.1 to use the script?


Additionally, for S10, the SDM the security device manager should be use as an advantage if you are porting from A10, so using the Board Update Portal isn't ideal to utilize it's full potential, as it is intended more towards a taste of the Quick Start Guide.


Moving forward towards RSU is my ideal suggestions, I understand it may require further understanding, however you may file any new thread on any questions on the RSU and we will help your there, on security/SDM, config etc.. So let me know your thoughts.


0 Kudos
ChrisConger
Beginner
571 Views

Hi, sorry for the slow replies I am on work travel currently through next week and will be back in the office on Aug 11th.

 

I am using Quartus Prime Pro, 23.1.  I can check with IT about installing an earlier version, however it may not work as the disk space required for each version of Quartus is significant.

 

As long as I manually generate the .pof using PFG and then manually type the sequence of commands in from the end of the script, I can get the commands to generate the file as well.  However it still does not work upon uploading through the Board Update Portal.

 

When I get back from this long travel, Ill take a closer look at the RSU and see if I am able to figure out the steps there and get one of my boards loaded with the user design through that method.

0 Kudos
EBERLAZARE_I_Intel
564 Views

Hi,


Got it, as per the earlier version discussion, as far as our dev concerns it should work on the older versions 18.1 ~ 19.1 versions of Quartus + Nios II. Please give it a try if you're opt for the BUP.


In the meantime, I would recommend we close the thread for this round, and you may reopen a new one, once you're back and @TAG me, I will be there once you open the new thread.


0 Kudos
EBERLAZARE_I_Intel
558 Views

Hi,


I will transition this thread to community support. If you have a new question, Please login to ‘https://supporttickets.intel.com’, view details of the desire request, and post a feed/response within the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you on your follow-up questions.



p/s: If any answer from the community or Intel Support are helpful, please feel free to give best answer or rate 4/5 survey.


0 Kudos
Reply