Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Altera_Forum
Honored Contributor I
1,769 Views

DE0-nano system CD Control Panel "Error make sure quartus is installed"

hi, i recently buy a DE0 nano develpment kit, i install del quartus web edition 10.1 and i download de nios 2 10.1 from the download center of altera becouse it doesn't come with the free package dvd.. 

 

This happens to me when i open the panel control in order to see it in action..."Error make sure quartus is installed".... i am really sure quartus is installed.. 

 

Whrn i try with the .bat in the demonstration that comes with the System CD it they work fine or that it is what i believe.. 

 

thank you
0 Kudos
9 Replies
Altera_Forum
Honored Contributor I
191 Views

I have the same problem. 

 

My workarround is to manually program the DE0_Nano from the \Tools\DE0_Nano_ControlPanel folder by  

quartus_pgm.exe -m jtag -c USB-Blaster[USB-0] -o "p;DE0_Nano_ControlPanel.sof" 

 

and than start the control panel by DE0_Nano_ControlPanel.exe 

 

The control panel works fine then.
Altera_Forum
Honored Contributor I
191 Views

thanks , yes i have to manually download the .sof and then do a double click to the .exe to execute the control panel

Altera_Forum
Honored Contributor I
191 Views

Hello, 

I just get the DE0-Nano too. It works fine, I don't use anything from the DVD, I downloaded the newest package fro Terrasic. After Installing Quartus, I installed the driver and the Control panel work.
Altera_Forum
Honored Contributor I
191 Views

Thank you " TOK ". I did as you wrote and it works. Thank you again for your help.  

Altera_Forum
Honored Contributor I
191 Views

I recently aquired a DE0-Nano board and I find the same problem ("error make sure quartus is installed") but I can't follow your suggestion. I can't download the .sof file since the PC does not recognize the on-board blaster. In the tools/programmer panel, I click in "Hardware Setup" and I get an error ("attempted to access jtag server -- internal error code 82 occurred"). 

Although I've installed the driver and, if I look in the Device Administrator the USB is detected as "Altera USB-Blaster", I can't make the Quartus II soft detect the board. 

This page (http://www.altera.com/support/kdb/solutions/rd04042011_1000.html) suggest a solution regarding a reset on the altera jtag server, but I don't find it where It should be. 

 

I use Quartus II 11.0 with control panel 1.0.2 on a windows 7 64 bits platform. 

 

Thank you.
Altera_Forum
Honored Contributor I
191 Views

Error 82 is a failure to access the jtag server via its TCP port. 

 

I would start by using jtagconfig to check that the basic connectivity is there - from a command window which has Quartus on its path type `jtagconfig --debug` and it should give you a full list of what's on each JTAG chain. Once this is working you know you have a correct Quartus install and can start trying from other tools.
Altera_Forum
Honored Contributor I
191 Views

Thank you, I was not able to follow your instructions since the jtag server didn't even appear in the services tab of the Administrative tools, so no jtag's were detected. 

I fixed the problem (thanks to some TerasIC help) by installing the stand alone programmer, which in turns re installs the jtag server. With this done, Quartus II began detecting the jtag blaster and the control panel worked ok (after blasting the .sof file). 

 

Than kyou
Altera_Forum
Honored Contributor I
191 Views

how to i do this: 

quartus_pgm.exe -m jtag -c USB-Blaster[USB-0] -o "p;DE0_Nano_ControlPanel.sof"
GCRAW2
Beginner
191 Views

Since it says "..can't find the path folder..." i just copy the jtag_client.dll to the control panel folder and works. this is because the version 18 of quartus has evolved and the control panel software of altera no!. so, next time, please Aletra, use an ini file. i know is old but is easier.

Reply