FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5157 Discussions

Problem installing USB Blaster driver

Altera_Forum
Honored Contributor II
907 Views

Hello, 

 

I am running Quartus II web edition, version 12.0sp2, on Windows 7. 

 

I have just purchased the MaxII Micro kit development board, and on plugging it in to USB port it behaves correctly, with LEDs flashing as described in the User Manual. The manual says that I must install the USB Blaster driver software before I can communicate with it, which seems sensible. So I go to the Altera download centre and select USB-Blaster Driver for Windows 7. It says there that when I plug the USB-Blaster download cable into the PC, the "Found New Hardware" dialog box will appear, and I should then follow rest of instructions. 

However, the "Found New Hardware" dialog box does NOT appear on my PC, and I don't know how to proceed. This happens however I set the DIL switches on the Micro kit board. 

 

The USB Blaster driver files (dll files) are on my system in the correct place, i.e: 

C:\altera\12.0sp2\quartus\drivers\usb-blaster\x64 

also same with \x32 

 

I assume that the files being there is NOT the same as being installed. 

So how do I go about installing? 

 

Many thanks for any help.
0 Kudos
3 Replies
Altera_Forum
Honored Contributor II
130 Views

There was a problem using the web edition of version 12.0 on Win 7, there is a lengthy thread about it. I think I downloaded an earlier version of the standalone programmer software and that installed drivers that worked with 12.0. Version 12.1 works OK, download that.

Altera_Forum
Honored Contributor II
130 Views

Have downloaded v 12.1, and now everything is working as it should (until the next obstacle!) 

Many thanks for your help Leon.
Altera_Forum
Honored Contributor II
130 Views

Glad you got it working. I suppose that Altera got so much stick over the problems with the USB Blaster and 12.0 that they made sure that it worked OK with 12.1.

Reply