FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
Announcements
Intel Support hours are Monday-Fridays, 8am-5pm PST, except Holidays. Thanks to our community members who provide support during our down time or before we get to your questions. We appreciate you!

Need Forum Guidance? Click here
Search our FPGA Knowledge Articles here.
5239 Discussions

Programming Cyclone 5CEBA2F17 with SVF fails

JDowd3
Beginner
200 Views

I have created an SVF file using the Quartus programmer. I have a CPU then the FPGA in the JTAG chain. When I run the SVF file using JTAG's SVF player I see my LEDs light briefly (so the pins are going to 0V) but the programming fails and my FPGA does not start. The failure is because a check on the TDO is returning all 0s and the SVF file expects a bit set.

 

Are there any requirements on the PCB config pins to allow JTAG programming? Is there any other reason why programming could fail?

 

Thanks for your help.

 

SDR 865 !line 20769 TDI ( 0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000 ) ! TDOexpected ( 0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000080000000000000000000000000000000000000000 ) MASK ( 0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000080000000000000000000000000000000000000000 ) ! FAIL ( 0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000080000000000000000000000000000000000000000 ) TDO ( 0000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000 ) ;

 

0 Kudos
3 Replies
ShafiqY_Intel
Employee
149 Views

Hello,

 

May I know which Quartus version you are using?

And, which download cable you used?(i.e usb blasterII, etc)

 

 

Thanks

JDowd3
Beginner
149 Views

Hello and thanks for answering. I had closed this case because I managed to fix it.

 

I am still using Quartus 14. I am using a third-party JTAG test tool to do the programming.

 

It did not work when I added the extra device just by specifying the IR length. I don't know if it was something I did wrong, but it works now that I have imported the BSDL file for the other device.

 

Thanks, John

ShafiqY_Intel
Employee
149 Views

Hi John,

 

Thanks for get back.

Your answer would help other users in future.

 

Thanks

Reply