FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits

cyclone V FPGA

Arvinda
Beginner
549 Views

Hello all,

 

I am using Cyclone V FPGA and flashROM configuration device in my board.

sometimes FPGA configuration time is extending compared to normal configuration time. 

FPGA is retrying to get configuration data from flashROM when configuration time extended.

can anyone explain why FPGA retry to get configuration data from flashROM?

 

 

Regards

Arvinda

0 Kudos
5 Replies
NurAiman_M_Intel
Employee
520 Views

Hi,


  • What is the flash used?
  • What is the Quartus version?
  • Is this happening only on this FPGA and board?
  • Any error shown?


Regards,

Aiman


0 Kudos
Arvinda
Beginner
516 Views

Hello Aiman,

 

Thank you for the reply.

 

I am using 

S25FL064P0XMFI003 flash from Cypress.

Quartus II 14.1 version.

happening only in this board. producing thousands of board..

 

please check the attached files.

normal : without error, normal configuration.

error : fpga switching cs signal high low when configuration is going on. 

signal order

cs

clock

SI

SO

 

Regards

Arvinda 

 

0 Kudos
NurAiman_M_Intel
Employee
462 Views

Hi,


  • Has this board been working fine before sudden failure?
  • can you use the latest version of Quartus?
  • To use 3rd party flash, you will need to use Generic serial flash interface IP

https://www.intel.com/content/www/us/en/docs/programmable/683419/22-2-20-2-1/user-guide.html


Regards,

Aiman


0 Kudos
NurAiman_M_Intel
Employee
436 Views

We do not receive any response from you to the previous answer that I have provided. This thread will be transitioned to community support. If you have a new question, feel free to open a new thread to get the support from Intel experts. Otherwise, the community users will continue to help you on this thread. Thank you


0 Kudos
Arvinda
Beginner
431 Views

using generic flash IP and this time problem is not related to quartus software.

FPGA AS configuration is delaying when board temperature is high.

till 30deg no delay observed in AS configuration but after 30deg FPGA AS configuration delay is increasing with temperature.

what might be reason behind this temperature dependency.

 

producing thousands of boards and only in one board this problem is detected.

no problem with circuit, no problem with power levels.

 

Regards

Arvinda Kumar

0 Kudos
Reply