Community
cancel
Showing results for 
Search instead for 
Did you mean: 
dkaws
Novice
528 Views

jtagconfig not working properly.

I'm using quartus 13.1 installed on ubuntu 12.04 (32-bit) in a Oracle VM. When I tried to connect my cyloneV SoC development kit some times it works but most of the time it's not working.it's very random :( . I used sudo killall -9 jtagd and restart the jtagd but the issue remains. But for my cycloneII board it's working fine. I tried cycloneV in my host OS (win10 with quartus 17.1) and the device is detected properly. unfortunately I cannot change my environment (I must use ubuntu 12.04 in VM ) So anyone know how to solve this please help me.

0 Kudos
15 Replies
JohnT_Intel
Employee
250 Views

Hi,

 

May I know what is the error message you observed? How do you connect the JTAG port?

dkaws
Novice
250 Views

I don't get any error message. using USB-BlasterII cable.

JohnT_Intel
Employee
250 Views

Hi,

 

Is the blaster detected or FPGA device not detected?

dkaws
Novice
250 Views

blaster is detected by VM. But when I call jtagconfig command most of the time it won't detect the device. (sometimes it did) I have attached screenshots with this comment.(NB: In those Screenshots I didnt do any harware changes (connect/disconnect the device). only thing I did was called the commands shown in terminal).device is detected by VM.pngCapture1.PNG

JohnT_Intel
Employee
250 Views

Hi,

 

It looks like the issue is happening if you accidentally terminate or exiting the jtagconfig. Could you confirm if you run it normally without terminating it, are you still observing the issue? When you are not able to detect the device, are you seeing the led light?

dkaws
Novice
250 Views

No I don't see and red light. My task is to generate Nios II processor system and upload c program to processor and run it. Even if I successfully upload the system into FPGA I cannot upload my c code most of the time.

JohnT_Intel
Employee
250 Views

Hi,

 

Have you try to reduce the TCK to 6M? If not then could you try to reduce it using this command "jtagconfig --setparam <cable number> JtagClock <frequency><unit prefix>". Example command "jtagconfig --setparam 1 JtagClock 6M "

dkaws
Novice
250 Views

I tried to reduce the TCK as you mentioned but the issue remains. And I tried it with new VM with ubuntu 14.04 64-bit version and Qaurtus 15.0 installed on it and jtagconfig worked fine. (but even for this environment I have reduce the TCK as you mentioned) :(

JohnT_Intel
Employee
250 Views

Hi,

 

May I know if this issue is also happening if you are not using VM? I would like to isolate to see what is actually happening.

 

May I know whenever you use VM, you are seeing hanging issue detecting the blaster or the blaster is detected but not FPGA device?

dkaws
Novice
250 Views

No. jtagconfig is working properly when I connect it to my hhost OS. (Windows 10 with Quartus 17.1). But I didn;t check it for same environment as in VM. Since When I create a new VM with Ubuntu 14.04 and Quartus 15 and call jtagconfig works fine means it's not a issue with VM right?

 

What's happening is when I first connect the FPGA into VM the device is detected with revision no 1034. Then when I called jtagconfig device is detected again with different revision no 0111. and in VM it indicates that the device is attached. (like in this screenshot). device is detected by VM.png

JohnT_Intel
Employee
250 Views

Hi,

 

I think it is due to your system contain multiple Quartus version and it is usually used to load the firmware into the USB-BlasterII. May I know if you have USB-Blaster I?

 

dkaws
Novice
250 Views

I hv uninstalled all other quartus versions and now I have only quartus 13.1 installed in my PC.

 

------------------------May I know if you have USB-Blaster I?----------------------------

In my rules.d/usbblaster.rules file I have the following.

"SUBSYSTEM==\"usb\", ATTR{idVendor}==\"09fb\", ATTR{idProduct}==\"6001\", MODE=\"0666\"" | sudo tee /etc/udev/rules.d/usbblaster.rules -a "SUBSYSTEM==\"usb\", ATTR{idVendor}==\"09fb\", ATTR{idProduct}==\"6002\", MODE=\"0666\"" | sudo tee /etc/udev/rules.d/usbblaster.rules -a "SUBSYSTEM==\"usb\", ATTR{idVendor}==\"09fb\", ATTR{idProduct}==\"6003\", MODE=\"0666\"" | sudo tee /etc/udev/rules.d/usbblaster.rules -a "SUBSYSTEM==\"usb\", ATTR{idVendor}==\"09fb\", ATTR{idProduct}==\"6010\", MODE=\"0666\"" | sudo tee /etc/udev/rules.d/usbblaster.rules -a "SUBSYSTEM==\"usb\", ATTR{idVendor}==\"09fb\", ATTR{idProduct}==\"6810\", MODE=\"0666\"" | sudo tee /etc/udev/rules.d/usbblaster.rules -a

 

JohnT_Intel
Employee
250 Views

Hi,

 

May I know if the issue is happening if you are not running VM?

dkaws
Novice
250 Views

I didn't check it on similar environment as in VM.

But I hv checked it on

1.windows 10 quartus 17.1 (64 bit)

2.ubuntu 14.04 quartus 15.1 (64 bit) in VM

In above environments it worked fine. (EVEN THOUGH I HAVE TO CHANGE THE JTAG CLOCK SETTINGS (AS YOU MENTIONED) ON 2ND ENVIRONMENT.)

JohnT_Intel
Employee
250 Views

Hi,

 

May I know how to you set up the environment? Have you tried using the method in https://www.intel.com/content/www/us/en/programmable/support/support-resources/knowledge-base/soluti...?

Reply