FPGA, SoC, And CPLD Boards And Kits
FPGA Evaluation and Development Kits
6020 Discussions

quartus_hps -c 1 -o I Command error

Chandrashekhar_K
Beginner
528 Views

We are trying to programm QSPI on custom board.

Running the command before programming QSPI.

quartus_hps -c 1 -o I
quartus_hps -c 1 -o S

We are getting the following errors as in the attached screen shot.

Power supply is stable, clock and reset are present for HPS.

Part CycloneV 5CSEBA5SU23

Able to programm fpga section via Programmer IDE.

 


Please help to resolve the error.

 

Labels (1)
0 Kudos
7 Replies
JingyangTeh
Employee
481 Views

Hi


Could you try adding the below paramter to the quartus_hps command:


quartus_hps -c 1 -o PV --boot=18 -a 0x0 <filename>.img


Regards

Jingyang, Teh


0 Kudos
Chandrashekhar_K
Beginner
460 Views

The behaviour is same with the command with  option --boot=18.

We are observing that WARM RESET is generating pulse at regular intervals as in the attached snap shot.   May be because of this the behaviour is observed ?

 

0 Kudos
JingyangTeh
Employee
389 Views

Hi


I notice that you are using the quartus_hps tool to program the QSPI flash.

However you are not entering any address for the command.

Please refer the link below on the usage of the quartus_hps tool.

https://www.rocketboards.org/foswiki/Documentation/BuildingBootloaderCycloneVAndArria10#Cyclone_V_SoC_45_Boot_from_QSPI


Regards

Jingyang, Teh


0 Kudos
Chandrashekhar_K
Beginner
352 Views

Dear Jingyang

Even for this command quartus_hps -c 1 -o S I'm getting the same errors as in the attachments. For chip erase the same error.

Would you please help to understand why the WARM REST is generating a continuous pulse as in previous attachment. The pin is pulled to 3.3V with 4.7K ohm.



0 Kudos
JingyangTeh
Employee
220 Views

Hi


Sorry for the slow response.


In your custom board have you manages to successfully boot into the HPS already?

The reset could be due to command parameter " --boot=18 " which resets the HPS before running the program command.


Regards

JIngyang, Teh


0 Kudos
JingyangTeh
Employee
175 Views

Hi


Any update on this case?

Have you managed to boot into the HPS?


Regards

Jingyang, Teh


0 Kudos
JingyangTeh
Employee
150 Views

Hi


Since there are no feedback for this thread, I shall set this thread to close pending. Please login to ‘https://supporttickets.intel.com’, view details of the desire request, and post a feed/response within the next 15 days to allow me to continue to support you. After 15 days, this thread will be transitioned to community support. The community users will be able to help you on your follow-up questions.

If you happened to close this thread you might receive a survey. If you think you would rank your support experience less than 4 out of 10, please allow me to correct it before closing or if the problem can’t be corrected, please let me know the cause so that I may improve your future service experience.



Regards

Jingyang, Teh


0 Kudos
Reply