Community
cancel
Showing results for 
Search instead for 
Did you mean: 
355 Views

unable to boot my cyclone 5 soc

Jump to solution

I used the ghrd to boot my board. I not able to boot. Uboot says bad kernel image.

 

0 Kudos
1 Solution
Fawaz_J_Intel
Employee
177 Views

Hello,

If you use a custom image, you need to take care of several items:

1- Device tree is up to date.

2- zImage is compiled successfully without any error.

3- rbf file is available in the FAT partition.

4- preloader/uboot should be up-to-date with the FPGA design.

 

Please double check the items below, and let me know if none can help.

 

Thank you

View solution in original post

4 Replies
Fawaz_J_Intel
Employee
177 Views

Hello,

May I know if you are using the default sdcard image file, or you build your custom image? This might be due to either corrupted image, or invalid data read from sdcard.

 

Thank you

177 Views

Hello Fjumaah,

The default sdcard imag is working fine. When I customize my kernel, I cannot boot it. Do you think this might be due to corrupted image?

Please advice.

 

 

Fawaz_J_Intel
Employee
178 Views

Hello,

If you use a custom image, you need to take care of several items:

1- Device tree is up to date.

2- zImage is compiled successfully without any error.

3- rbf file is available in the FAT partition.

4- preloader/uboot should be up-to-date with the FPGA design.

 

Please double check the items below, and let me know if none can help.

 

Thank you

View solution in original post

thanhtung
Beginner
157 Views

Hi all ,

I have followed this guide to build the image of cyclone5: 

https://rocketboards.org/foswiki/Documentation/CycloneVSoCGSRD

And i have enough several items as you said. But when i use putty to boot, it's nothing happend. A board (De1-SoC) have loaded sd card and after that nothing happend in screen.

And i also try using yocto project to build all file and create sd card image with wic file but it's not working too.

is there someone could help me? Thank all.

 
Reply