Gaming on Intel® Processors with Intel® Graphics
Ask questions and get answers, tips/tweaks, and techniques from product and technology experts
425 Discussions

Missing textures from Diablo II: Resurrected with Iris Xe Graphics

Kineax
Beginner
6,243 Views

Dear Intel Support Team

 

I've been playing with my Intel Iris Xe Graphics for a while,  with no issues at all. However, I picked up Diablo II: Resurrected recently, and to a fair amount of surprise, textures seemed to be missing. 

 

This seemed particularly odd, as the game itself was running fine, without noticeable lagging or performance issues.

 

In order to solve this issue, I've tried doing various things, but none seem to work, and I feel as if I'm out of my depth this time. Here are the solutions I tried so far:

1. Updated my graphics driver manually

  1. Downloaded Intel Driver and Support Assistant and (re)updated my driver automatically.
  2. Downloaded Intel Graphics Command Center and changed/overridden the settings there
  3. Cleared the cache of D2R / Battle.net
  4. Tried updating  DirectX

 

The only real solution guide was this (https://community.intel.com/t5/Graphics/Graphics-Glitches-Intel-Iris-Xe-Max-Graphics/m-p/1328088) thread, however, I'm not entirely sure what its author meant under "It made perfect sense for me so that I`ve excluded programs from `My Games` list" in addition to "deleted custom profiles in users\profile\mydocuments\*specificapp*".

 

To answer upcoming questions seen in the previously mentioned thread:

 

  1. I'm not using an external display
  2. The game itself doesn't crash and I do not receive error codes

 

In conclusion, nothing has worked so far, and I'm somewhat out of options on what to do.

 

Thank you for you assistance in advance. 

See the pictures regarding the issue below:

Labels (1)
0 Kudos
5 Replies
Alberto_R_Intel
Employee
6,204 Views

Kineax, Thank you for posting in the Intel® Communities Support.


In order for us to provide the most accurate assistance on this scenario, we just wanted to confirm a few details about your system:

What is the model of your Intel® processor?

What is the model of the motherboard?

If this is a laptop, what is the model of it?

Did "Diablo II: Resurrected" ever work fine before on this specific platform?

If yes, when did the issue start?

Did you make any recent hardware/software changes that might cause this issue?

Which Windows* version are you using?

Does the problem happen at home or in the work environment?

Please attach the SSU report so we can verify further details about the components in your platform, check all the options in the report including the one that says "3rd party software logs":

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-?product=91600


Any questions, please let me know.


Regards,

Albert R.


Intel Customer Support Technician


0 Kudos
Kineax
Beginner
6,194 Views

Thank you for your quick reply.

 

The answers to your questions are below:

1.  Processor 11th Gen Intel(R) Core(TM) i5-1135G7 @ 2.40GHz, 2419 Mhz, 4 Core(s), 8 Logical Processor(s)

2.  BaseBoard Product X513EAN

3. System Model VivoBook_ASUSLaptop X513EAN_S513EA

4.  I have not played Diablo 2 on this laptop before, as I've acquired the hardware recently . Therefore I've only seen this glitchy version of the game here.

5. See answer above

6. I do not believe I did, as everything was quite in tact and working when I recieved the laptop, so there was no need for it

7. Microsoft Windows 11 Pro

8. It does not, no, as Diablo 2 works just fine on my home PC. 

 

I hope these answers might assist you to an extent. Thank you again for your assistance, I'm looking forward to your reply.

 

Kind regards,
Kineax

0 Kudos
Alberto_R_Intel
Employee
6,159 Views

Kineax, You are very welcome, thank you very much for providing that information and the SSU report.


According to the information shown in the SSU document, the graphics driver version currently installed on your computer is 30.0.101.3111, which should be the proper driver for your device since it was customized by ASUS to work with your specific platform.


Since the issue persists after that, even though you mentioned that you tested different driver versions, for testing purposes, please try a clean installation of our latest graphics driver version 31.0.101.3790, following the instructions in the links below:

https://www.intel.com/content/www/us/en/download/19344/intel-graphics-windows-dch-drivers.html?

https://www.intel.com/content/www/us/en/support/articles/000057389/graphics.html


Here you have "Game Troubleshooting for Intel® Graphics Products" with further troubleshooting steps on this matter: 

https://www.intel.com/content/www/us/en/support/articles/000005746/graphics.html


Additionally, we also recommend to get in contact directly with ASUS Support to verify that the latest BIOS version is currently installed on your device or to gather the instructions on how to update it:

https://www.asus.com/support/


Once you get the chance, please let us know the results so we can further assist you.


Regards,

Albert R.


Intel Customer Support Technician


0 Kudos
Kineax
Beginner
6,078 Views

Albert,

 

I solemnly apologise for the late reply. I'm afraid the exam weeks are keeping my attention elsewhere.

 

Regarding my issue, I've completed the reinstallation of the graphics driver, however, the error has unfortunately not been fixed. I may try contacting the Game Troubleshooting Department in the future, but as of now, I've more or less forsaken the chance to play the game.

 

Either way, I am quite grateful for your assistance so far, and I hope you have a lovely week/future career. 

 

Best wishes,

Kineax

0 Kudos
Alberto_R_Intel
Employee
6,064 Views

Kineax, No problem at all, thank you very much for your response.


We are sorry to hear the issue persisted after trying the troubleshooting steps provided previously.


We completely understand your decision and we hope the problem with the game gets fixed in the future.


Any other inquiries, do not hesitate to contact us again.


Regards,

Albert R.


Intel Customer Support Technician


0 Kudos
Reply