Community
cancel
Showing results for 
Search instead for 
Did you mean: 
HJung9
Novice
7,119 Views

Auto scaling issue in Full-Screen Mode with Intel HD 4600 graphics

Jump to solution

There is auto scaling issue in Full-Screen mode ( usually in game ^-^ )

In NVIDIA, it is possible to scale game screen full-fittingly with fixed aspect ratio.

But, In Intel HD 4600 graphics driver... there is no way to fit game screen fully in FULL SCREEN MODE.

In Intel graphics, FIXED ASPECT RATIO only works when I set game resolution max to possible.

( In my system, max possible resolution is 1920 X 1080 and ONLY when I set IT on game, FIXED ASPECT RATIO works. )

But I believe it is not good solution because there are so many classic games having no option to change resolution.

Is it possible to auto scaling like NVIDIA in FULL SCREEN MODE ???

1 Solution
JEFFREY_F_Intel
Employee
1,862 Views

Please checkout newest driver posted for Haswell/Broadwell product generations (Intel HD Graphics 4200/4400/4600/5000 + Iris 5100 and Iris Pro 5200 + Intel HD Graphics 5300, 5500, 6000, Iris 6100, Iris Pro 6200):

Make sure to follow the instructions about selecting preferred scaling option in Intel control panel and checking the "Override Application Scaling" checkbox.

View solution in original post

47 Replies
GSaza
Beginner
324 Views

Chiming in with my same problems. I've noticed this mostly with Civilization V and Civ: Beyond Earth. Other games, like Dishonored, Papers, Please, State of Decay and Valkyria Chronicles all work fine.

https://www.dropbox.com/s/0c3y1aq9a8b1shn/DxDiag.txt?dl=0 Dropbox - DxDiag.txt

BP5
New Contributor I
324 Views

February. Any word on this yet? Has this been resolved in a newer driver release?

JEFFREY_F_Intel
Employee
1,863 Views

Please checkout newest driver posted for Haswell/Broadwell product generations (Intel HD Graphics 4200/4400/4600/5000 + Iris 5100 and Iris Pro 5200 + Intel HD Graphics 5300, 5500, 6000, Iris 6100, Iris Pro 6200):

Make sure to follow the instructions about selecting preferred scaling option in Intel control panel and checking the "Override Application Scaling" checkbox.

View solution in original post

ttpro
Novice
324 Views

The problem is solved for me with version 15.32.21.4222. my config : laptop asus + intel HD 4600 + nvidia 750M (optimus), windows 8.1 up to date.

idata
Community Manager
324 Views

Still not working for me i7-5500U, HD 5500, Optimus with GT 940m. Doesn't matter if Nvidia or Intel though. I think it's a DX11 only issue though.

Kevin_M_Intel
Employee
324 Views
Reply