Showing results for 
Search instead for 
Did you mean: 

Can't Install Intel hd graphics "Intel hd graphics 630"

it seems that after the last windows update, I couldn't install intel hd graphics, so the screen became dimmed I tried many things but it keeps uninstalling itself.

what I did trying to solve this:

1- Checking the BIOS if it blocks the intel driver.


2- remove it completely and install it from "Device Manager" and intel installer, .exe


3- restarting.

4- uninstall windows updates.

5- contacting Intel support, NVIDIA support ( my other GPU, they said to check the bios because it is automatically blocking other GPU if it detects Nvidia first, I tried to change it but nothing happened ), Asus support ( motherboard manufacturer ).

6- Using Intel® Driver and Support Assistant, sometimes it detects the drivers, sometimes nope.

what happens exactly:


I tried to install it and after the restart, the screen become normal, after that it goes back go dim, I checked if Intel HD graphics controller is there, but it seems that after every restart it delete itself " no I don't have a program that freezes the windows" I tried many updates and intel driver installers but they are all the same. what can I do to fix this problem?

intel hd graphics 630


i7 7700
0 Kudos
3 Replies
Community Manager

Hi Sqwaz,



I understand the screen dimmed after Windows® was updated.


I noticed you already tried reinstalling the driver manually but I would like to confirmed if you followed steps available at



Download the zip version of the latest graphics driver



Please let me know your findings.



Allan J.

Did that already, sadly nothing worked out.

Community Manager

Hi Sqwaz,



Thank you for the update.


It seems to be a problem with the latest Windows® update because I tried to install the latest version without updating Windows® and I did not get any issues with the graphics drivers or the screen.


Is there a possibility you can install Windows® on a different partition and check if the latest Windows® update causes this issue?





Allan J