Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
20709 Discussions

Dell HDMI display is no longer detected after BIOS upgrade

Matti1
Novice
1,629 Views

I installed a fresh NUC 11 today. It is a fresh Windows 11 installation and all except USB worked fine (USB was lagging). Therefore I decided to update drivers and BIOS. After the BIOS update my DELL up2716d is no longer detected. I completed installation of all drivers (Ethernet driver fails to update), but this didn't help. One of my HDMI displays is still not detected. So I switched the HDMI cables to see if that would help. No success. Only one of my HDMI displays is working properly.

 

What do I need to do to fix this?

 

NUC 11 Core i5

Dell up2716d display connected via HDMI (not detected after BIOS update)

Second Dell display connected over HDMI to VGA, working fine.

Labels (1)
0 Kudos
1 Solution
Matti1
Novice
1,590 Views

Issue found. The HDMI cable had poor connection. I found the issue after a lot of tests and replaced it with a new cable.

View solution in original post

0 Kudos
4 Replies
Andres_Intel
Employee
1,605 Views

Hello Matti1,

  

 

Thank you for posting on the Intel®️ communities. I am sorry to hear that you are having display issues, I will be happy to help you.  

 

To have a better understanding of the situation, please answer the following questions: 


 

  

Regards,  

 

Andres P. 

Intel Customer Support Technician 


0 Kudos
Matti1
Novice
1,598 Views

Scan done. It was not possible to submit using the "Submit" button due to some issue with the address "https://servicerequestmgmt.intel.com/webticketui/"

 

 I also realize that I should have posted this in the NUC forums...

 

The display is connected HDMI to HDMI.

 

I have also tried to connect it using USB-C with a Deltaco USBC-DP100-K Rev4 adaptor cable, USBC to DP. Display is detected, but it flickers, and USB Mouse connected at the back is laggy and almost impossible to control. USB mouse connected at the front works much better, but the display flickers.

0 Kudos
Matti1
Novice
1,591 Views

Issue found. The HDMI cable had poor connection. I found the issue after a lot of tests and replaced it with a new cable.

0 Kudos
Andres_Intel
Employee
1,550 Views

Hello Matti1,

 

 

Thank you for your response, and all the information provided, it has been really helpful.


Happy to hear that the issue is fixed, so we will close this thread. If you need any additional information, please submit a new question as this thread will no longer be monitored. 

 

  

Regards,  

 

Andres P. 

Intel Customer Support Technician


0 Kudos
Reply