Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
1,268 Views

Display problem with HD Graphics 4600

Acer TC-605 is about 2 years old. Running Windows 10 and recently developed display problem pictured below. Problem has been reproduced on VGA and HDMI ports and multiple monitors/ cables. Driver was updated to 20.19.15.4531. I even replaced the mother board. Any ideas?

0 Kudos
2 Replies
Highlighted
Community Manager
5 Views

Hello Ztampa,

 

 

Thank you for contacting the Intel community.

 

 

Please try installing the latest graphics driver, you can download it here:

 

https://downloadcenter.intel.com/download/26984/Intel-Graphics-Driver-for-Windows-15-40-?product=814... https://downloadcenter.intel.com/download/26984/Intel-Graphics-Driver-for-Windows-15-40-?product=814...

 

 

I suggest you to uninstall the older driver and install this new driver manually; please https://www.intel.com/content/www/us/en/support/graphics-drivers/000005598.html Uninstalling the Intel® Graphics Driver and Intel® Display HDMI/Audio Driver and see how to https://www.intel.com/content/www/us/en/support/graphics-drivers/000005629.html Manually Install an Intel® Graphics Driver in Windows® 10 and Windows 8*/8.1*

 

 

If the problem persists, what changed when this started to happen, what was installed? Was any hardware change, any software installed or new application installed on you system?

 

 

Is the BIOS up to date?

 

 

 

Please let me know how it goes.

 

 

 

Best regards,

 

 

Ivan U.
0 Kudos
Highlighted
Community Manager
5 Views

 

Hello,

 

 

 

I'm following on this post to ask you if your issue has been resolved or if you need further assistance.

 

 

 

Regards,

 

 

 

Ivan U.
0 Kudos