Community
cancel
Showing results for 
Search instead for 
Did you mean: 
LF000
Beginner
2,101 Views

External displays on Lenovo Thinkpad T490 with Intel UHD Graphics 620 are detected, but nothing is shown on them (no signal)

I have a new Lenovo Thinkpad T490 with an Intel UHD Graphics 620 controller and whenever I try to connect an external display through the HDMI port the display is detected, but nothing shows on it. The screen either remains black or a "No signal" message is displayed on it.

 

I am primarily using Ubuntu 19.10, but I tested the problem on Windows 10 and it is the same. The graphic card drivers and the BIOS are up to date. I also tried with different monitors and none of them works (I only tried the HDMI port, though, not the USB-C one because at the moment I don't have a USB-C cable for the monitors).

 

Here's an output from the xrandr command, where the display is detected on the port HDMI-2.

Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 16384 x 16384 eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 309mm x 173mm 1920x1080 60.00 + 59.97* 59.96 59.93 1680x1050 59.95 59.88 1600x1024 60.17 1400x1050 59.98 1600x900 59.99 59.94 59.95 59.82 1280x1024 60.02 1440x900 59.89 1400x900 59.96 59.88 1280x960 60.00 1440x810 60.00 59.97 1368x768 59.88 59.85 1360x768 59.80 59.96 1280x800 59.99 59.97 59.81 59.91 1152x864 60.00 1280x720 60.00 59.99 59.86 59.74 1024x768 60.04 60.00 960x720 60.00 928x696 60.05 896x672 60.01 1024x576 59.95 59.96 59.90 59.82 960x600 59.93 60.00 960x540 59.96 59.99 59.63 59.82 800x600 60.00 60.32 56.25 840x525 60.01 59.88 864x486 59.92 59.57 800x512 60.17 700x525 59.98 800x450 59.95 59.82 640x512 60.02 720x450 59.89 700x450 59.96 59.88 640x480 60.00 59.94 720x405 59.51 58.99 684x384 59.88 59.85 680x384 59.80 59.96 640x400 59.88 59.98 576x432 60.06 640x360 59.86 59.83 59.84 59.32 512x384 60.00 512x288 60.00 59.92 480x270 59.63 59.82 400x300 60.32 56.34 432x243 59.92 59.57 320x240 60.05 360x202 59.51 59.13 320x180 59.84 59.32 DP-1 disconnected (normal left inverted right x axis y axis) HDMI-1 disconnected (normal left inverted right x axis y axis) DP-2 disconnected (normal left inverted right x axis y axis) HDMI-2 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 725mm x 428mm 2560x1440 59.95 + 74.97 1920x1080 60.00* 50.00 59.94 1920x1080i 60.00 50.00 59.94 1280x1440 59.91 1680x1050 59.88 1280x1024 75.02 60.02 1440x900 59.90 1280x960 60.00 1280x720 60.00 50.00 59.94 1024x768 75.03 70.07 60.00 832x624 74.55 800x600 72.19 75.00 60.32 56.25 720x576 50.00 720x480 60.00 59.94 640x480 75.00 72.81 66.67 60.00 59.94 720x400 70.08

I tried multiple resolutions, refresh rates, but nothing works. I am not sure if it is a software/firmware/hardware problem. In case it is a faulty hardware, the laptop is still under warranty so I can replace/repair it, but I would like to rule out the other options before I do so. If anyone can help me in this regard, I would be very grateful. Thank you!

 

Edit: I tried connecting a monitor through the USB-C display port and it works. Now the question is what's happening with the HDMI one.

Tags (1)
0 Kudos
2 Replies
AlHill
Super User
1,780 Views

Use better quality cables, or contact Linux.org for support, or even better, contact Lenovo for support with their laptop and its support of external monitors.

 

Doc

 

LF000
Beginner
1,780 Views

Thank you. I will also try to contact Lenovo.

Reply