Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
17454 Discussions

GLFW error 65542 WGL (OpenGL not supported error) on intel graphics UHD 630 starting Minecraft

varencilator
Beginner
2,649 Views

On a Windows 10 Home edition computer with i5-9600k cpu running intel UHD 630 for graphics. Trying to run Java edition Minecraft (after launching game with minecraft launcher).

error.PNG

Getting this error when trying to start Minecraft. I've tried update, uninstalling/reinstalling intel graphics drivers. (On another note, Windows keeps auto-updating the graphics driver to an older version of intel driver: 27.20.100.9415 when checking for updates)

 

OpenGL extensions viewer says OpenGL version is 1.1

openglextension veiwer.PNG

 It's also kinda weird how the Intel Graphics Command Center doesn't display OpenGL compatibility.

igc.PNG

I know OpenGL is bundled with the specific game but it worked completely fine when I was using a discrete gpu but now I'm getting this error using only the onboard graphics. I've also tried some fixes online saying to put the opengl.dll file directly into a Java's bin folder but the error still happens.

 

Display settings:

display.PNG

SSU and dxdiag report is attached

Labels (1)
0 Kudos
4 Replies
AlHill
Super User
2,636 Views

UHD 630 supports OpenGL 4.6.  Look under core processors here:

https://www.intel.com/content/www/us/en/support/articles/000005524/graphics.html

 

Doc (not an Intel employee or contractor)

varencilator
Beginner
2,634 Views

Sorry I poorly worded my title, I know it does support it but I'm getting an error trying to run opengl in a game with it (minecraft).

AlHill
Super User
2,616 Views

I would check with Microsoft on the error.

Doc (not an Intel employee or contractor)

varencilator
Beginner
2,571 Views

Was able to get it to run by putting OpenGL.dll in System32 folder, OpenGl.dll and opengl32.dll in bin folder of Java installation. Not sure which ones fixed it. OpenGL extensions viewer still says OpenGL version is 1.1 and I suspect the existing opengl32.dll file in System32 is old

Reply