Community
cancel
Showing results for 
Search instead for 
Did you mean: 
DDing4
New Contributor I
7,743 Views

GMA3600 Linux Support.

Hey,

I know that their is practically no Linux support for any PowerVR based chipset. But I have a netbook that came pre-installed with Linux, and because of Intel not being bothered to make drivers that have 3D Acceleration we are stuck using GMA500 2D drivers on outdated systems. It's bad enough that you will not develop drivers despite the community pleading for them, but you will not even release the source code to the existing drivers (like the GMA500 driver). If you made the driver opensource then people from the Linux Community and other developers would most likely be able to develop fully working drivers with 2D and 3D Acceleration.

PLEASE Intel listen to your community. You sell us a product with Linux then abandon us. You cannot tell us to go to the Linux Community because we cannot develop drivers from complete scratch without you opening the sourcecode. You cannot tell us to goto Imagination Technologies (The people who developed the GMA3600 and licensed the chip to Intel) as they say it is Intel's responsibilty.

I urge people in need or these drivers to share your thoughts and show Intel that we need these drivers to use our netbooks.

-Sam,26 interg

71 Replies
DDing4
New Contributor I
274 Views

Again, leo, Most of that is right, except from the fact that the GMA500 also had a PowerVR chip, and that recieved hardly any support. So they havn't learned.

Four powerVR graphics from Intel exist:

-GMA500

-GMA600 - Higher clocked version of previous

-GMA3600

-GMA3650 - Higher clocked version of the previous.

-Sam

DDing4
New Contributor I
274 Views

So, I have Linux running on my N2600 Netbook.

I am currently running Archbang (simply because I really couldnt be bothered installing Arch, may do that at somepoint...) With a combination of the cdv 'bee' bundle and Xorgs generic driver. My DE is OpenBox with tint2, and is extremely usable. I idle at about 3% CPU because the CPU obviously runs X and what not, and I can have about 10 tabs open in Firefox with Youtube playing at about 45% CPU. Profit, i guess.

My netbooks spec:

N2600 Atom CPU

1GB RAM

Nothing else, ie no BCM70015 chip.

Still no 3D Acceleration but it works, for now... The good thing about having Openbox and Tint2 is that it is very customisable, which is good. If you want to run a full DE, like Cinnamon or GNOME, you're out of luck, Openbox is just incredibly lightweight and this shows it haha. Will probably add a Broadcom chip for youtube videos etc, and the cpu load should drop considerably.

I had to fidgit around with it a little, but if anyone wants, I will write detailed instructions for you . Not having 3D is a bummer, but progress is progress.

Goodluck,

-Sam

DDing4
New Contributor I
274 Views

update: I know have sleep/suspend/resume working with brightness controls without any blacklisting or additional kernel bootlines with Kernel 3.10 !

agree11
Novice
274 Views

Hi Sam,

Just thought I'd say well done for getting brightness controls working, not seen that done anywhere else so hope that gives you some more motivation Not sure what else there is to be done at the present time in terms of doing more.

Alasdair

DDing4
New Contributor I
274 Views

Thanks, Its going good. Youtube videos being watchable is a huge plus, however VLC will need a broadcom card, atleast when i tried my DVB-T adaptor.

-Sam

agree11
Novice
274 Views

Just saw Imagination technologies advertising this board, looks like the processor is on a par with an Atom and the graphics should be significantly better, oh and they've provided decent drivers for Linux. Only $150, why can't you go even half the way Intel? I think with a bit of ingenuity it should fit in the original case.

http://hardkernel.com/renewal_2011/main.php ODROID | Hardkernel

DDing4
New Contributor I
274 Views

This ^ .

Sorry for keeping the thread quiet, I have been making modifications to my netbook software side since my last post. I know have almost perfect performance now in Linux .

Maybe it would be a good idea to compile a kernel that I use for others?

HRadi
Beginner
274 Views

Hi sammy

I also have an intel n2600 based netbook.

I have tried to use the thomas001's github repository drivers for the kernel 3.5 .I did a lot of tweaking but my display is flickering , some parameters are different in my asus1015 netbook like i have LVDS-0 on grub cmdline instead of LVDS-1.

i have used fbdev in the xorg.conf file ,still my display is flickering with the cedarview-drm drivers from the thomas repo

i went to fallback on the vesa gma500_gfx in kernel driver , in which my display is stable,but video doesnt play properly, brightness and pm(sleep/hibernate/standby) problems.

I am using ubuntu 12.04.

can you help me with proper direction on how to get my display working fast and als i am able to play movies n vlc.

EDIT:- when i used the cedarview drivers i didnt downgrade my xorg version to 1.11.. just realised it

can you please share your steps to get it working with the 3.10.

my system info.

System: Host:Kernel: 3.5.0-39-generic i686 (32 bit) Desktop: N/A Distro: Ubuntu 12.04 precise

 

Machine: System: ASUSTeK product: 1015CX version: x.x serial:

 

Mobo: ASUSTeK model: 1015CX version: x.xx serial: EeePC-0123456789

 

Bios: American Megatrends version: 1015CX.1101 date: 08/09/2012

 

CPU: Dual core Intel Atom CPU N2600 (-HT-MCP-) cache: 512 KB flags: (nx sse sse2 sse3 ssse3)

 

Clock Speeds: 1: 1600.00 MHz 2: 1600.00 MHz 3: 1600.00 MHz 4: 1600.00 MHz

 

Graphics: Card: Intel Atom Processor D2xxx/N2xxx Integrated Graphics Controller

 

X.org: 1.13.0 drivers: vesa (unloaded: fbdev) tty size: 112x27 Advanced Data: N/A for root

 

Audio: Card: Intel N10/ICH 7 Family High Definition Audio Controller driver: snd_hda_intel Sound: ALSA ver: 1.0.25

 

Network: Card-1: Broadcom BCM4313 802.11b/g/n Wireless LAN Controller driver: wl

 

IF: eth1 state: up mac: dc:85:de:27:97:89

 

Card-2: Atheros AR8152 v2.0 Fast Ethernet driver: atl1c

 

IF: eth0 state: down mac: 50:46:5d:de:22:ef

 

Drives: HDD Total Size: 320.1GB (8.2% used) 1: id: /dev/sda model: ST9320325AS size: 320.1GB

 

RAID: No RAID devices detected - /proc/mdstat and md_mod kernel raid module present

 

Sensors: System Temperatures: cpu: 55.0C mobo: 26.8C

 

Fan Speeds (in rpm): cpu: N/A

 

Info: Processes: 159 Uptime: 2:00 Memory: 568.9/2005.1MB Client: Shell inxi: 1.8.4

 

 

RElki
Beginner
274 Views

Motherboard: Intel D2550MUD2 Mini-ITX

- Manual --> http://www.intel.com/content/www/us/en/motherboards/desktop-motherboards/desktop-board-d2550mud2.htm... http://www.intel.com/content/www/us/en/motherboards/desktop-motherboards/desktop-board-d2550mud2.htm...

- Dual-core Intel Atom CPU 1.86GHz

- Graphics support auto-selected by Xubuntu 13.04, 13.10, and 14.04:

* Kernel module - gma500_gfx (no GMA3650 module exists)

* Xorg video driver - modesetting (no Intel video driver available)

Free advice: Don't wait for Intel. They have written off Cedar Trail.

I would suggest using the latest *buntu distributions and accept the mismatch in video graphics. This essentially works if you do not need high performance or 3D graphics. I am a programmer (not 3D graphics) so this is okay for me. I will probably replace my current motherboard and write off the USD 70.00 I spent on it. I will *not* trust another Intel motherboard without doing extensive research in the future. So, partially, this is my own fault for blindly trusting Intel.

Best wishes, everyone.

Reply