Community
cancel
Showing results for 
Search instead for 
Did you mean: 
gcurr1
Beginner
476 Views

HDMI not working on TVs, only pc monitors

Hi everyone.

 

I've unplugged the HDMI cable from my notebook with the power cable plugged in as well, and it made some static noise.

From that point on, cant get any video signal on any TV, although it does works on computer monitors, which is kind of odd.

 

Already tried different cables, different TVs, installed Linux, went back to Win10, reset my TV, everything.

A local computer service store told me the problem was with the integrated GPU, but as i said it works with monitors.

 

The notebook (ASUS F556U) also has a dedicated GeForce 940m, but the BIOS its very basic and cant get to use that one all the time, it only activates with 3D graphics (i think).

 

Anyone has any ideas whatsoever to what can i do now, before having to buy a new CPU? (its a i7 6500U, not sure ill find something with FCBGA1356 socket anymore).

 

Thanks in advance!!

0 Kudos
31 Replies
AlHill
Super User
110 Views

Well, if it works with monitors, I would immediately try different cables, and TV settings. I know you say you have already done that.

 

But, before you start talking about processor replacement, forget it. Your processor cannot be replaced.

 

I suggest you contact ASUS for support, and that you use ONLY the intel and nvidia driver provided by ASUS.

 

Doc

 

gcurr1
Beginner
110 Views

Hi Al, thanks for the quick response.

 

Yep, already tried different cables and TV settings (i've access the TV service mode and did a factory reset, in case it was something with HDMI handshake config, whatever that is).

But it works perfect for example with the same cable, the same TV, and my girlfriend's notebook (a Lenovo).

 

Your processor cannot be replaced. killed me with this one 😥

 

Currently user the drivers provided by ASUS, nothing, black screen

 

 

gcurr1
Beginner
110 Views

anybody from intel can shed some ligth on the subject?

 

link to the SSU Scan Information

Abigail_G_Intel
Employee
110 Views

Hello gcurr1,

 

Thank you for posting on the Intel Communities.

 

I was checking the report that you have provided and, these are our recommendations:

 

 

  1. Check for any equipment that could be causing electrical noise is near the monitor.
  2. Use straight connections, with no video adapters in between.
  3. There is a Windows* update available, we would recommend you to check with your OEM (Original Equipment Manufacturer) if the update could be performed on your laptop.
  4. This static noise is coming from the TV or the computer when is connected?
  5. I have seen some cases where adjusting the brightness fixes the issue, could you try that? (From the TV Menu)
  6. Besides testing with the customized graphics drivers from your OEM, have you tested with the Intel generic drivers?
  7. I also check the drivers that you have installed on the system and the drivers available for the ASUS Vivobook X556UB and I would recommend you to update the Realtek* High Definition Audio driver available at the OEM website: https://www.asus.com/us/supportonly/X556UB/HelpDesk_Download/
  8. Have you tried updating/uninstalling the Audio High Definition driver listed under the Sound, Video and game Controllers on the Device Manager? (With the TV connected through HDMI at the moment).

 

  • You can open Device Manager doing right-click on the Windows* Start Icon.
  • Split the Sound, video and game Controllers.
  • Right-click on the High Definition Audio Device driver and click Uninstall.
  • Click on Action and select Scan for Hardware Changes.

 

 

Best Regards, 

  

 

Abigail G 

Intel Customer Support Technician

Under Contract to Intel Corporation. 

gcurr1
Beginner
110 Views

Hi Abigail, thanks for the response.

Point by point:

 

Check for any equipment that could be causing electrical noise is near the monitor.

- Tried moving away the speakers for a while, nothing happened.

 

Use straight connections, with no video adapters in between.

- No video adapters, notebook on one end and TV on the other.

 

There is a Windows* update available, we would recommend you to check with your OEM (Original Equipment Manufacturer) if the update could be performed on your laptop.

- Which one? Just updated win10 to build 1903 os version 18362.239, and BIOS to the one on ASUS site for my notebook. Same behavior.

 

This static noise is coming from the TV or the computer when is connected?

- It just did it the time i unplugged the cable and stopped working. No more static noise coming when either plugging or unplugging the HDMI cable. This is what makes me think some hardware thing may have burnt, but with PC monitors working fine i dont know anymore. Maybe there's something on TV voltage specifically that notebook cant handle?

 

I have seen some cases where adjusting the brightness fixes the issue, could you try that? (From the TV Menu)

- Done, nothing changed.

 

Besides testing with the customized graphics drivers from your OEM, have you tested with the Intel generic drivers?

- Yes, already installed Intel version 100.6912 (from https://downloadcenter.intel.com/download/28888/Intel-Graphics-Windows-10-DCH-Drivers?product=80939), no changes. Back to OEM now.

 

I also check the drivers that you have installed on the system and the drivers available for the ASUS Vivobook X556UB and I would recommend you to update the Realtek* High Definition Audio driver available at the OEM website: https://www.asus.com/us/supportonly/X556UB/HelpDesk_Download/

- Using that ones, had no effect.

 

Have you tried updating/uninstalling the Audio High Definition driver listed under the Sound, Video and game Controllers on the Device Manager? (With the TV connected through HDMI at the moment). You can open Device Manager doing right-click on the Windows* Start Icon. Split the Sound, video and game Controllers. Right-click on the High Definition Audio Device driver and click Uninstall. Click on Action and select Scan for Hardware Changes.

- Tried it, nothing changed.

 

Restarted the PC after every driver update. Find attached the last SSU Scan.

Abigail_G_Intel
Employee
110 Views

Hello gcurr1,

 

Thank you for the information provided.

 

With the information that you have provided we are working on your inquiry, please provide with more time while I work on it. I will get back to you as soon as possible.

 

Best Regards, 

 

  

Abigail G 

Intel Customer Support Technician 

Under Contract to Intel Corporation. 

 

gcurr1
Beginner
110 Views

Thanks Abigail, ill be waiting.

 

 

Abigail_G_Intel
Employee
110 Views

Hello gcurr1,

 

I am sorry, I would like to ask you for at least 2 models (brand and model) of the TVs that you have tested with the laptop in order to check the compatibility on HDMI.

 

Best Regards, 

 

  

Abigail G 

Intel Customer Support Technician 

Under Contract to Intel Corporation. 

gcurr1
Beginner
110 Views

Hi Abigail, dont understand what that has to do with anything giving it worked just fine for 2 years, but the one at home its a Samsung UN40J6400AGCFV, tried also with a Sony at work (using another cable), ill post the exact models tomorrow.

gcurr1
Beginner
110 Views

Also Samsung UN40C5000QF and Sony Bravia KD-55X725E

Abigail_G_Intel
Employee
110 Views

Hello gcurr1,

 

Thank you for the information provided.

 

I will get back to you as soon as I can with more updates on your inquiry.

 

Best Regards, 

 

  

Abigail G 

Intel Customer Support Technician 

Under Contract to Intel Corporation. 

Abigail_G_Intel
Employee
110 Views

Hello gcurr1,

 

We are still working on this issue, but we will need the following details:

 

  1. When did the issue come up? After any update of Windows* or driver updates? How long ago did this function stop working with TVs?
  2. Does the Television have any other port that you can test such as DP* or MiniDP*?

 

Please provide me with the Graphics report (while the TV is connected): 

 

  1. Open Intel® HD Graphics Control Panel by pressing the CtrlAlt, and F12 keys simultaneously. Or, right-click the Windows* Desktop, and then click Graphics Properties.
  2. Click Options and Support.
  3. Click Information Center.
  4. Click the Save option on the lower right-hand corner, then select a location to save the .txt file.
  5. You can attach the .txt file on the next post.

 

 

Best Regards, 

 

  

Abigail G 

Intel Customer Support Technician 

Under Contract to Intel Corporation.

 

gcurr1
Beginner
110 Views

Hi Abigail.

 

Not after any update that I recall, plus I did a system rollback at the time with no effect. Guess it stopped working like 3 or 4 months ago by now.

 

It's attached.

 

Thanks.

Abigail_G_Intel
Employee
110 Views

Hello gcurr1,

 

I was checking the report and only contains information about the built-in display (the laptop's display), so I would like to know if you ran the report while having the TV connected?

 

Thank you very much,

 

Abigail G 

Intel Customer Support Technician

Under Contract to Intel Corporation. 

gcurr1
Beginner
110 Views

Hi Abigail, yes, that's the problem, any TV connected its not recognized at all by my notebook.

 

The TV does get some signal (or power at least) as it detects something's connected (listing PC/DVI as an active selectable option on its Source list), but shows No Signal and black screen when that HDMI port is selected.

 

Ill bring the notebook to work next week to show you an SSU and Graphics report while connected to a PC monitor, but that's the situation with any TV.

Wanner_G_Intel
Moderator
110 Views

Hello gcurr1,

 

Thank you for the update.

 

As soon as you have more information, please let us know.

 

We also recommend checking this information:

 

1. Press the Windows Logo Key + P to make sure that the Extend option is selected.

2. Switch the system's default display adapter. Depending on your system model, you can right click your desktop and select this option.

3. You can also go to Device Manager and expand the Display adapters section. Right-click a display adapter, and disable it for testing purposes.

4. Press Windows logo Key + Ctrl + Shift + B to refresh the displays.

 

Wanner G.

Intel Customer Support Technician

Under Contract to Intel Corporation

gcurr1
Beginner
110 Views

Hi Wanner

 

1. Press the Windows Logo Key + P to make sure that the Extend option is selected.

Already tried that, but nothing happens.

 

2. Switch the system's default display adapter. Depending on your system model, you can right click your desktop and select this option.

The only thing I can set its in the NVIDIA control panel, but just seems to be for 3D graphics. Already set up as default both on 3D Settings and PhysX Configuration. Screenshots attached.

 

3. You can also go to Device Manager and expand the Display adapters section. Right-click a display adapter, and disable it for testing purposes.

Yeah, did that already to see if i can force the usage of the dedicated graphic card, no effect. After this: i couldn't configure anything at the NVIDIA control panel, nor use the Windows Logo Key + P (says to try reinstalling drivers or using another graphic card). Apparently ASUS have force all the output through the IGP. Cant disable it in the BIOS either, there's just o option there.

 

4. Press Windows logo Key + Ctrl + Shift + B to refresh the displays.

Done with the TV connected and the IGP both enabled and disabled, got nothing.

 

Ill post tomorrow the results connected to a pc monitor.

 

Thanks!

gcurr1
Beginner
110 Views

posted a file.
Wanner_G_Intel
Moderator
110 Views

Hello gcurr1,

 

Thank you for the update.

 

Wanner G.

Intel Customer Support Technician

Under Contract to Intel Corporation

gcurr1
Beginner
61 Views

Hi Wanner, i've gotten 3 logs:

  • one connected to a PC Monitor via VGA that didn't work,
  • one connected to a PC Monitor via HDMI that didn't work (thought it worked with every PC monitor as it never failed previously, first time trying with this monitor),
  • and a third one connected to a PC monitor via HDMI that worked perfectly.

 

Both SSU and Graphics report.

 

Thanks.

Reply