Community
cancel
Showing results for 
Search instead for 
Did you mean: 
KKema
Beginner
3,172 Views

[HELP] How to solve Black Screen after update intel hd graphic 630 driver software in Windows 10

Please help my problem. I am really desperate because of this issue. I've been looking for some proper answers and made me headache.

I just bought a notebook which is Gigabyte Aero 15X V8 (i7 - 8750H , 16 GB RAM , 512 GB SSD , Intel HD Graphic 630, nVidia GTX 1070 8 GB Max Q). Windows 10.

After updating the intel hd 630 driver software from intel websites , the display went black screen and left me just a mouse pointer. I cannot do Ctrl+Alt+Del . After that , i did hard reset (hold power button for 5 secs) . Turned it on again and it went normal again in terms of the display of the monitor (black screen disappear). Running smoothly into desktop.

At that moment i think it was okay. Then, i checked the device manager status, it says my device is running properly (both , intel hd & nvidia gtx). But, when i wanted to install farcry 5, suddenly the monitor goes black screen again after i clicked my farcry setup launcher application consent (farcry setup.exe -> run as administrator -> yes -> lag about 3 seconds -> black screen appears with mouse pointer). Hard reset again. Display went normal again. YES, Still cannot install my farcry. I tried 3 times.

Not only that, i cannot play PUBG also ,

1. The steam status for PUBG is running (the PUBG font went green in games library , which indicates the program is running) but it doesnt enter the game actually (stays in the desktop) . And ended up with some error information.

2. When I saw and checked the task manager , yes my notebook was loading the PUBG in the system.

Please i need some detail guidance in order to fix this issue. I want to play games in my notebook. This notebook costs me a lot of money tbh

0 Kudos
3 Replies
Stefan3D
Honored Contributor II
453 Views

1)

roll back to the original Intel driver from https://www.gigabyte.com/Laptop/AERO-15X--i7-8750H# support-dl-driver-vga AERO 15X (i7-8750H) | Laptop - GIGABYTE Global

Also Gigabyte offers an undocumented tool named WakeupGPU there. Whatever it's good for

2)

open NVIDIA control panel and force GeForce GPU for demanding games or right-click games' executables and select "run with dedicated GPU"

idata
Community Manager
453 Views

I have same problem, but different style: My laptop is Acer Aspire VX 15 with Intel HD Graphics 630 and Geforce GTX 1050 Ti, 16GB DDR4 RAM and a i7-7700HQ CPU. Recently the 630 made my computer have a eternal frozen screen or black screen with cursor and a weird pixelation looking like "QR-code". Updated the software, both GPU with newest update, uninstalled one of GPU and I still encounter the problem. However, 630 is the only problem form me; The weird black screen APPEARS only after I log-in with iGPU activated. If I go to safe mode and turn the integrated graphics off and restart, then I have no black screen, but CPU does hot multitasking. As far as I can tell, I managed to get the bluescreen that showed the word: VIDEO_MEMORY_MANAGEMENT_INTERNAL, so it has to REALLY to do with Intel HD Graphics 630.

But don't worry, I have still a evidence that is a minidump.

Did anybody look that is caused by a driver called "watchdog.sys"?

I would be happy to hear a solution to us all who have Intel HD Graphics 630

Stefan3D
Honored Contributor II
453 Views

@ E1466

Your issue is described here: https://docs.microsoft.com/en-us/windows-hardware/drivers/debugger/bug-check-0x10e---video-memory-ma... Bug Check 0x10E VIDEO_MEMORY_MANAGEMENT_INTERNAL | Microsoft Docs

Analysis of mini dump looks like this:

Microsoft (R) Windows Debugger Version 10.0.17674.1000 AMD64

Copyright (c) Microsoft Corporation. All rights reserved.

Loading Dump File [C:\Temp\052618-9484-01.dmp]

Mini Kernel Dump File: Only registers and stack trace are available

************* Path validation summary **************

Response Time (ms) Location

Deferred srv*

Symbol search path is: srv*

Executable search path is:

Windows 10 Kernel Version 17134 MP (8 procs) Free x64

Product: WinNt, suite: TerminalServer SingleUserTS Personal

Built by: 17134.1.amd64fre.rs4_release.180410-1804

Machine Name:

Kernel base = 0xfffff803`11218000 PsLoadedModuleList = 0xfffff803`115d52f0

Debug session time: Sat May 26 10:53:13.602 2018 (UTC + 2:00)

System Uptime: 0 days 0:00:20.347

Loading Kernel Symbols

...............................................................

................................................................

................................................................

...........

Loading User Symbols

Loading unloaded module list

........

*******************************************************************************

* *

* Bugcheck Analysis *

* *

*******************************************************************************

Use !analyze -v to get detailed debugging information.

BugCheck 10E, {17, ffff9885a5192000, 0, ffffffffc00002b6}

Probably caused by : dxgmms2.sys ( dxgmms2!VIDMM_GLOBAL::RestoreFromPurge+b2 )

Followup: MachineOwner

---------

nt!KeBugCheckEx:

fffff803`113af680 48894c2408 mov qword ptr [rsp+8],rcx ss:0018:ffff9701`ae92a920=000000000000010e

Reply