Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
18304 Discussions

How to setup anti aliasing / FSAA on Intel Graphics / NUC on Ubuntu ?

mobuche
Beginner
161 Views

Anti aliasing is running perfectly on an application running under Windows 10 on Intel Graphics UHD  series embedded in a NUC.

But the same application running under Ubuntu 22.04 and the same hardware, the anti aliasing doesn’t seem to be available, typically glGetIntegerv GL_SAMPLE_BUFFERS_ARB and/or GL_SAMPLE_BUFFERS return 0 samples.

The main difference is that on Windows, there is a driver configuration application (https://www.intel.fr/content/www/fr/fr/support/articles/000055840/graphics.html) that allow to setup anti aliasing (enable/disable/let app choose), but on Linux it seems that this tool doesn’t exist. 

I’ve also tried via the  xorg.conf files (https://wiki.archlinux.org/title/intel_graphics, https://man.archlinux.org/man/intel.4#CONFIGURATION_DETAILS), butI  didn’t find anything regarding anti aliasing.

 

Thanks a lot for any clues !

 

The chipset and drivers characteristics  are:

 

https://www.intel.com/content/www/us/en/support/articles/000005520/graphics.html

lspci -k | grep -EA3 'VGA|3D|Display'

00:02.0 VGA compatible controller: Intel Corporation CometLake-U GT2 [UHD Graphics] (rev 02)

DeviceName:  GPU

Subsystem: Intel Corporation CometLake-U GT2 [UHD Graphics]

Kernel driver in use: i915

https://linuxconfig.org/graphics-driver-check-on-ubuntu-22-04

glxinfo -B

name of display: localhost:10.0

display: localhost:10  screen: 0

direct rendering: Yes

Extended renderer info (GLX_MESA_query_renderer):

    Vendor: Mesa/X.org (0xffffffff)

    Device: llvmpipe (LLVM 13.0.1, 256 bits) (0xffffffff)

    Version: 22.0.5

    Accelerated: no

    Video memory: 3634MB

    Unified memory: no

    Preferred profile: core (0x1)

    Max core profile version: 4.5

    Max compat profile version: 4.5

    Max GLES1 profile version: 1.1

    Max GLES[23] profile version: 3.2

OpenGL vendor string: Mesa/X.org

OpenGL renderer string: llvmpipe (LLVM 13.0.1, 256 bits)

OpenGL core profile version string: 4.5 (Core Profile) Mesa 22.0.5

OpenGL core profile shading language version string: 4.50

OpenGL core profile context flags: (none)

OpenGL core profile profile mask: core profile

OpenGL version string: 4.5 (Compatibility Profile) Mesa 22.0.5

OpenGL shading language version string: 4.50

OpenGL context flags: (none)

OpenGL profile mask: compatibility profile

OpenGL ES profile version string: OpenGL ES 3.2 Mesa 22.0.5

OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.20

vainfo

libva info: VA-API version 1.14.0

libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/iHD_drv_video.so

libva info: Found init function __vaDriverInit_1_14

libva info: va_openDriver() returns 0

vainfo: VA-API version: 1.14 (libva 2.12.0)

vainfo: Driver version: Intel iHD driver for Intel(R) Gen Graphics - 22.3.1 ()

0 Kudos
3 Replies
Steven_Intel
Moderator
135 Views

Hello mobuche,


Thank you for posting on the Intel® communities.


I am sorry you are having issues with your Intel graphics. I'll be glad to assist you.


In order to better assist you, please provide the following information:


  • Are you using an Intel NUC? If so, what is the model of your NUC?
  • Have you installed the latest graphics available for your system?


Best regards,


Steven G.

Intel Customer Support Technician.


mobuche
Beginner
103 Views

Hi Steven,

Yes it is an Intel NUC, product id=bxnuc10i5fnhm, I guess this one: https://ark.intel.com/content/www/us/en/ark/products/214591/intel-nuc-10-performance-kit-nuc10i5fnhn...

I didn't install the latest drivers because it doesn't seem to be to so easy to do, and the drivers are not so old (22.3.1). Do you know if there are some fixes around this topic since this version ? Of course, if the answer is yes I will try to update the drivers.

Thanks

Best

 

Steven_Intel
Moderator
89 Views

Many thanks for your reply.


The Intel® NUC10i5FNHN does not officially support Ubuntu or any other Linux operating system, therefore, there are no official drivers we can provide.


Our best recommendation is to check on Linux forums for further information/assistance.


Supported Operating Systems for Intel® NUC Products: https://www.intel.com/content/www/us/en/support/articles/000005628/intel-nuc.html


Please keep in mind that this thread will no longer be monitored by Intel. Thank you for your understanding.  


Best regards,


Steven G.

Intel Customer Support Technician.


Reply