Showing results for 
Search instead for 
Did you mean: 

Immediate OpenGL crash on Intel Graphics 520 (with domain account!!!)

I'm developing an application which is also using OpenGL to visualize some 3D graphics.

In the past years (the application is now 20ys old - but still under active development) I often experienced problems with Intel Graphics and OpenGL (never with AMD or Nvidea).

Mostly the problems "disappeared" - probably because the customers gave up or found some solution (one was to deactivate the Intel GPU on computers with an additional Nvidea/AMD GPU, another to try all drivers until one working is found)  ...


Now the issue is back - actually it came up a couple of times in the past year - from notebooks around the world).

Today I received a notebook for the next 2-4 weeks to follow up the issue and to find a solution.

So far the story - and now my observations:


1. I build a small OpenGL application with Visual Studio 2017. I used the "mouse.c" windows sample from

2. Running the application on the notebook (Lenovo T470 with Intel HD Graphics 520) caused an immediate crash on startup wglMakeCurrent(...) - at the same address as my application.


Trying around with the code and reading blog posts didn't help UNLESS I read a topic on the "Graphics" forum (from 2017):

OpenGL driver crash as USER but not as ADMIN


Ok, I gave it a try ...

After activating the Administrator account, I logged in and executed the application: IT'S RUNNING!

Then I tried my application: IT'S RUNNING

Then I created a local user account with Administrators group membership: IT'S RUNNING

Then I removed the local user account from the Administrators group: IT'S (STILL) RUNNING

Then I tried the USER DOMAIN ACCOUNT (with local admin membership): IT'S CRASHING

Then I tried the USER DOMAIN ACCOUNT (without local admin membership): IT'S CRASHING



On my personal convertible (Lenovo Yoga 900 Intel Graphics 520 on Windows 10). I don't experience any problems.


My conclusion:

... is that user/admin rights don't seem to be the problem.

... But probably Windows 7 with domain accounts or domain account settings / group policies ?



* I've attached the Visual Studio 2017 solution/source for the test application (project based from sample)

* Depending on the actual Graphics 520 driver the application crashed immediately or when resizing the window. - Crash on startup - Windows appears and works until window is resized

* Test machine

   Lenovo T470 (Notebook)

   Windows 7 Enterprise

   Intel Graphics 520 with drivers mentioned above (and some other between)

* In the x64\Release folder you can find

   -> The compiled standalone executable (no VS libraries required) including the PDB file

   -> A screenshot of Visual Studio Debugger (showing stack trace, source line, modules and disassembly of crash address)

   -> A minidump with heap for own diagnostic (if you have your drivers PDB you [a developer] should be able to restore the whole stack trace and function names)


If you need more information / assistance please contact me.

I'm very interested to solve the issue - and have access to a notebook to reproduce the error for the next 2-3 weeks.


Best regards


Werner Slabon

0 Kudos
2 Replies

In the meantime we found the settings which seems to cause the crash:

-> The used local account used the default "Windows 7" theme

-> While the domain user account was using "classic" theme

As soon as "classic" theme is selected, the OpenGL applications (both demo and my product) are crashing!

By the was:
​After 1 1/2 weeks there's no response on this issue. Is this forum a intel moderated forum?
​An intel employee redirected me with this issue from "graphics" forum to here - one working day after my initial post.

0 Kudos

i've same problem with this case, i've used dell latitude 7470 with lastest version graphics card drivers and working with CAD software and open open gl but it's work and normally when i opened as local admin and it's not working as an user with domain.

any idea for this case ??


0 Kudos