Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
17452 Discussions

Installation of Intel Graphics WIndows 10 DCH Drivers causes Black Screen Part 2

GarhenChiu
Beginner
678 Views

I have recently re-encountered an issue where I get a black screen after the installation of Intel graphics drivers from both windows update and the VGA rivers from my motherboard website.

 

The first time this occurred, I uploaded this post in search of a way to resolve this issue.

https://community.intel.com/t5/Graphics/Installation-of-Intel-Graphics-WIndows-10-DCH-Drivers-causes...

 

I had previously solved it after reinstalling windows again and having the INF drivers on hand to download first before everything else. This completely solved my issue until one day i was forced to reinstall windows again when I was once again stuck in a black screen after boot after putting my computer in sleep mode. This time installing the INF drivers first did not prevent the black screen from occurring after installing the drivers in windows update and I got the error, "We removed some recently installed update" after going into repair mode. Once again in the device manager under display adapters it only shows Microsoft Basic Display adapter instead of Intel UHD 630.

0 Kudos
7 Replies
Alberto_R_Intel
Moderator
645 Views

GarhenChiu, Thank you for posting in the Intel® Communities Support.


In order for us to provide the most accurate assistance on this matter, we just wanted to confirm a few details about your system:

What is the model of the motherboard?

If this is a laptop, what is the model of it?

Did you make any recent hardware/software changes besides installing the Intel® Graphics driver?

What is the Intel® Graphics driver version that you installed?

Which specific Windows* version are you using?

Does the problem happen at home or in the work environment?

Please attach the SSU report so we can verify further details about the components in your platform, please check all the options in the report including the one that says "3rd party software logs":

https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-?product=91...


Any questions, please let me know.


Regards,

Albert R.


Intel Customer Support Technician


GarhenChiu
Beginner
635 Views

For information about the model of my motherboard I have attached the information in my previous post that I linked previously but I will put it up again here.

specs.PNG

 I have not done too many software changes after reinstalling windows as it was mostly just the INF and lan drivers before I downloaded the windows updates.


The Intel Graphics driver I installed after the windows update failed was the VGA drivers directly from my motherboard's website linked below.
https://www.asrock.com/MB/Intel/B560%20Pro4/index.asp#Download

I am using Windows 10.
This is happening in my home environment.
The SSU report is attached below.

Alberto_R_Intel
Moderator
626 Views

GarhenChiu, Thank you very much for providing that information and the SSU report.

 

I was checking the SSU report and, as you mentioned, " under display adapters it only shows Microsoft Basic Display adapter instead of Intel UHD 630", the SSU shows the same, the Intel® Graphics controller is not being detected.

 

Since the Intel® Graphics controller is not being recognized we cannot confirm if the graphics driver is properly installed. The graphics driver provided by ASRock should be the proper driver for your system since it was tested and validated by them.

 

Just to confirm, after this problem happened, did you try a clean installation of Windows* once again?

 

In order to rule out a possible hardware problem with the Intel® Processor itself, please install and run the Intel® Processor Diagnostic Tool, it does an overall test on the unit and if it passes the test it means it is working properly:

https://downloadcenter.intel.com/download/19792/Intel-Processor-Diagnostic-Tool

 

At this point, we can try a clean installation of the graphics driver provided by AsRock which is version 27.20.100.9127, following the instructions in the link below,:

https://www.intel.com/content/www/us/en/support/articles/000057389/graphics.html

 

And if the problem persists a clean installation of Intel® Graphics driver version 27.20.100.9466:
https://downloadcenter.intel.com/download/30381/Intel-Graphics-Windows-10-DCH-Drivers

 

Also, you can try a system restore to a point when the computer was working properly:

https://support.microsoft.com/en-us/windows/recovery-options-in-windows-10-31ce2444-7de3-818c-d626-e...

 

And then you can also get in contact directly with AsRock to make sure that the latest BIOS version is currently installed or to gather the instructions on how to do that, once you get the chance, please let us know the results:

https://www.asrock.com/support/

 

Regards,

Albert R.

 

Intel Customer Support Technician

 

GarhenChiu
Beginner
605 Views

This issue happened directly after I had reinstalled windows from a usb drive and done nothing but install INF drivers, LAN drivers, and windows updates. 

Here are the results from the Intel Processor tools

GarhenChiu_0-1623290144852.png

Following the clean installation guide, I skipped steps 1-11 because it had already displayed Microsoft Basic Display Adapter in Device Manager.
Both versions of the Intel Graphics driver resulted in the same error of a black screen mid installation.
At that point I restarted my computer and used system restore point both times.

Alberto_R_Intel
Moderator
595 Views

GarhenChiu, Thank you very much for letting us know those results.


Perfect, it is great to know that the Intel® processor passed the test because that indicates there is no hardware problem with it nor with the graphics portion of the unit. The problem could be related to the board itself.


To confirm that information, by any chance, do you have the option to test your Intel® processor on a different board or test your board with a different processor?

Do you have the chance to test a different monitor? This is basically to confirm if there might be a problem with the video port of the board being used, with the cable, or with the monitor itself.


The problem could be also related to the Windows* image installed, and in that case, we suggest to use the link below to install Windows* from scratch or to get in contact directly with Microsoft for further suggestions on the operating system installation:

https://www.microsoft.com/en-us/software-download/windows10

https://support.microsoft.com/


We also suggest to contact ASUS directly to communicate this scenario, to check with them if they have reports from other users with a similar issue, and for further recommendations on this matter, they might have the option to do additional testings on the board.


Regards,

Albert R.


Intel Customer Support Technician


GarhenChiu
Beginner
572 Views

Thank you for suggesting the Windows image, as reinstalling windows with it seems to have solved the issue. I installed it onto my usb drive and after installing inf drivers and lan drivers, the vga driver installation worked as normal. Intel UHD 630 now shows up in my device manager and applications run as normal.

Alberto_R_Intel
Moderator
560 Views

GarhenChiu, You are very welcome, thank you very much for sharing those updates.


Perfect, excellent, it is great to know that the problem got fixed after reinstalling Windows* the problem got fixed and now the VGA driver installation worked as normal.


Any other inquiries, do not hesitate to contact us again.


Regards,

Albert R.


Intel Customer Support Technician


Reply