Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
991 Views

Integrated UHD 630 Graphics Duplicated-Displays Lag

I have a Dell Inspiron 7777 and have an external display (TV) connected via HDMI. When it is configured for Extended display it works perfect. When I have it connected as a Duplicate display the performance of the graphics drops significantly. As examples, pressing the Start button in Windows causes a delay in the menu appearing, and dragging a window around the screen is choppy. Disabling or disconnecting the HDMI cable immediately resolves the issue. I have installed the latest Intel Driver via the Dell website 24.20.100.6287. I tried installing the latest driver form the Intel website but I could not because it said it was not designed for my device.

 

Any help would be appreciated.

 

Nathan

0 Kudos
11 Replies
Highlighted
Moderator
80 Views

Hello NNaho, Thank you for joining this Intel Community. To better assist you, we would like to gather the following information: 1. Run the Intel® System Support Utility and attach the report to this thread. 1.Download the Intel® System Support Utility and save the application to your system. https://downloadcenter.intel.com/download/25293/Intel-System-Support-Utility-for-Windows-?product=91... 2.Open the application and click Scan to see system and device information. The Intel® System Support Utility defaults to the Summary View on the output screen following the scan. Click the menu where it says summary to change to Detailed View. 3.To save your scan, click Next and click Save. You can save the file to any accessible location on your computer. 2. Please include the TV brand/model. 3. Are you using a straight-through connection with a single cable? Wanner G. Intel Customer Support Technician Under Contract to Intel Corporation
0 Kudos
Highlighted
Beginner
80 Views

Thanks for getting back to me! Here are the answers you requested, and the scan results are attached.

 

2 different TVs. Brand Samsung. Models: UN65NU7100 and UN58NU7100

 

I've had it connected both via a direct cable connection and also through a 4 port HDMI Powered Switcher. Both ways of connecting cause the same result.

0 Kudos
Highlighted
Moderator
80 Views

Hello NNaho, This could be related to the TV input lag (e.g. UN65NU7100 : 10 milliseconds). Also, there may be a slight amount of lag from your mouse/keyboard. For testing purposes, please try these steps: 1. Change the refresh rate. 2. If possible, try running a game and let us know if the input lag gets worse. Check if there is a game mode available. 3. Try using other HDMI* cables. Wanner G. Intel Customer Support Technician Under Contract to Intel Corporation
0 Kudos
Highlighted
Beginner
80 Views

Something about the direction of this conversation isn't sounding right to me. The lag isn't on input from the keyboard/mouse or from the TV. The lag is in the display of the graphics on the screen. For example, when I do not have the HDMI cable plugged into the back of the computer the whole screen is very "zippy". The start menu appears very quickly and smoothly. Dragging open windows around is smooth and not choppy. The experience is as expected. The moment I plug anything into the HDMI port and set the display to Duplicate (not Extend) the screen elements/animation get choppy. I unplug the HDMI cable and it is back to normal.

 

For more info, I have the HDMI cable coming out of the back of the computer and plugged into a 4 port HDMI powered switcher. Even if the TV is off the graphics get choppy on the built in display when the cable is plugged into my switcher.

 

Based on this information do you still want me to adjust things? I did check the refresh rates and the monitor is set to 59 and the TV is something in the high 20's.

0 Kudos
Highlighted
Moderator
80 Views

Hello NNaho, Try setting both the Inspiron 7777 and the TV to 59 or 60 hz refresh rate. If the issue persists, please attach a short video showing this issue. Wanner G. Intel Customer Support Technician Under Contract to Intel Corporation
0 Kudos
Highlighted
Beginner
80 Views

Brilliant! Changing the refresh rate for the TV to 59hz solved the issue. Why would the refresh rate of the TV impact the refresh rate on the primary monitor? It almost seems like the setting for the refresh of the monitor was being overridden by the rate on the TV without the user knowing it. Can you tell me what the optimal refresh rate would be for both? Is it 59, 60, 60i or 60p? I currently have them both at 60p. 60i tends to have the image on the TV too low and cutoff by about an inch.

 

Thanks so much!

 

Nathan

0 Kudos
Highlighted
Moderator
80 Views

Hello NNaho, I am glad to hear that the issue was resolved. 60p and 60i describes how frames are made up (Progressive or Interlaced). When using 60i, the graphics card will require less bandwidth. It basically means that you will get a full picture every two frames and quality may be reduced. In this scenario, you can continue using 60p. Regarding the cause of the issue, the faster the refresh rate, the more times the image can update every second and the smoother the image will look. My understanding is that the 60Hz built-in display is trying to accommodate to the lowest performing TV (e.g 24Hz). If you have a slow refresh rate, it make take more time to get an image, and it may be perceived as laggy. Wanner G. Intel Customer Support Technician Under Contract to Intel Corporation
0 Kudos
Highlighted
Beginner
80 Views

Wanner,

 

A related issue has come up that I hope you might be able to help with. Each time the HDMI cable is attached, or the input on the HDMI switch is selected, the refresh rate for the TV jumps back down to 29Hz. which then makes the computer display choppy again (even though the refresh rate in the driver utility shows the display is still at 59Hz). Do you know what can be done to prevent this?

0 Kudos
Highlighted
Moderator
80 Views

Hello NNaho, According to the report attached, you are using Full HD (1920 X 1080) on your computer. What is the resolution set on the TV? Please attach a graphics report with the TV connected to your computer: 1. Right click on the Desktop, and click on Graphics Properties. 2. Click Options and Support, and then click Information Center. 3. Save it. 4. Attach the report. Wanner G. Intel Customer Support Technician Under Contract to Intel Corporation
0 Kudos
Highlighted
Moderator
80 Views

Hello NNaho, If you have any further questions, we will be glad to help you. Wanner G. Intel Customer Support Technician Under Contract to Intel Corporation
0 Kudos
Highlighted
Beginner
80 Views

So, for now the issue as I described it isn't there anymore. I have been working late nights so my memory might have gotten the best of me. I will ping you back if I can reproduce the issue, but as of now the issue is not present.

 

Thanks again!

 

Nathan

0 Kudos