Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
20360 Discussions

Intel Graphic Command Center using port 5000

Patrick_Hume
Novice
5,672 Views

Hi,

 

Not sure how to get this to Intel but their Intel Graphic Command Center software is running on port 5000 which is typically used b Microsoft .NET applications when doing development, rather than have to change all my .NET applications to use another port, could Intel release an update to there Intel Graphic Command Center software to NOt use this port please because a lot of developers are going to have a bad time otherwise 😄

 

Many thanks 

 

P

 

 

21 Replies
Jocelyn_Intel
Moderator
5,585 Views

Hello, @Patrick_Hume  

 

Thank you for posting on the Intel® communities. 

 

Your comment is really important for us and has been added to our records now, we really appreciate your feedback on this matter. 

Apart from this, Is there any assistance you need? Please let us know and we will gladly assist you. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
VicO
Novice
5,576 Views

Count me as one of those .NET developers who are going to have a bad time with this 😠

I just wasted a bunch of my time trying to figure out why my port 5000 was suddenly in use. This needs to fixed ASAP!

Jocelyn_Intel
Moderator
5,513 Views

Hello, @Patrick_Hume  

 

I am sorry to hear that you are having a bad time with this. I have passed the feedback to the proper team and explained the situation that you are going through as a developer for visibility. 

 

Since you have no more inquiries, this thread will no longer be monitored, but if you need further assistance with another matter, please feel free to contact us back and submit a new post. 

 

Have a rest of the week. 

 

Best regards,  

Jocelyn M.   

Intel Customer Support Technician. 


0 Kudos
VicO
Novice
5,469 Views

Hello?!?! Does my response not count towards keeping this thread active?

0 Kudos
Patrick_Hume
Novice
5,463 Views

I have to keep killing the process just so I can do dev work, lucky only need to do it on login/reboot, took me ages to work out what the cause was though

 

so I tried to reserver this port using

netsh int ipv4 remove excludedportrange protocol=tcp startport=5000 numberofports=1

But that didn't work, There is an entire Stackoverflow post with users having similar problems (stackoverflow.com ), most Mac users but has some Windows workarounds. Personally, I didn't want to have to alter my  .NET  projects to run on a different port as I shouldn't have to and I have too many to alter. I just hope they release an update to fix this 🙄

 

0 Kudos
VicO
Novice
5,458 Views

I just went into Services and stopped and disabled the "Intel(R) Graphics Command Center Service" service. This has worked around the defect for me.

0 Kudos
Rantanplan
Beginner
5,434 Views

Done that also, but now on Windows Startup the "Driver & Support Assistant" ist not autostarted anymore.

0 Kudos
Rantanplan
Beginner
5,349 Views

With new version 31.0.101.4672 the service is switched to "automatic" again, port 5000 is still occupied (while this service is running), but the tray icon for "Driver & Support Assistant" seems to be back.

0 Kudos
RLagrange
Novice
5,341 Views

Hi @Jocelyn_Intel , same issue here, the driver update prevent our app to start by taking the 5000 TCP port.

0 Kudos
User-01010101
Beginner
5,156 Views

Hi Jocelyn,

 

I have the same issue, intel shouldn't use port 5000.

Intel really needs to solve this problem, it creates a lot of problems for developers. I didn't have these issues with AMD.

 

Thank you

0 Kudos
RafaStopUsing5000
5,133 Views

Seriously why this ppl decide it was a good idea on using a port that is mainly using for dev work.

Been debugging my Flask app for 3 hours now...

Rantanplan
Beginner
5,017 Views

I'm afraid this is getting forgotten. Maybe closed due to inactivity by us users soon?

No sign this has been accepted as an real issue by Intel, and several driver updates not changing the behavior. Just installed 31.0.101.4887 today with the problem still going on.

What can we do to highlight this issue?

0 Kudos
RLagrange
Novice
5,004 Views

create new topics everyday and flood the forum ?

Patrick_Hume
Novice
4,990 Views

I have logged a support ticket with Intel (Support Request 06014177), I don’t know how long or even if they will reply to it but will post any updates I get here. I should have done this back at the start, but I don’t recall being able to find a way to contact Intel to raise an issue with them until now, I must have somehow missed it... anyway will keep you all apprised.

Seams they have done this before with other commonly used ports https://community.intel.com/t5/Graphics/Intel-graphics-command-center-service-use-port-9001-how-can-I/m-p/719129

 

Will recreate a new message on the forum if I don’t get a reply soon to re-raise the issue with them 

Patrick_Hume
Novice
4,962 Views

The latest reply from Intel:

 

Hello Patrick,

Thanks for your patience.

This is to inform you that feedback has been passed internally to IGCC developers.

Please be informed that the respective port is not assigned permanently to the Microsoft .NET services and other services run on that port as well.

We look forward to your kind reply. In the event that you no longer need our assistance at the moment, please give us feedback to be able to close this case.

Best regards,

Sign in to view and update your request or to get additional information. You can also reply to this email with questions or comments.
Best regards,
Intel Customer Support

 

---------------------------------------------------------------------------------------------

HI Pietro

I would argue that whilst there may be some services that use port 5000 (not that I have ever found any in the 15 years of my .net profession)  they obviously are not commonly used, or do not hold onto the port or use it for long as such applications would be well known and avoided by .net developers (of which there are many). If you read the thread, you can see many .net developers are simply blocking the intel command centre from even running, so simply claiming that it's used by other services is not exactly accurate and doesn’t resolve the issue of those who use Intel products but do not want their work hampered by such an inconvenience. There are plenty of other port numbers the application can use so surely changing to another should not be a mammoth feet for such a prestigious company as intel   

Regards

P Hume

---------------------------------------------------------------------------------------------

Hello Patrick,

Thanks for your feedback.

As mentioned before, your issue has been passed internally to IGCC developers who will work to solve the problem.

We inform you that we will proceed with the closure of the case.

If you have any further questions or need further assistance regarding this report, you can respond to this email within 14 days and the file will be reopened.

Kind regards.

RLagrange
Novice
4,912 Views

How I hate when the support close the ticket saying "information is forwarded"...

Yeah, so even if they changed the tcp port, we will not be notified...

LordofLightning
Beginner
4,546 Views

Count me in with this. I have a whole team that is experiencing this issue. Disabling the service works until a new version comes and reenables the service. I do find it funny that everything appears to work with this service disabled... What is the point of it? And yes, they should look at the .net documentation to know that using port 5000 is a bad idea. Pick something to host kestrel in a much higher ranger intel. 

0 Kudos
VodniDrak
Beginner
4,481 Views

It is actually big security issue, as it listens not only on local host, but on all interfaces too. Intel setup also adds rule to the Windows firewall to allow external access to the port 5000 from whole network!

Only safe solution is to disable the `igccservice` (Service for Intel(R) Graphics Command Center) in Services.

AlHill
Super User
4,476 Views

The real "only safe solution" is to ban intel from doing software development.   Just take a look at IDSA, XTU, Graphics drivers, BT driver trash, etc. etc. etc.

 

They will quietly fix this, and not make any annoucements, just like they did with the trash in the BT installs.

 

Doc (not an Intel employee or contractor)
[Maybe Windows 12 will be better]

0 Kudos
AndrewC1
Beginner
3,413 Views

My development environment stopped working after an Intel drive update. I found the Intel(R) Graphics Command Center) was listening on port 5000 and disabling the Intel(R) Graphics Command Center) in Services resolved the problem.

 

Reply