Community
cancel
Showing results for 
Search instead for 
Did you mean: 
MMand6
Beginner
1,203 Views

Intel HD 4400 native resolution scaling issues DX11

It seems I have a similar problem with the one described here: and here:

My system is a Surface 2 Pro (i5-4300u/Intel HD4400). I tested with the official MS drivers (v10.18.10.3431, but from what I gather from the other posts the issue remains with version 3496 as well, and not limited to surface devices). When desktop is in native resolution (1080p), the only option in the Intel HD control panel for the surface screen is "maintain display scaling". In any other resolution there are 2 additional entries, one of them being Scale Full Screen.

The impact of running games at lower resolution than native is as follows:

- DX 9 games will be scaled full screen (tested with Crusader Kings 2, Europa Universalis 4, etc.);

- DX11 games will not be scaled full screen and will run in a box (Rome II Total War, Civilization V). In order to make it run full screen, I need to switch to any non-native desktop resolution before starting the games, or to actually run the games in dx9 mode.

Are any fixes coming to this issue? Having to change the desktop resolution every time before launching a game is annoying.

0 Kudos
3 Replies
Jose_H_Intel1
Employee
100 Views

Hi Nico88, I suggest contacting the manufacturer of your system for the driver update. Most of the Tablet PCs will require specific drivers that are created by the manufacturer of the system itself. Generic drivers like the one posted on our web site may not work properly with your device.

MMand6
Beginner
100 Views

Thanks for the suggestion. I posted this on Microsoft's forums as well.

However,if you look into the other 2 threads from intel forums that I linked, you will see that the issue is not limited to surface devices, but affects other intel HD4000/4400 users as well.

ROBERT_U_Intel
Employee
100 Views

@ Nico88

Please try the latest driver announced here:

Be sure to enable "Override Application Settings" in the Intel HD Graphics Control Panel.

Thanks

Robert

Reply