Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
20378 Discussions

Intel UHD 750 big issues

Khalilbel
Novice
7,877 Views

Hello I've had a problem for a long time, despite update system and drivers

A problem that does not happen only with some programs, for example, a program Adobe illustrator and RPG in a Box and some games.

 

Fortnite work well no problem and most game play without problem and use pc all the day no problem with surf and youtube watch Problems happen with the same software every time

 

same problem happen when i use yuzu emulator but whene i use old driver 27.20.100.9127. yuzu work well and same thing the app RPG in a box work withou any issue but But the same driver did not solve the problem with the program Adobe illustrator, program is original from adobe

 

I used Unity and blender are working fine

 

The BIOS is also updated to the latest version and I used a driver from the asus website same problem

 

Mostly a driver problem When a problem occurs, the device hangs for a few seconds, then returns to work with a problem on screen

 

A summary of the programs and games that I tried with an old and new driver

driver 27.20.100.9127

Apex : crash With no distortions on the screen

RPG in a Box : Work well

Yuzu : Work Well with VulKan

Adobe illustrator : crash With distortions on the screen

Cemu emulator : Work well

 

driver 31.0.101.4146

Apex : crash With distortions on the screen

RPG in a Box : crash With distortions on the screen

Yuzu : crash With distortions on the screen

Adobe illustrator : crash With distortions on the screen

Cemu emulator : crash With distortions on the screen

0 Kudos
27 Replies
Khalilbel
Novice
6,069 Views

Up 

0 Kudos
Khalilbel
Novice
6,055 Views

same problem with latest beta driver 31.0.101.4148

0 Kudos
AjrAlves
New Contributor II
6,048 Views

Hey, what's your system's specs?

More specifically: what's your RAM speed/latency? Is it OCed?

 

0 Kudos
Khalilbel
Novice
6,042 Views

specs : Intel Core I5 11600K - Motherboard Asus ROG strix Z590-F - RAM Kingston HyperX Fury RGB 8 Gb x 2 3200 Mhz only Overclock it by using XMP Profile from BIOS

CPU not overclocked

All info can be checked from

0 Kudos
Khalilbel
Novice
6,033 Views

i test ram before use Memtest from Asus Bios and its pass no problem

0 Kudos
deepak-kumar
New Contributor I
5,988 Views
0 Kudos
Hugo_Intel
Moderator
5,941 Views

Hello Khalilbel


Thank you for posting on the Intel Communities and for bringing this issue to our attention. I am sorry that there are flickering screen issues and crashes on your system with Intel(R) UHD Graphics 750. Please let's try the following:


  • Reset your BIOS to default settings.
  • Uninstall the current driver using Display Driver Uninstaller. Once uninstalled, update to the latest version 30.0.101.4148.
  • I see that you are using a DisplayPort connection, please let's try an HDMI connection as well as different Display Port cables.
  • If possible, please test a different motherboard.


If the issue persists, could you please let us know if you are using any type of video adapter or dongle?


Best Regards,


Hugo O.

Intel Customer Support Technician.


0 Kudos
deepak-kumar
New Contributor I
5,892 Views

Hi @Hugo_Intel 

This issue also having to me,  
My motherboard was MSI Z590A-Pro

I have the updated my BIOS to the, and i have reseted to my motherboard to the default settings,

my windows updates are uptodate, and i using the latest graphics driver version 30.0.101.4148,
i am using a HDMI Conntection, 
I think the motherboard is not matter because many people having  different motherboard has same issue on the I5-11600K UHD 750 processor, and it does't crash in Linux based PC's only happning in windows based PC,

i have contacted intel live support for this, they emailed me https://community.intel.com/t5/Graphics/UHD-730-crashes-with-Figma-and-WebGL/m-p/1319389 this issue was fixed after the driver version 30.0.100.9955, so they say to clean install this version and check for crash,

but the bug was still present, the screen was not blinking, but the figma was crashing and WebGL was goes to Software mode automatically, I record this test in my mobile phone and uploaded into the youtube, 

please see this video,
https://youtu.be/prHxr0VpCuQ

And also after i again install fresh version of latest driver 31.0.101.4148, the blinking was happening again, with new graphics driver, and also instead of white background crash now it was crashed in black colour with white lines on the top of the screen, and blue colour blinking was continuously happening,  and the beep sound on the speakers (on the below video 0:43) for the first time 
Please see this video,
https://youtu.be/5dU66kRN3mg



The case id of this issue is Case #: 05788113

0 Kudos
Khalilbel
Novice
5,889 Views

Hi @deepak-kumar

same i try old driver 27.20.100.9127 screen was not blinking after crashing on many software and yuzu emulator work very well with that driver

0 Kudos
Khalilbel
Novice
5,909 Views
  • Reset your BIOS to default settings.

try it many time 

do it right now still have same issue

  • I see that you are using a DisplayPort connection, please let's try an HDMI connection as well as different Display Port cables.

try use HDMI cable same issue

  • If possible, please test a different motherboard.

here same problem wirh different motherboard : Intel UHD 750 WegGL crashing blinking the screen

0 Kudos
Khalilbel
Novice
5,907 Views

If the issue persists, could you please let us know if you are using any type of video adapter or dongle?

 

not i don't use any adapter or dongle i use the displayport connection on my motherboard

i'm sure its driver issue

0 Kudos
Hugo_Intel
Moderator
5,857 Views

Hello Khalilbel


Thank you for providing this information. Please let's try the following:


  • If possible try a different monitor.
  • Test the latest driver provided by your motherboard manufacturer, version 30.0.101.3959, and check if the same issue happens.


Best Regards,


Hugo O.

Intel Customer Support Technician.


0 Kudos
Khalilbel
Novice
5,844 Views

Hi @Hugo_Intel

i try different monitor same problem. same software crashing same blinking

yes i try driver provided by motherboard manufacturer nothing change same softwares crashing same blinking

 

but when i use old driver 27.20.100.9127 the crash still happen but screen  was not blinking

0 Kudos
Hugo_Intel
Moderator
5,857 Views

Hello @deepak-kumar


Thank you for all the information that you have provided on this thread. We understand that you have opened an internal case with us, so please feel free to continue posting on the thread, you can also follow the troubleshooting steps that I will be provided on the thread, however, we will continue gathering information and providing personalized troubleshooting through your internal ticket.


Best Regards,


Hugo O.

Intel Customer Support Technician.


deepak-kumar
New Contributor I
5,829 Views

I asked this about in figma support they were saying it is a hardware issue.

this is there response
image.png

Thanks

0 Kudos
Khalilbel
Novice
5,788 Views

This is what I notice when the crash happen and screen start blinking with freesync "ON" Note that the screen frequency changes that's weird

https://drive.google.com/file/d/1qKZsjoGkq-8qZjBf-MQCavDJg94QQESo/view?usp=share_link

 

when the crash happen and screen start blinking with freesync "OFF" thats happen Screen goes black and appears for a few seconds randomly

https://drive.google.com/file/d/1BjxljFMiwqytYm0m0VZm72DNkbDtR_G0/view?usp=share_link

 

Hugo_Intel
Moderator
5,767 Views

Hello Khalilbel


Thank you for sharing these videos and for completing the advised troubleshooting steps. Please let us know the following information:


  • I see that you are using a 144Hz refresh rate, Could you check if the same happens with a lower refresh rate like 60Hz?
  • What is the resolution that you have configured on the system?
  • Does this issue happen on the BIOS screen?


Best Regards,


Hugo O.

Intel Customer Support Technician.


0 Kudos
Khalilbel
Novice
5,737 Views

Hello @Hugo_Intel

yes i use high refresh rate screen. try set it 60hz same issues. try another 60hz screen same issue
i use 1920x1080 resolution
issue not happen on the BIOS screen.
this issue not happen whene use pc when surfing watching youtube. it happen when using the app that i mentioned earlier

 

try use duel monitor HDMI & DP i notice when the crash happen only one screen blinking

0 Kudos
Hugo_Intel
Moderator
5,689 Views

Hello Khalilbel


We will need to look into this issue internally, I would like to ask you for one more report so we can do more research about this behavior. Please create a System report following these instructions. Only use the instruction under Intel Graphics Command Center (Intel GCC):

https://www.intel.com/content/www/us/en/support/articles/000005848/graphics.html


Best Regards,


Hugo O.

Intel Customer Support Technician.


0 Kudos
Khalilbel
Novice
5,679 Views

Hello @Hugo_Intel , I have created a file as you requested

0 Kudos
Reply