Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
20328 Discussions

Intel UHD Graphics 630 many issues

MBorz
Beginner
11,231 Views

I built a new system together. Based on the new Intel Coffe Lake CPU Core i7 8700, with integrated Intel UHD Graphics 630. And the ASUS ROG STRIX Z370-H Gaming Mainboard with newest Bios Version.

Windows 10 Fall Creators Update is up to date. Also, the official Intel driver for the iGPU is installed (15.47.02.4815).

However, many Software is not working properly at all. Like Example Cyberlinks Power Director 15+16 versions (on the current patch stand).

The preview in the timeline hangs constantly, and the image flickers constantly, or momentarily the Display goes completly black for a few seconds, and the software is not operable. Timeline playback stops or programs hang.

Furthermore, creating a BD disc is not possible because an error code is constantly being output. There are different error codes, including "eC0030106".

Before this - with the iGPU Intel HD Graphics 530 - everything ran smoothly.

Cyberlinks PowerDVD 17 (up to date) playback don't look smooth anymore, too.

Other Software which use the iGPU in Hardware didn't run well anymore. It looks like the iGPU Rendering doesn't work anymore.

All my Video Rendering Software like TMPENC didn't run with the Hardware Encoding of the iGPU (Intel UHD Graphics 630) anymore.

I have reinstalled Windows completly new, but nothing changes.

Is there anything changes in the driver ?!

When I use the Nvidia GTX1060 graphics card, there are no such problems at all.

I did not have any problems with all iGPU's before that, which is currently with the Intel UHD 630. The system runs very stable otherwise, even a test with Prime 95 did not cause any problems. Only when the iGPU becomes active, nothing works properly, as it should.

0 Kudos
24 Replies
idata
Employee
5,155 Views

Janami25: Thank you very much for contacting the Intel® Graphics communities. We are sorry to hear the applications are not working properly.

 

 

Remember that the Intel graphics drives are generic, meaning they might or might not work with your system, that is why we always recommend to install the drivers provided by the manufacturer of the board.

 

Please try to install the graphics driver version 4758 from ASUS:

 

https://www.asus.com/us/Motherboards/ROG-STRIX-Z370-H-GAMING/HelpDesk_Download/ https://www.asus.com/us/Motherboards/ROG-STRIX-Z370-H-GAMING/HelpDesk_Download/

 

 

Which video port are you using on the board?

 

 

Any further questions, please let me know.

 

 

Regards,

 

Alberto R

 

0 Kudos
MBorz
Beginner
5,155 Views

Tank you for response.

What does that mean that you should use only the video driver of the motherboard manufacturer? They are mostly partially totally outdated. And if you have problems, you will anyway - also from Intel support - advised to use the driver of the GPU manufacturer. Everywhere and also here in the forum it is recommended to prefer the driver of the GPU manufacturer. Or is the Intel UHD 630 of the Intel Core i7 8700 CPU not fully supported by Intel?!

So far, I have always taken the official driver from Intel, and it has always worked excellently. Only now with the Intel UHD 630 there are problems.

Windows 10 also automatically installs the latest driver provided by Intel. Even forcibly. That's it... Well, I absolutely do not understand these argument.

On the subject...

The Only driver offered by ASUS is just the same, as the Intel Official Driver. Have deinstalled and installed the Driver from ASUS. Same things.

The image output actually works well in 2D mode. But the iGPU encoding does not work with any software. And the decoding / deinterlacing especially of interlaced material looks eg horrible with PowerDVD 17.

If only the CPU renders, everything looks normal.

The playback of 4K video is also absolutely clean. Also, the playback of progressive AVCHD material looks good.

But the rest just does not work as it should. Before that, with the Intel HD 530 had zero problems. Really everything was played very well. And the video editing and hardware transcoding worked. But now anymore.

I tried everything with another motherboard, the MSI Z370 Gaming Plus. After several days of testing but the same occur. Both Systems are very stable with Windows 10. But the iGPU doesn't works correctly as described.

I have only 2 x HDMI 1.4 ports and 1 x VGA on my monitor, the same behavior on both HDMI ports.

Edit:

Do you know the problem since you came up with it right away ?!

I have now tried a DVI> HDMI adapter cable. Output on the mainboard DVI-D, input on the monitor HDMI 1.4. What else is not for testing.

Now, in Cyberlink Power Director 15 + 16, the image no longer turns black, and the preview in the timeline runs smoothly. That looks good.

Unfortunately, I have no sound now, of course, even if I activate in the motherboard Bios Audio via DVI. As I said, I only have 2 x HDMI and 1 x VGA on the monitor. That's why I always used HDMI.

Also because I do not use external speakers. But only the internal, good of the monitor.

In spite of everything, the hardware encoding of the iGPU I still can not use. Either the programs do not (yet) support this, or the driver still has to be worked on.

As I said, the playback of interlaced material just does not look good, if the iGPU is decoding in Hardware.

Edit 2:

after a few Minutes same errors came along, with the DVI>HDMI Adapter....Picture didn't hang in the Timeline, but creating stops permantly and freezes PowerDirector 16.

0 Kudos
idata
Employee
5,155 Views

Janami25: You are very welcome. Thank you very much for providing those updates, we are sorry to hear the problem persists. In regard to your inquiry, yes the Intel® UHD Graphics 630 controller is fully supported, it is just that the manufacturer of the board does some customizations on their driver to work properly and to be fully compatible with your platform.

 

 

Now in order to further assist you with this matter, please provide the information requested on the link below:

 

/message/319025 https://communities.intel.com/message/319025

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

0 Kudos
MBorz
Beginner
5,155 Views

To exclude a defect of the iGPU, I have run a few graphics tests. I've tested Furmark, and also Unigine Heaven, as well as the 3D Mark. There was not the slightest problem here.

I'm assuming that there is a problem with HDMI here. And iGPU hardware encoding does not work properly on all programs I use.

Or they crash regularly.

I will fill out the form.

Thanks in advance.

0 Kudos
idata
Employee
5,155 Views

You are welcome, thank you for sharing those results. Perfect, take your time and once you get the chance please provide that information.

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

0 Kudos
MBorz
Beginner
5,155 Views

Category

Questions

Answers (N/A if not applicable)

Description

Provide a detailed description of the issue

Many Cyberlink Software like Power Director 15 and 16 are freezing, or crashing if creating a BD Movie Disc or if you try to produce a Movie. In the Timeline the Playback hangs, or freezes, and the Display completly flickers or get black screen, for a few seconds. It looks like it refreshes every time. Mostly, the Software Crashes after a few minutes. iGPU Hardware Encoding crashes after 30 seconds, and produces Picture Errors.

PowerDVD 17 Playback with Interlaced Movies stutters, and PowerDVD 17 freezes almost. The Music runs in Background, but there is no Video Playback.

Playback of Interlaced Video stutters very much. If you turn off the Hardware Decoding, all runs smoooth.

Handbrake didn't run with iGPU Hardware Encoding. TMPEG Enc didn't convert Videos with support of the iGPU UHD 630, alsmost they transcode very slow, compared to the Intel HD 530.

Any Video Converter makes trouble, too. It didn't support the iGPU UHD 630 in Hardware anymore, too.

iGPU is connected via HDMI 1.4 to ASUS M279H Display.

Game Benchmark and Graphic Tests runs without Errors. Stress Tests with the Core i7 8700 runs flawlessly, System is always stable.

I additionally tested everything with a Nvidia GTX 1060. There are no problems here.

All the problems always occur. It does not matter if you activate both GPUs or only use the Intel GPU.

All current drivers on the part of motherboard manufacturer and the Intel own were tested.

Windows 10 64Bit and all drivers are up to date. Bios Firmware of the Mainboard, too.

Please place an X to the right of the option showing how often you see this issue using specific steps. (Ex: 'Every few times a game is started it flickers.' <- This would be "Often")<p> 

Always (100%): 100%

Often (51-99%):

Sporadic (20-50%):

Very Sporadic (<20%):<td rowspan="6" style="padding: 0 5.4pt; border-top: none; border-right: 1pt solid windowtext; border-bottom: 1pt solid black; border-left: 1pt solid windowtext; font-style: inherit;" width="1...

0 Kudos
idata
Employee
5,155 Views

Janami25: Thank you very much for sharing that information and for providing those files. At this point we will do further research on this matter in order to try to find a possible solution for this issue. As soon as I get any updates I will post all the details on this thread.

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

0 Kudos
MBorz
Beginner
5,155 Views

With the new Intel Graphics Driver 23.20.16.4849 nothing changes.

0 Kudos
idata
Employee
5,155 Views

Janami25: Perfect, thank you very much for letting us know those results. I just received some updates from the research we are doing on this matter, and we are just wondering if you have the chance to remove the fall creator Windows update and then test the system that way? This is just for testing purposes to confirm if the issue persists after that.

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

0 Kudos
MBorz
Beginner
5,155 Views

Thank you.

No, i couldn't roll back Windows 10 before Fall Creators Update.Then I have to reinstall Windows, with an older image and retest. If I still find an older Windows 10 image (RS2).

Need a little time to do this. I will contact you in any case.

The only thing I can say at the moment is that there was no such problem with the Intel HD 530 Graphics (Intel Core i7 6700K). Not even with the Windows 10 Fall Creators Update.

BG

0 Kudos
MBorz
Beginner
5,155 Views

So, I've just tested everything with the Windows 10 Creators Update (RS2) and everything installed on a second SSD. With current drivers. Unfortunately, the problems are the same as before.

In particular, PowerDVD 17 crashes constantly, the picture is black (or green) before, and the sound then continues in the background. For every interlaced Bluray movie. But also with many progressive videos.

PowerDirector 15+16 has not changed, same issues. The preview in the timeline stops constantly, the picture goes black, then it keeps running, and eventually the program crashes.

And the encoding module of the Intel UHD 630 does not seem to work properly with various programs, or is no longer cleanly supported. Like I already wrote.

As I said, everything ran smoothly with the Intel HD 530.

So video editing and encoding is simply impossible. It may be that 4K works better, but most still use Full HD like me.

Attached are the system files.

So the system is unfortunately not useful for me. I borrowed a Geforce GTX1060 here for comparison. Everything has worked great without exception. But not with the Intel UHD Graphics 630 (Intel Core i7 8700). Supposedly nothing was changed, I now see it differently.

0 Kudos
idata
Employee
5,155 Views

Janami25: Thank you very much for providing those updates and the files. We will continue with the research on this subject. As soon as I get any new details. I will post them on this thread.

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

0 Kudos
idata
Employee
5,155 Views

Janami25: I just received some updates from the research we are doing on this matter and to try to fix this problem, please try to install driver version 4849:

 

https://downloadcenter.intel.com/download/27266 https://downloadcenter.intel.com/download/27266

 

 

If by any chance does not get installed properly, please try to install it manually:

 

https://www.intel.com/content/www/us/en/support/articles/000005629/graphics-drivers.html https://www.intel.com/content/www/us/en/support/articles/000005629/graphics-drivers.html

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

0 Kudos
MBorz
Beginner
5,155 Views

Please read my post from the 08-11-2017.

i've tested and installed this official driver one day after release (.4849) and several times, with setup and manually. Nothing changes.

Or is this a wrong link?

0 Kudos
idata
Employee
5,155 Views

Janami25: Thank you very much for sharing those results, we will continue with our research on this matter, I will post the resolution as soon as possible.

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

0 Kudos
idata
Employee
5,155 Views

Janami25: I just received some updates on this matter, there is a new driver, it is version 4877, please install the driver to try to fix this problem:

 

https://downloadcenter.intel.com/download/27355 https://downloadcenter.intel.com/download/27355

 

 

If the problem persists after that, then we suggest to replace the processor. If you are interested in that option, please get in contact with Intel directly to confirm if the unit is eligible for replacement:

 

Chat support:

 

http://intelsupportchat.force.com/icslivechat/ics_tech_processor_ww_english_Chat http://intelsupportchat.force.com/icslivechat/ics_tech_processor_ww_english_Chat,

 

 

For phone support, depending on your location, you will see the contact information on the links below:

 

EMEA contact information: https://www.intel.com/content/www/us/en/support/contact-support/emea-contact.html https://www.intel.com/content/www/us/en/support/contact-support/emea-contact.html

 

APAC contact information: https://www.intel.com/content/www/us/en/support/contact-support/apac-contact.html https://www.intel.com/content/www/us/en/support/contact-support/apac-contact.html

 

LAR contact information: https://www.intel.la/content/www/xl/es/support/contact-support/lar-contact.html https://www.intel.la/content/www/xl/es/support/contact-support/lar-contact.html

 

North America: Phone Number 1-916-377-7000, Monday – Friday 7:00 AM to 5:00 PM (Pacific Time).

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

0 Kudos
MBorz
Beginner
5,155 Views

PowerDirector 16 and PowerDVD 17 no longer freezes or hangs with this new driver, and everything seems to work. The encoding is also much better.

Unfortunately, I am still not satisfied with the support of 1080 50i (interlaced) H.264 video streams, eg MTS.

It looks like only 25 FPS will be played instead of 50 FPS as soon as the iGPU of the Intel Core i7 8700 (Intel UHD 630) is used. You can see that clearly in PowerDVD 17. That was not the case with the Intel HD 530, the videos were played at 50 FPS.

Not only when playing, but when producing BD discs you can see that clearly. Has the support of interlaced videos with the UHD 630 been considered? Almost all self-made, compliant BD discs (PD16, Magix VDL) must indeed be produced in 1080 50i, and as soon as the iGPU encodes and "plays back", you can clearly see a tightening and flicker. The software for playing does not matter (eg PowerDVD17). Without iGPU support (only CPU) everything looks normal and smooth As I said, with the Intel HD 530 there was not this problem.

Otherwise, this driver is a very big step forward.

0 Kudos
idata
Employee
5,155 Views

Janami25: Perfect, it is great to hear that after installing the 4877 driver version the computer no longer freezes or hangs and everything seems to work fine.

 

 

In regard to your inquiry about the interlaced videos, we will do further research on this matter, as soon as I get any updates I will post all the information on this thread.

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

0 Kudos
MBorz
Beginner
5,155 Views

Thank you, Alberto, for the great job.

As is said, Cyberlink Software runs now very smooth.

I am curious if the problem with the iGPU support for interlaced videos can be improved or corrected. 25 FPS don't look beautiful, instead of 50 FPS.

0 Kudos
idata
Employee
3,274 Views

Janami25: You are very welcome. I just received an update on this matter and most of the performance issues Encoding/Decoding are explained by the applications not being optimized yet to utilize the Cofee Lake HEVC Hardware Encoder/Decoder. So far PowerDVD 17 Ultra and Kodi 17.6 are some of the ones we have successfully tested here. Performance will improve as new applications and drivers updates become available.

 

 

We will do further research in reference to the support of 1080 50i (interlaced) H.264 video streams. Could you please provide us with samples and steps to reproduce this scenario in our lab?

 

 

Any questions, please let me know.

 

 

Regards,

 

Alberto R

 

0 Kudos
Reply