Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
Announcements
The Intel sign-in experience is changing in February to support enhanced security controls. If you sign in, click here for more information.
18306 Discussions

Iris Xe not going above 1280x1024 when using Dell dock

Cenur
Beginner
369 Views

Dear Community,

I recently bought some new hardware, but I'm unable to get it working in the intended way. Although my monitor has a native resolution of 1600x1200 I'm unable to select anything higher than 1280x1024. In the past weeks I did lots of tests, both on hardware and on software side. Based on the results my current assumption is that this seems to be an issue of the Intel Iris Xe graphics driver for Windows 10 or an issue with the drivers required by the USB-C / Thunderbolt ports.

I have no idea what to do next. If this is really a software bug, how to get support? If it's not a bug, what am I doing wrong? I would be really grateful for any kind of support in here! I'm really looking forward to finally use the hardware I bought about 2 months ago with its full potential. But I don't know how to get there 😞

Of course more details are required to be able to assess the situation, so here we go:


Short summary
My new hardware is a Dell Latitude 7420 laptop with an Intel 11th Gen CPU and Iris Xe graphics chip + a Dell WD19TBS Thunderbolt dock. In parallel my father bought a Latitude 7520 with a WD19S dock. It's almost the same hardware except for the connection of the dock (Thunderbolt vs. regular USB-C). The described problem occurs with both laptops and both docks in the same way.

I want to connect my existing monitors to the WD19 dock. These are NEC MultiSync LCD 2180UX with a native resolution of 1600x1200 and DVI input. However, I'm only able to select 1280x1024 as highest resolution in Windows, 1280x960 is offered as preferred solution (I guess due to the 4:3 aspect ratio). I have three of these monitors, but even when only one of them is connected to the dock it does not work as expected. For the sake of simplicity I did all tests with just one monitor connected.

I searched the Internet for similar reports. I found only few entries. For some there was no response or solution at all. Some others where related to issues with 4K monitors, wrongly selected refresh rate or wrong cabling (not using DualLink cables for higher resolutions, etc.). Nothing was applicable to my problem.

The monitors are working nicely with 1600x1200 resolution for many years now using my old hardware (see details below) and when checking the Graphics Control Center the EDID of the monitor is correctly read (1600x1200 is listed as supported resolution). Now I'm stuck.


What I tried so far on hardware side

The hardware I got from my employer is a Dell Latitude 7280 and a WD15 dock. In addition to the new WD19 docks I also bought a Dell DA310 portable USB-C dock. And finally there is a Fujitsu DisplayLink Port Replicator (PR08) with regular USB 3.0 (USB-A) connection. Using this hardware I tried out many different combinations. Here are the results:

  • Latitude 7280 with WD15: 2x 1600x1200 working (with HDMI->DVI and miniDP->DVI cables)
  • Latitude 7280 with WD19: 2x 1600x1200 working (with 2x DP->DVI cables)

  • Latitude 7420 with WD15/WD19 and HDMI->DVI cable: only 1280x1024 possible (single monitor connected)
  • Latitude 7420 with WD15/WD19 and (mini)DP->DVI cable: only 1280x1024 possible (single monitor connected)
  • Latitude 7420 with WD15: 2x 1280x1024 is working (but no higher resolution)
  • Latitude 7420 with WD19: 3x 1280x1024 is working (but no higher resolution)

  • Latitude 7420 with DA310 and DP->DVI cable: 1600x1200 working
  • Latitude 7420 with DA310 and HDMI->DVI cable: 1600x1200 working
  • Latitude 7420 with direct HDMI->DVI cable: 1600x1200 working
  • Latitude 7420 with DisplayLink PR: 2x 1600x1200 working (DP->DVI + DVI->DVI cables)

Firmwares of WD15 and both WD19 docks are up to date.
Firmware/BIOS of Latitude 7420 and 7520 are up to date.


What I tried so far on software side

I'm using Windows 10 21H2 with all available updates installed (as found by Windows update + Dell Command | Update).

I tried many different versions of the graphics chip driver:

  • Version 30.0.100.9955 (latest version provided by Dell)
  • Version 30.0.101.1191 (latest version provided by Intel)
  • All older versions provided on the Dell homepage
  • Latest Beta version provided by Intel

Completely removing any installed driver and rebooting resulted in a fallback to the "Microsoft Basic Display Driver". However, at that moment a resolution of 1600x1200 was suddenly possible - but only one monitor was recognized and there was no 2D/3D acceleration. Few minutes later Windows auto-installed the latest Intel/Dell driver (9955) and the resolution switched down to 1280x1024.

I tried to manually add "1600x1200" as resolution in the Intel Graphics Control Center. I was able to add the entry to the dropdown list, but selecting it resulted in an error message and an automatic switchback to 1280x1024.

To make sure this is not related to a bad pre-installation of Windows by Dell, I installed Windows 10 from scratch onto an USB drive (Windows To Go). But there the behavior is exactly the same. It won't go above 1280x1024 when using any of the docks.

I finally booted a live Linux from an USB drive (Fedora 35), and with this running I was able to use 3 monitors at 1600x1200 with the WD19 dock and 2x 1600x1200 with the WD15. This was the final evidence to me that this seems to be Windows/driver related and has nothing to do with the hardware or cabling.

 

Tool output
Since it was requested in several other threads, I attached the reports of multiple tools to this post (Intel SSU, DxDiag and the Graphics Control Center). In some of the reports it's also visible that the monitor(s) are detected with a native resolution of 1600x1200, but I can't see any reason why it cannot be used.

 

I'm looking forwarding to any kind of input on this topic!

Thanks in advance for any help!

 

Best regards,

Cenur

 

P.S.: The template for submitting a graphics bug is now attached as well.

0 Kudos
1 Reply
AndrewG_Intel
Moderator
331 Views

Hello @Cenur

Thank you for posting on the Intel® communities.


We found another thread describing the same issue and the same hardware/software environment as this one. To avoid duplication of effort, we will close this thread.

We will continue working on this other thread.


Thank you for your understanding.

Best regards,

Andrew G.

Intel Customer Support Technician


Reply