Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance and optimization
Announcements
Welcome to the Intel Community. If you get an answer you like, please mark it as an Accepted Solution to help others. Thank you!
16861 Discussions

Language issues on Graphic Accelerator for Mobile 945 Express

idata
Community Manager
2,951 Views

Hi, hope someone can help? I have an HP laptop with Intel 945 Graphics Accelerator, which I bought in Thailand (as I now live there), Windows XP Pro and all drivers etc were installed when I got it. I had no problem changing the XP and all other drivers to English, but cannot get the Graphic Accelerator control panel in English it still comes up in Thai. I have tried uninstalling and reinstalling forceing an English Setup with the command line setup.exe -l 0009, But that only allows me to see the setup instructions in english. All languages DLL's have been installed in the windows\systems32\lang directory but I cannot find a way to change the language in the Accelerator Control panel. Have scanned registry, ini files and everything I can think of but to no avail. There's probably a very simple answer, but I sure can't find it anywhere at the moment. So if anyone has any ideas I would be truly grateful.

regards

Steve

0 Kudos
11 Replies
HERBERT_H_Intel
Employee
263 Views

is your xp in Thai?

perhaps you can look in the region and language option of control panel. lots of applications check the settings there before installing.

to me the quickest solution would be to reinstall the OS in english or at least do an In-Place upgrade (http://support.microsoft.com/kb/315341). this will keep all your programs and that.

OJ

idata
Community Manager
263 Views

Xp is all in English now but has language pack installed so can be switched to any language. Region and Language settings are set to UK.

regards

Steve

HERBERT_H_Intel
Employee
263 Views

i myself had problems before installing programs on a windows XP which had a MUI applied to it . OS was in English but the MUI was in portuguese, it would not install some programs in portuguese.

Some installations are more sophisticated than others and will look for language information in the 'standard' places while other will dig through the OS and get a 'best guess'.

I would personally reinstall the base OS in english.

OJ

idata
Community Manager
263 Views

Have already tried re-install of XP still can't get English on Graphics Control Panel,

regards

Steve

idata
Community Manager
263 Views

I know how to make the Control Panel change to English. Here it is:

1. Go to the Windows Control Panel>Regional and Language Options

2. Click on the Advanced tab

3. You should have a dropbox designating the language Windows uses for non-Unicode characters. In your case I'm guessing it's set to Thai (or in my case it was Hebrew). Just set it to English. You may have to restart your computer.

That's it.

Now if only someone could figure out a way to change the language of the Intel Graphics Control Panel without tinkering with this setting that would be great, because I actually need the above dropbox set to Hebrew for other programs.

Hope this helps you and somebody helps me.

idata
Community Manager
263 Views

Hi,

Thanks for your reply, have tried that, setting to English Uk and English US, it does have an effect, but instead of Thai characters I then get just ??????? where the letters should be. Any other ideas would be gratefully accepted.

kindest regards

Steve

idata
Community Manager
263 Views

I think I have the same problem:

English Version of Windows 7 RC

All locale settings are England or UK (apart from keyboard which is Norwegian). I am in Norway and for some %$£" reason Intel display drivers are all in Norwegian, no option of language, no choice at install time. $%£"$%£" ridiculous that I;m wasting my time on some auto-magic installer decision.

Intel - how to we change this?

idata
Community Manager
263 Views

hello,

well i have finally come to a solution for the problem.

I have faced all the problems which you guys have narrated like different language ending up with ??????? etc etc.

So enough said. now the solution.

1. Control Panel

2. Region and Languag , Advanced Tab

3. Need to select the language as English US or UK or whatever is desired

( The important part is the box below this there is a list of languages few of them are not selected. If we change the above language to say english and do not click the language in the below boxes we will get a list of ??????? after restarting. So click on the language required.)

4. click on apply to current option.

apply save and exit...

SO YEA I AM PRETTY SURE THIS WILL SOLVE THE PROBLEM ..IF U GUYS FEEL LIKE THANKING SEND ME THANK U GREETINGS HEHE...

eulosis@gmail.com...

Have a good day....

idata
Community Manager
263 Views

hi, thanks for checking this out. unfortunately this fix does *not* work for Windows 7 (RC) - the menus don't exist

idata
Community Manager
263 Views

Tried all that, thanks. Still get ?????????? instead of characters.

idata
Community Manager
263 Views

Hi,

Fixed it at last!

Process was :

1. Control Panel

2. Region and Languag , Advanced Tab

3. Need to select the language as UK or whatever is desired

( In the box below this there is a list of languages few of them are not selected. Click the language in the below boxes on the language required.)

4. click on apply to current option.

apply save and exit...

/servlet/JiveServlet/downloadImage/2-51743-7039/intel help.JPG

 

Then REBOOT!

NEXT: Download the drivers for the chipset from HP NOT INTEL (The Intel ones won't work, but the HP ones are customised for the HP Laptop).

Install the HP drivers.

REBOOT!

Job done!

Steve

Be like a postage stamp. Stick to one thing until you get there.

Guest wrote:

Tried all that, thanks. Still get ?????????? instead of characters.

Reply