Graphics
Intel® graphics drivers and software, compatibility, troubleshooting, performance, and optimization
Announcements
All support for Intel NUC 7 - 13 systems has transitioned to ASUS. Read latest update.
20339 Discussions

SOLVED-New 4K display but nothing higher than 1080 resolution option in settings

d0gg
Beginner
464 Views

I just picked up a 4K UHD display (Samsung U32J590) for my BeeLink SEi8 i5 8279U w/ Iris Plus Graphics 655.
I plugged it in and when it starts up, the bios load screen is in 4K. But when windows 11 loads it is in 1080p. When I go into settings the highest resolution listed is 1920 x 1080 (Recommended).


I have tried several HDMI cords (I used the new one that came with the display first).
I checked to make sure the most current drivers are installed.
I have tried to change the refresh to 30Hz to see if it would add the 4k resolutions (Several places I had read that the model I have will only support 4k @30Hz).

In the intel Graphics Command Center I looked at the Information tab under connected displays. It shows that the display supports up to 3840 x 2160 (50p Hz, 4K).

What should be my next step?

0 Kudos
2 Replies
d0gg
Beginner
443 Views
After quite a bit of searching and reading. I was able to find out what the issue was.

At some point someone made changes to the bios (wasn't me, I bought it gently used). And what ever those changes were it royally messed up the video on the SEi8. Not only was the 4K not working. I also ended up finding out that the second HDMI port was not functioning as well. That turned me in to different direction of searching. Eventually I ended up hitting on the suggestion of setting the bios to optimized defaults.

Set it... Started up..
Both ports work and 4k is functional!!!

So if someone else has the same issue. Consider loading the optimized defaults in the bios!
0 Kudos
Jean_Intel
Moderator
394 Views

Hello d0gg,


Thank you for posting on the Intel️® communities.


We are glad to know you found a solution, thank you for taking the time to share this fix, and hopefully, it may help other community members experiencing similar behavior. 


Since the thread is now solved, we will proceed to close it. Please keep in mind that this thread will no longer be monitored by Intel. 


Best regards,

Jean O.

Intel Customer Support Technician


0 Kudos
Reply