Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Novice
448 Views

UHD 630 Brightness not working

After updating the driver for Intel UHD 630 on a Dell XPS9570, Win 10, the F11 and F12 buttons, which regulate the brightness, are disabled. To have them work - and it appears to me that the 630 too is disabled although Device Manager says otherwise, I must "Disable" and then "Enable" the driver manually.

The buttons work after this. However, when I shut down the laptop and turn it on, the driver and the buttons are disabled again.

Does anyone know how to solve this issue and have the driver and the button work permanently?

Intel(R) UHD Graphics 630

Driver version is 26.20.100.7985

0 Kudos
7 Replies
Highlighted
Novice
445 Views

Hello Rutgard!

You can try reverting the driver, back to when it worked, if you want. This would be done in Device Manager, going to the graphics device, double-clicking, clicking the 'Driver' tab, and clicking 'Roll Back Driver'.

Alternatively, it might be best to make sure you're getting the correct drivers, from the OEM. You said it was a Dell XPS 15 9570, so you should be able to get the drivers from here: https://www.dell.com/support/home/en-us/product-support/product/xps-15-9570-laptop/drivers

Hope this helps, and feel free to reply with any queries, and to let me know how it all goes 🙂

-Emily

Highlighted
Super User Retired Employee
439 Views

Actually, I believe that this is happening because the new driver completely replaced the old driver, thereby upsetting the customizations. What I would try is:

  1. If you haven't already, download the latest driver package available on both the Dell and Intel sites.
  2. Disconnect from Internet. Unplug Ethernet cable and/or disable Wireless.
  3. From Apps & Features Settings app, uninstall the Intel Graphics Drivers entry.
  4. Reboot, keeping Internet disconnected.
  5. Within Device Manager, if no Intel Graphics Driver is installed, go to Step 8.
  6. Right-click on the intel Graphics driver and select Uninstall Device. Choose to uninstall all associated software as well.
  7. Go to Step 4.
  8. Install the graphics driver package provided by Dell.
  9. Reboot, keeping Internet disconnected.
  10. Install the latest graphics driver package provided by Intel.
  11. Reboot.
  12. Reconnect Internet.
  13. Test.

Hope this helps,

...S

Highlighted
Novice
417 Views

Hi Emily,

Thank you for your suggestion. I can report that it was partially successful. When I reverted the driver, the buttons did return to life. I was able to see the slider in the left upper corner, moving up and down. But the display remained unphased and would not change the brightness.

Please see below my response to Scott to see what I did next.

Regards

Rutgard

0 Kudos
Highlighted
Novice
415 Views

Hi Scott,

Thank you for responding to my question. I tried your solution but unsuccessfully. However, I think I will try it again but first I would like to ask you a few questions:

You suggested downloading the drivers from both Intel and Dell sites. I noticed that Dell's driver installation is two years old. It would be the one I have already installed. Intel's driver is the latest version, issued this year in May. Dell's driver is Intel-dedicated (dare I say Intel's own) driver.

I would not have thought of installing both of them. Why do you think it should be done, and why in the sequence you suggested? Dell's driver installation is more for video rendering than for display management, hence my confusion.

Regards,

Rutgard

 

0 Kudos
Highlighted
Super User Retired Employee
401 Views

Rutgard,

As I said, it looked to me as if the customizations done by Dell were being wiped out. This could occur if a version of the driver package prior to those supporting customization retention was installed before the latest package, with this retention support, was installed.

By having you go back and install the latest version of the driver package from Dell, we restore the customizations the Dell provided. Then, by immediately installing the latest version from Intel, you gain the improvements that have subsequently been made by Intel while retaining the customizations made by Dell. Having you disconnect from the Internet for much of this process (you did do this, right?), was to avoid Windows Update possibly stepping in and installing an intermediate version of the package that would wipe out the customizations.

...S

0 Kudos
Highlighted
Novice
377 Views

Yes, I followed your suggestions in full. The stumbling happened when I tried to install the Dell's original package (the latest driver is from 2018). I got "Your OS is not supported." My OS is Win 10 64x, admittedly from 2019 when I bought the laptop.

I think you may be right when suggesting that the Win updates may be to blame. I have them blocked and I updae only urgent security updates, after reviewing them, but Win does have some "pushed" updates that we cannot see, nor stop, and there were some recently, just when this happened to me.

I shall wipe the disk clean and reinstall the OS to factory condition. I see no other option. Looking for the cause could take a lot more time than reformatting and reinstalling everything.

Thank you both Emily and Scott for your advice. Although I was unable to fix the problem, I have learned a few new things and I appreciate the knowledge you have shared.

Highlighted
Novice
367 Views

This may be of interest in trying to resolve this issue. I have just discovered that whole number of my privacy settings have been set to "hidden or controlled by your organisation". Mic, camera, locked screen background, the list goes on.

In a number of forums this message is claimed to be a result of microsoft's forced updates. And here is where it becomes interesting. I thought I knew how to stop the updates (I work in an IT department in a reasonably large company). I was wrong. There are several more ports, which ones I do not know - yet, and microsoft is pushing its updates through these ports into the OS. One of these has been identified as an update for some preview program for pre-releases.

I was able to re-enable mic and cameraby going to:

Computer\HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\AppPrivacy\LetAppsAccessCamera

and change the "value" from 2 to 0 - by deleting the 2 and then doing the same for LetAppsAccessMicrophone

Then I restarted the laptop. That gave me back the mic and cam.

However, the rest (lock screen settings and brightness) are not there. They are somewhere else. I'll post details when I find them. If anyone knows where they are in the registry, I'll appreciate a link. It would save me some time. Family and work are keeping me busy too...

Once I sort these out I'll post results and how to steps, as above.

Regards

Rutgard

Tags (1)