Community
cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Beginner
2,736 Views

WebGL rendering issue with Intel HD Graphics 620 and Windows 10

Steps to reproduce the problem:

1. Open https://sayduck.com/3d/jhqw?starting-variant=0od32t8kalqa https://sayduck.com/3d/jhqw?starting-variant=0od32t8kalqa on a computer with an Intel HD Graphics 620 (or 520).

2. The rendering is completely wrong.

What is the expected behavior?

On a machine with an Intel HD Graphics chipset, the rendering looks like this:

It should look like this:

That correct screenshot was taken from a computer with a different GPU chip. Also, I tried updating the Intel drivers to the latest version with no impact. Disabling hardware acceleration for webGL (ie. use the CPU for rendering) fixed the issue (both on Chrome and Firefox).

What went wrong?

The rendering of WebGL is completely wrong on computers with an Intel HD Graphics (tested with chipset 620 and 520 on Windows 10).

However, no errors are present in any of the major browsers' console, and support should be fine for both webGL and webGL2 on the computer (see attached webGL report files).

Also, the Graphics Feature Status of chrome://gpu has all elements green and "Hardware accelerated" (except for Native GpuMemoryBuffers which is not supported on Windows).

Tags (1)
0 Kudos
7 Replies
Highlighted
Honored Contributor II
49 Views

Re: WebGL rendering issue with Intel HD Graphics 620 and Windows 10

I can confirm broken rendering with Broadwell in Firefox, however its different.

It starts normal then the object vanishes when shader program 2 is loaded.

Also Firefox leaks memory when running this demo.

On MS Edge the demo seems to run fine.

0 Kudos
Highlighted
Beginner
49 Views

Re: WebGL rendering issue with Intel HD Graphics 620 and Windows 10

Hi!

Thanks for the feedback!

I forgot to mention, but that page first loads a PNG preview of the rendering (what is appearing as a good rendering in a first time) while the 3D data is actually loaded in the background. So the behavior you see is logical. However, the fact that the actual 3D rendering is completely empty is very surprising. What kind of GPU do you have?

I guess the memory leak is probably unrelated, but how did you notice it? And do you have any additional information you could share regarding that issue?

0 Kudos
Highlighted
Honored Contributor II
49 Views

Re: WebGL rendering issue with Intel HD Graphics 620 and Windows 10

I have a Gen8 Broadwell HD 5500.

There are some deviations between ig8icd*.dll and your Kabylake's ig9icd*.dll for a while so i'm not surprised about different behaviour.

(I had already complained in the developer forum)

For some reason the memory leak appeared only once. Windows popped up its standard memory warning and then closed Firefox.

0 Kudos
Highlighted
Honored Contributor II
49 Views

Re: WebGL rendering issue with Intel HD Graphics 620 and Windows 10

Today i got hands on a new Broadwell driver so i re-checked this and that.

It appears that i had forced webgl.disable-angle = true in Firefox which works fine with GeForce GPU, but not with Intel iGPU.

After resetting to false the demo appears as intended (with both old and new driver).

0 Kudos
Highlighted
Beginner
49 Views

Re: WebGL rendering issue with Intel HD Graphics 620 and Windows 10

Hi,

Thanks for looking into this, and for sharing the info. At this point though, I'm fairly sure you are reporting a different issue than the one I am seeing, since mine happens on end-user laptops who have default webGL settings.

I'm not sure, but is there a more direct way to contact the Intel technical team than this forum? If webGL isn't rendering properly on their chips, I think it's probably something worth knowing and investigating for them.

0 Kudos
Highlighted
Honored Contributor II
49 Views

Re: WebGL rendering issue with Intel HD Graphics 620 and Windows 10

Silvain schrieb:

I'm not sure, but is there a more direct way to contact the Intel technical team than this forum? If webGL isn't rendering properly on their chips, I think it's probably something worth knowing and investigating for them.

Live chat: https://www.intel.com/content/www/us/en/support/contact-support.html# @1 Contact Support

Otherwise try the developer forum https://software.intel.com/en-us/forums/developing-games-and-graphics-on-intel Developing Games & Graphics on Intel

0 Kudos
Highlighted
Beginner
49 Views

Re: WebGL rendering issue with Intel HD Graphics 620 and Windows 10

Nice, thanks a lot for all your help!

0 Kudos